Lightburn Bridge files going to wrong laser

I have a Mira 7 and Mira 9 with each having their own bridge.

When I turned on the Mira 7 the laser wasn’t connected. So, I did the following:

  1. Checked that I’m connected to wifi - yes
  2. upgraded the latest software of lightburn
  3. unplugged/replugged the bridge
  4. Took ethernet cable out and back in (from bridge and machine)
  5. Hit esc on the laser keypad
  6. Hit reset on the laser keypad
  7. Restarted the mira 7

None of those worked. So I turned on my Mira 9 to see if that bridge was working and it showed laser connected on the lightburn software. Then I switched back to 7 and boom it showed laser connected so I sent a file over and it didn’t go to 7 it went to 9 even though I had switched the bridge to 7. I tried it again and sure enough the file went to 9. I turned off Mira 9 and it shows bridge 7 no longer connected.

The Mira 7 bridge on the back is showing a solid yellow light, the front shows a solid red light

Try this: turn off the Mira 9, but leave the Mira 7 on. Then, select your Mira 7 device profile in LightBurn, and click the ‘Re-scan’ button in the Laser window. LightBurn will start looking for Bridges on your network. If both Bridges are powered on, one option will show a laser connected (it will show as a Ruida controller), and the other will say No Laser Connected. Click the one that is showing a laser connected, then click ‘Select Device’ to close out of that window. You may want to repeat this process with the Mira 9 as well.

I was able to connect via usb. Once I have completed this job, I will follow your advice. Thank you

only one device appeared it said No laser connected

It sounds like the Mira 7’s bridge is not connected to your WiFi network. If you check your available networks, do you see a LightBurn Bridge access point presented as an option? If so, try connecting to that, entering your WiFi credentials to connect it to your network, then scanning again.

If you don’t see the option presented, check to make sure the bridge is powered on - you should see a light indicating that is has power - and check to make sure its SD card is properly seated.

SD Card is in place. I took the cables out and put back into lightburn box (power to wall and usb).
Checked that the machine is set to Lightburn box has solid red light on front on, back has solid yellow light by usb ports. My computer does not show the bridge on my wifi but my phone did. When I clicked the connection on my phone it reads - no internet connection and i’m unsure how to fix that.

Great - that’s progress. It’s normal for the phone to show no internet connection when it’s connected to the Bridge’s network. Open a web browser on your phone and try navigating to - that should take you to a page where you can enter your home WIFI network’s login information.

Once you enter the login credentials, the Bridge should connect to your network and no longer present itself as an available network after a few moments. At that point, you can go back to your PC and try scanning for it in LightBurn, with your Mira 7 device profile selected.

When I click that link it says safari could not open the page because the server stopped responding

Are you still connected to the Bridge network when you navigate to

i do not understand what that means.

Earlier you said you were able to see and connect to the Bridge access network on your phone’s list of available networks. I’m asking whether you were still connected to that Bridge network when you opened a browser on your phone and attempted to navigate to

oh no what i said was - My computer does not show the bridge on my wifi but my phone did. When I clicked the connection on my phone it reads - no internet connection and i’m unsure how to fix that.

You are likely seeing ‘No Internet Connection’ in your phone’s WIFI settings menu. That is OK and expected. The Bridge network you’re connecting to does not provide an internet connection, it’s only presenting a network to allow you to connect directly to the bridge, and enter your home WIFI network login credentials so that it in turn can connect to your local network.

If you see a pop-up message asking you if you’d like to remain connected even though the network you do not have an internet connection, select ‘Use Without Internet.’

Then, try opening a web browser and navigating to - you should see a page like this, where you can enter your WIFI credentials:

I don’t have any pop up message giving me the chance to do anything.

If there’s no pop up message that’s fine. The important thing is that you select the Bridge network from the list of available networks on your phone, ignore anything that says you do not have an internet connection (that’s expected and OK), and then open a web browser on your phone and navigate to so you can enter the login credentials for your home WIFI network.

It may be helpful for you to open the instructions I sent earlier on a separate device (whatever computer you’re running LightBurn on), and follow them as you attempt that process.

Sorry to butt in, but I think you should find out why your local network doesn’t show the bridge. It must be alive or you wouldn’t see the entry on your phones wifi listing.

As @JTR pointed out, it’s not meant for a connection to the Internet… generally the use of a bridge is to cross from one domain to another… from your 192.168.x domain to the Ruida 10.0.3 domain.

It should connect to your domain and be visible on your router. I have a linksys and it has a global view of the devices on the my lan… I can see the PI bridge on that screen. I can also bind it’s mac address to it’s current ip address, ensuring it won’t be issued a different IP when the systems reboot.

Once this is done, the device can be named to reflect where it’s going… such as which mira 7 or mira 8, that you want to use.

It should work on your lan

Good luck


don’t apologize at all - i’ll take all the insight i can get. unfortunately everything you said is over my head lol
I’m going to reply to back to JTR my latest steps feel free to comment/share ideas and I don’t mind if you speak to me as a kid trying to learn lol

I printed the instructions and have step by step them and still can’t find where to insert my credentials. I must be missing/skipping something.

Here is what I’m doing - please review and let me know - Thanks

PC = I see my Mira 7 on the wifi listing (this is what I named it when it previously worked)
I choose it and click connect
Open lightburn - device tab - lightburn bridge - next - Lightburn page click here - that page says This site can’t be reached took to long to respond

Mobile - Settings - wifi - choose mira7 - open safari - enter - safari could not open the page because the server stopped responding.

Thank you for clarifying the steps you’re taking. Did you alter the data on the SD card that came with the Bridge to change the name of the network it presents? If not, the Mira 7 network is not the one you should be looking to connect to. Unless you changed it in the SD card data, that network should be named something like “LightBurn Bridge E4B7.”

If you did change it, it may be worth re-flashing the SD card with the bridge image at this point, to revert that and any other changes you may have made, and then try again.

i wouldn’t know how to alter the data on the sd card lol
i assumed the name changed when I changed it on the initial lightburn setup. i don’t remember where it is but i was able to name it to make it obvious which one was my 7 and which was 9. do you suggest i start completely over and remove the *7 bridge that shows on my device list?