Lightburn camera is way off

I have a lightburn camera I purchased from you. Its been awesome! I love it and it works great. I used my laser yesterday and everything was fine as normal. I know sometimes when I snap a pic and open the lid its got a margin of not perfect but its worked for me.

Today I went to use it and I am over an inch off. The cuts I was lining up at the bottom edge of my wood were cutting 1"+ above where its showing it should.

I made a video and cannot figure out why its not working.

I have done the calibrate camera lens and calibrate camera alignment twice now and still get the same results as I posted in the video below. I made it unlisted but it should work, let me know if its not.

Thanks for your help!

Any ideas? I use this feature regularly but right now I can’t use it properly.

LB version 0.9.11

The only things that can affect the camera alignment are:

  • physical movement of the camera or bed
  • changing the focus height of the bed (different lens, adjusting lens tube height, etc)
  • the Shift / Width / Height controls in the camera control window
  • Running in User origin or Current position instead of Absolute Coords

The first item, the camera being moved, is probably the most common. If you bump the mount and change the angle of the camera even by a degree or two, it’s not likely to be visible to you, but changing the direction that much will affect the alignment a lot.

You shouldn’t have to redo the lens calibration, only the alignment.

Since you said it’s only off on the Y axis, that suggests the lid not opening to the same position, because that wouldn’t affect X, just Y. If you have a camera mount with a hinge along Y, like ours, that would be another possibility.

Any of these seem like the culprit?

Thanks for the reply.

The bed has not moved as I mainly cut 3mm birch 99% of the time. It was working fine yesterday but today its not and off an inch. The camera would not have moved because when I made the acrylic its attached to, I made the holes the exact same size as the screws so it would not move. Nothing has changed with it. The camera itself is two side taped to the acrylic and not going anywhere.

I ran through both settings and neither fixed it :frowning:

I know the lid has some play in it which is why it never gets dropped down or auto lifted up. I am careful in slowly lifting it because I noticed if I let the shocks move it, its not as accurate. Been manually slowly opening it for almost a year now and had great results. Another user posted that the 0.9.11 update messed his up too.

What’s the easiest way to roll back to 0.9.10 and try that just for fun?

Also on the Camera control window, everything is set to on switch and all the width/height/xshift /yshift are all set to 0.0

All releases can be downloaded here:

Wild guess - do you have a pointer offset entered in the device settings?


Pointer offset is not enabled. I will try installing the older version of LB tomorrow. Thanks for trying to help. It worked perfectly for a year and then the next day its off :frowning:

Is it possible that you bumped a homing sensor? The math doesn’t change - the only thing in the system that touches the numbers for the camera are the calibration wizard and alignment wizard.

If you mount the camera to a wall looking at a room, and repeatedly click ‘Update Overlay’, you’ll have a hard time figuring out if if even updated, unless something in the room is moving or you zoom in and can see the camera noise change. I’ve done this many times, just to make sure I wasn’t crazy. :slight_smile:

The only things that can affect the image after calibration is done are the position of the bed, and the position of the camera. Technically, if you change the capture resolution that would affect it too, but not “off by an inch”, more like, “fun-house mirror result”.

It’s very sensitive - If your camera is mounted a meter from the bed (1000mm, or just over 3 feet), and the angle of the camera is changed by one degree, it will shift the image of the bed by 15.7mm.

I don’t know what the homing sensors look like to even check. I am pretty careful putting wood in the machine.

I have removed the camera and put it in another spot, re calibrated both settings and its still completely off. I am not even sure what else to try at this point. Its two sided taped to some acrylic and the acrylic does not move, its held on by the bolts that hold the handle and on tight. It worked perfectly for almost a year and then one day it was completely off.

Did the calibration board change? I made one forever ago and have been using that… maybe its different in the new versions and that is what is causing issues?

Wait… what do you mean by this? Lens calibration, or alignment?

If you ran the alignment wizard to cut the markers and have just been re-using that pattern, that’s quite likely the problem. The laser has to run the job so you know it is exactly in the right place. If you just drop the alignment markers on the bed yourself, they’ll be the right size, but highly unlikely they’d be in the right place or orientation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.