Lightburn cannot connect with Sculpfun S10 - trouble with starting the laser

I just recently purchased a Sculpfun S10 laser engraving machine. I am aware that lightburn is having trouble detecting S10 automatically so what I did is to just add it manually just like what everyone is suggesting. However, I could not make the laser start. I clicked on the “fire” button before clicking the “frame” button but still the laser does not move from its position. Whenever I hover my mouse to the “frame” button, it says “beam disabled” so I went to check the settings to make sure that everything is good to go. I still got the same results - laser did not move at all. Any tips on what I should do next? Really hoping someone could help me with this. Thank you!

Is a port selected in Laser window? If not, select the port that correlates to the laser.

If no appropriate port is available that usually indicates a driver issue.

Hi! Thank you for your response! I really appreciate it. I am really new to this. Just wanted to be sure, is this what you are talking about? How would I know if a port is selected in the laser window? Sorry if it’s a stupid question.

This is the Laser window. Notice the opened pull-down field. That is where you would pick the appropriate port.

Hi! Thank you again for your response! I’ll check it out and let you know!!! appreciate your help!

Here is a guide for setting up LightBurn with your Sculpfun laser: Setting up the software - Diode Laser Wiki Including a step-by-step guide for all settings. Maybe that helps.
Did you set up the mechanics correctly as well? This is not done from factory, you need to adjust quite some bits and pieces: Guide to mechanical adjustments and maintenance - Diode Laser Wiki

Hi! Thank you so much for your help! I was able to successfully make the laser move. Unfortunately, I have one more problem. I could not make the laser actually start engraving. Whenever I click “start” the laser just keeps moving back and forth and a message in the console pops up on my screen: " Your Grbl may not support Variable Power mode (M4)

If your laser does not turn off between cuts,

switch to the GRBL-M3 device

The message you are citing is just a warning. It’s no error. LightBurn can’t detect the grbl version the S10 laser is using. But the S10 supports M4.
What settings did you use for the layer you are trying to engrave? If the power is too low, you won’t see the laser beam.

Hi! It also says “Homing cycle is not enabled in your Grbl settings.” How can i fix this? :frowning: The power is good enough because I can see the laser light whenever I click the “frame” button. The only problem is I really can’t make the laser start engraving.

This message is another warning. This means, you enabled “auto home on startup” in your device settings. Turn that off (in device settings). LightBurn sends the command for a homing cycle, but this is not activated, since the S10 does not have end stop switches.

In the video you posted at Facebook, it was visible that you didn’t fasten the belts of the y-axis, that is why it’s not moving in the y-direction. Fix that before going on.