Lightburn Connectivity Issues

Hello Everyone:

I’m noticing something weird when using the Lightburn Software. First of all, I am using a Boss Laser LS1420 65W machine.

Now, for the issue, I’m having a lot of connectivity issues. I’ll run a file and all seems okay, however, when I then try and frame my unit using Lightburn it has magically disconnected from the software and I have to power down my machine and Lightburn, then turn my machine on first, then launch the software. This happens a lot.

Anyone have this issue? How do I fix it?

Thanks,
Michael K.

You have not identified the way you connect to your laser - but try this. Force a communication reset by Shift-clicking the ‘Devices’ button at the bottom-left of the ‘Laser’ window and see if that gets you going again.

I apologize for the lack of information. I’m connected via USB through the back of the machine (Not the side port). I did try what you had asked, and unfortunately, no luck when I Shift+Click.

Things to try:

  • Make sure your USB ports aren’t allowed to go to sleep. https://www.windowscentral.com/how-prevent-windows-10-turning-usb-devices

  • Try installing the latest FTDI driver (used by Ruida for USB comms): https://www.ftdichip.com/Drivers/VCP.htm

  • Try changing the connection mode from Serial/USB to Packet/USB in the device settings. (Click the Devices button, select your laser and click Edit, go from there). Some systems prefer one over the other, for no reason I can figure out.

  • You said on your post “through the back of the machine” - How long is the USB cable, and does it have ferrite chokes on it? (the metal rings around it) USB cables aren’t supposed to be very long, so if it’s more than 15 feet you could have signal interference.

I’ll give these a try and let you know.

To answer your question about the USB length, I have the original Blue Cable that came with the machine, then I have a USB extension plugged into that to reach my computer. However, I do not believe that it is more than 15’. I then have the laser USB and the camera USB connected to a hub, and then that is connected to another hub that is attached to the computer due to limited USBs

One thing that I did notice is let’s say I turn on the laser for the first time. It will stay connected to the computer for ever, but, if I run a job, I have to disconnect the laser and plug it back in. So if it were a connectivity issue, wouldn’t have issues on the first start up? Just a thought…

If you’re trying to go a long way, and have limited USB ports, Ethernet would be better for connecting the machine.

To your other question, an idle post doesn’t send much info, and would have time to retry packets without falling behind. If you’re sending at full speed and the error rate is too high, the computer might drop the connection. I’m guessing here. USB port sleeping could easily be the problem too.

How would one go about connecting via Ethernet? Is there a guide somewhere?

I tried the Sleeping workaround and that didn’t help.

There’s a FAQ for that somewhere around here.
Ah, here it is…

My machine is hardwired to my router and never gives any trouble whatsoever. I think it’s much superior to a USB connection and it’s not limited to 15’ or whatever the max USB length is.

So do you have it connected USB to the router?

Also, does it talk anywhere about what hardware I need?

No USB. My desktop computer where I do most of my work is also hardwired to the router. Sometimes I use a laptop which is connected to router via wifi.

For hardware all you need is an inexpensive router if you don’t already have one, and an ethernet cable to connect it to the LASER.

Your computers can be hardwired to router via cable or connect with wifi.

So if I have a Wireless router in my shop already how can I connect to the laser via WiFi? Is there an option for that in the laser?

If your laser has a WIFI puck, then yes. If your laser has an Ethernet port, you will need to use that to connect the laser to the router. The laser needs an IP address assigned to it in the controller so it shows up as an addressable device on the network. You will then need to tell LightBurn what the address is in your ‘Devices’ setup.

There’s no option for wifi in the laser, but there should be an rj45 connector you can use to hardwire it. (or maybe not, I don’t know about Boss)

There are also adapters available that plug in to your rj45 and makes it play the wifi game, but I have no experience with them.

Amazon seems to have an assortment of them…

Okay, so here’s an update, I looked at the back of my machine and noticed that my cable from the machine was longer than I thought so I have it plugged into the only remaining USB port that I had and it seems to be working well now. I think the Hub to Hub method is what was killing the connection.

3 Likes