Lightburn does not detect RUIDA 6442G-B controller

Hi! I am an absolute newbie to the Lightburn software and to laser engraving. I am trying to get Lightburn to detect my laser which has the RUIDA 6442G-B controller. I have tried connecting to my Windows 10 laptop using USB and a ethernet cable; no detection either way. I have tried restarting the computer, restarting the laser, unplugging and re-plugging in the cables and no detection. An interesting thing that happens is that the computer gives an audible signal telling me something has been plugged in using the USB, but no indication of what it is. Any suggestions? Thanks in advance!!!

Go back through the installer for LightBurn and on the last page, click the ‘Install FTDI driver’ box. That’s likely what’s missing. Autodetect will not work with Ethernet, just USB. If you want to connect with a network cable, follow the guide here (and the driver isn’t required):

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.