Lightburn does not locate my device

I’m totally new to lasers. I purchased a 40w CO2 laser from a friend. I downloaded the trial of Lightburn but it doesn’t find my laser. Prior to downloading Lightburn I was able to use a different software to make a test burn.
Can someone help me. Can I use Lightburn with this machine?

This post is relevant:

1 Like

Thank You for your help

1 Like

Based on the information I received in my original post I decided to purchase one of the drop-in replacement boards.
Unfortunely the Cohesion 3D board is out of stock. I ordered a Mini Gerbil 3 board almost 3 weeks ago and it still has not shipped. I guess there is an issue with the warehouse.
I would really like to start using the laser with Lightburn.
Not sure if I should just wait for the Mini Gerbil board or cancel the order and go another route.
I want a good dependable solution.
I welcome any suggestions.


There are many alternative boards. I’ve listed some in the other post.

Why not try using the Meerk40t solution until the Mini Gerbil 3 board arrives. I don’t believe there are any positive confirmations of using the GRBL emulation with LightBurn so that would be interesting. Ruida emulation has been confirmed but would require the DSP license. Not an issue if you’re using the Trial version but becomes an issue once the license expires.

Or are you only interested in identifying potential other replacement boards?

I’m just looking for a good solution. I want to use lightburn and I don’t want to learn a different software first.

Are you referring to my suggestion about Meerk40t? You wouldn’t be learning Meerk40t in what I described. Meerk40t is merely acting as a middle-man emulation/translation layer to convert Ruida or GRBL commands to native M2 format. You would use LightBurn to connect to the Meerk40t provided middle layer.

Here’s a tutorial for how this can be done for Ruida emulation. Apparently this can also be done with GRBL but I’m not familiar with how that works:

I took a few minutes to review what it would take to use the GRBL emulation. From what I can tell the steps are nearly the same as the Ruida emulation. However, instead of typing “ruidacontrol” type “grblcontrol” in the Console window in Meerk40t. Create an ethernet GRBL device in LightBurn with as address. I have no way of testing this, however, so take as more directional than as a guide.

Thanks for the input. I’ll give it a try.

Maybe I’m missing it but I don’t see a free trial of the DSP version of lightburn.

The trial version allows for all license types to be trialed. There is not a different trial version per license type.

Might be a good opportunity to test both Ruida and GRBL emulation in Meerk40t to compare.

I was able to use Meerk40tto to create a GRBL link to lightburn and it seems find my laser and I can use the controls to go to home, etc. I created a sinple rectangle in lightburn (100x50 ) with text in the center of the rectangle. When I use the preview window it looks good. when I use the frame option or run the laser all I get is a horizontal line.
I then created a circle in lightburn. When I run the laser it engraved a diagonal line from home position to circle and then engraved the circle and then engraved the diagonal line back to home.
I’m using absolute coordinates. I’m not sure if I’m not setting something correctly in lightburn or if the emulation is not working properly. Any help for this newbie is appreciated.

I don’t have the hardware to test this functionality so won’t be much help there but here are a few things to check.

  1. Does your laser work correctly using native software for these same operations? Your initial post indicated that you did some level of testing but not clear what.
  2. What version of Meerk40t are you using? There have been a lot of updates in emulation more recently
  3. It’s possible the issues you’re seeing are with the GRBL implementation. Have you tried Ruida emulation as well to see if it behaves differently?
  4. You may want to try running the equivalent designs from Meerk40t directly to confirm that Meerk40t and the laser are communicating properly.

Thanks so much for your response. I’m running meerk49t v0.9.0004.
I tried using Ruida emulation and it seems to be working fine with it.
Guess I’ll just stick with Ruida emulation for the time being.

Glad it’s working for you.

You may want to try running 0.8.5 to see if that improves GRBL emulation as it may be more stable at the moment. In either case I’d encourage you to report your findings on GRBL to the Meerk40t team as I know they’re looking to make that as robust as possible.

Thanks for all your help. I was able to get Meerk40t working with Ruida and then my Mini Gerbil 3 board suddenly arrived! Mini Gerbil 3 board is installed and seems to be working well.
One question however, m laser came with a small flashdrive that was to be plugged into a USB port.
Is that still required when using the Mini Gerbil 3 board with Lightburn?

What is the stated purpose of the flash drive? What is on the drive?

LightBurn itself has no hardware dongle requirement or anything like that.

But the function of the USB flash drive is not apparent to me from your description.

The user manual calls the USB thumb drive a software protection dongle.

Oh. I misunderstood what you said earlier. The USB thumb drive came with the original laser, not MG3, correct?

That is no longer necessary. The dongle was necessary for the original software used to run the original board.

Sorry for my confusing post. It was the USB thumb drive that came with the original laser that I was talking about.
Thanks so much for your responses…great support!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.