Lightburn doesn't connect to BOSS LS 1630

New user to both laser and Lightburn software. Lightburn was pre-installed with windows based pc from Boss Laser; able to use LaserWORKS V-8 to send file to laser; but LIghburn says laser is “Disconnected” . What am I missing here? It explains why I had to manually select the laser on lightburn to set up. Thank you.

Are you trying to run both software at the same time?

In LightBurn, right-click the ‘Devices’ button found in the ‘Laser’ window to retry the initial connection.

If you power your laser first and let it finish homing, then start LightBurn, it’ll connect every time. If you run the software first, then power the laser, you might have to right-click the ‘Devices’ button to reconnect, though that’s rarely necessary - it mostly does the same thing when you click the ‘Start’ button.

Thank you for the prompt reply, not running both programs. The steps are the laser is powered up first and homing completed. lightburn powered up and connected via eithernet cord but it doesn’t connect. RIght clicking the Devices button does not respond to the click. The “find my laser” box remains blank.

You can check this connection (“ping” the IP set to laser w/network cable unplugged) without the need for LightBurn. This will ensure you have the IP configured correctly.

I have pinged the PI address of the laser and Lightburn does locate it and will find and install the laser. I have the TP link network connected; but LIghburn still says “disconnected”. What am I missing? likely something easy, but I’m sure not seeing what it might be. Thanks

‘Find my Laser’ doesn’t work over Ethernet, only USB - do you have the controller plugged in both ways? That would be “not good”. If you are connecting via Ethernet, you’ll have to manually configure the device in LightBurn, and provide the IP address of the laser when you do that. Read here: https://lightburnsoftware.github.io/NewDocs/CreateManually.html

The controller is not plugged in both ways; tonight I was able to again change the IP address and LIghtburn automatically recognized and installed the laser. The USB does not seem to connect to the laser, same result. Is there a tech number that I can call for a few minutes of walking me thru this? Thank you.

“automatically recognized”? What does this mean?

Did you define a Device Profile as described in the process above?

lightburn recognizes my laser in the Devices, but says the laser is “disconnected” . I have the USB plugged in and the TP link on, the laser is turned on and homed; Lightburn is opened, but the laser is not connecting. The IP address is pinged and found for the laser, but still not connecting. any ideas? thank you.

This is the issue. You are trying to connect to the laser using two different communication methods at the same time.

You need to pick only one, use only one cable, and then tell LightBurn which you have chosen.

If USB, plug a known good cable into the USB port on the laser and the other end into your computer. You can then use the ‘Find My Laser’ to find your Boss.

If on the other hand, you want to connect using a network, you will need to follow the instructions provided in a previous post above. In this case, you will plug a network cable, looks similar to an old phone connector, into the network connection on the laser, then into your network, via an access point, router or hub, depending on your desired configuration.

If the network setup I just described is gibberish to you, choose USB. :slight_smile:

good news! The laser is now connected and Lightburn is working with the laser. Thank you for your time and patience.

1 Like

Glad to hear you got sorted. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.