Lightburn fails handshake on startup


(Tim Jensen) #1

This is new behavior. I’ve been using LB for over a month, without issue, to control my grbl laser. I did some CNC work and then switched back to laser configuration. Now, when LB tries to connect, I get a message in the console window: “port opened waiting for response”, but it never connects. When this happens, the laser fires and the table starts to move, but with a grinding sound, not the normal smooth motion. The only way to stop it is to kill the power and unplug the USB cable.

It has happened once or twice using laserGRBL, but it is consistently failing with LB. If it does connect, it correctly reports my grbl version as 1.1f and then works fine. But it fails more often than not. Tried 6 times this morning and always failed with LB but laserGRBL connected. I’m running 0.9.04 version of LB.

Any advice would be appreciated.

Regards
Tim


(Rick James) #2

It appears something has changed in your configuration/setup as you have successfully used LightBurn before. Please post your grbl settings ($$) and post them here for review. When you say, “I did some CNC work and then switched back to laser configuration.”, how do you “switch” your configuration? Are you using a macro in LightBurn? If so, post that as well.


(Tim Jensen) #3

Hi Rick

For the “switch back” to laser, I just changed $30=1000 to $30=255 and $32=0 to $32=1 manually.

Here are the grbl settings

$0=10 (Step pulse time)
$1=25 (Step idle delay)
$2=0 (Step pulse invert)
$3=5 (Step direction invert)
$4=0 (Invert step enable pin)
$5=0 (Invert limit pins)
$6=0 (Invert probe pin)
$10=0 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=0 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=0 (Homing direction invert)
$24=25.000 (Homing locate feed rate)
$25=100.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=1.000 (Homing switch pull-off distance)
$30=255 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=1 (Laser-mode enable)
$100=800.000 (X-axis travel resolution)
$101=800.000 (Y-axis travel resolution)
$102=800.000 (Z-axis travel resolution)
$110=8000.000 (X-axis maximum rate)
$111=8000.000 (Y-axis maximum rate)
$112=600.000 (Z-axis maximum rate)
$120=10.000 (X-axis acceleration)
$121=10.000 (Y-axis acceleration)
$122=10.000 (Z-axis acceleration)
$130=290.000 (X-axis maximum travel)
$131=170.000 (Y-axis maximum travel)
$132=80.000 (Z-axis maximum travel)


(Oz) #4

It sounds like the homing cycle isn’t working. Check to make sure your limit switch wires are connected properly. If they aren’t, the head could run into the rail and cause this grinding sound while the laser was looking for the homing switch. You also have homing disabled. Have you enabled it in LightBurn?


(Tim Jensen) #5

Well, I don’t have limit switches.

The console shows “port open, waiting for response” and it never seems to get a response.

laserGRBL works fine…no more than 3 seconds and I get the grbl 1.1f showing in the window. Connection via other software I use for CNC works (Vcarve sender, Candle).

It really seems like whatever LB does to detect the board isn’t working.


(Tim Jensen) #6

Oh, and the grinding sound happens even though the table isn’t close to the rails. More like aborted moves or sudden, alternating moves. Since I don’t have limit switches, I can’t home.


(Oz) #7

Did you change the baud rate in LightBurn, perhaps? In the device settings - for an Arduino based GRBL board it’s usually 115,200.


(Tim Jensen) #8

No. Baud is still set to 115200


(Oz) #9

Try this:

  • Run LightBurn
  • click Help > Enable debug logging
  • click “devices”
  • click OK (this just resets the connection)
  • wait a moment for it to try connecting
  • turn the debug log back off
  • quit LightBurn

You should now have a file called LightBurnLog.txt in your documents folder. Post it here so I can have a look. It might take a day, as I’m driving cross-country this week.


(Tim Jensen) #10

Here is the log file report:
18:25:00.770 D: “LightBurn 0.9.04” “Sun Jun 30 2019”
18:25:10.317 W: QMutex: destroying locked mutex


(Oz) #11

If that’s all it contains, you shouldn’t even have “port opened, waiting for a response” in the console - That doesn’t look like it did anything at all. Can you try the process again?


(Tim Jensen) #12

Ok, I tried it again, and it connected fine. I restarted the program and it didn’t and I had to kill the power. Next attempt connected, next one after that did not. Here is the log from that attempt:
07:43:26.634 D: “LightBurn 0.9.04” “Mon Jul 1 2019”
07:43:34.007 W: QMutex: destroying locked mutex
07:43:34.069 D: “starting” busy: false state: 0
07:43:34.069 D: Enumerating ports:
07:43:34.069 D: Port: “COM1”
07:43:34.069 D: PID: 0 VID: 0
07:43:34.069 D: Manufacturer: “(Standard port types)”
07:43:34.069 D: Description: “Communications Port”
07:43:34.069 D: System Loc: “\\.\COM1”
07:43:34.069 D: Serial: “”
07:43:34.069 D:
07:43:34.069 D: Port: “COM6”
07:43:34.069 D: PID: 29987 VID: 6790
07:43:34.069 D: Manufacturer: “wch.cn
07:43:34.069 D: Description: “USB-SERIAL CH340”
07:43:34.069 D: System Loc: “\\.\COM6”
07:43:34.069 D: Serial: “”
07:43:34.069 D:
07:43:34.116 D: Found port: PID 29987 VID 6790
07:43:34.116 D: Manufacturer: “wch.cn
07:43:34.116 D: Product: “USB-SERIAL CH340”
07:43:34.116 D: Name: “COM6”
07:43:34.116 D: Port open failed
07:43:34.178 D: “starting” busy: false state: 0


(Tim Jensen) #13

Also got this in the console field the next time I started:
Waiting for connection…

Waiting for connection…

Port opened, waiting for response.

<8888<8888�

Grbl 1.1f [’$’ for help]


(Tim Jensen) #14

Restarted the computer, LaserGRBL worked so I tried LB and got this (I deleted a bunch of the failed attempt lines so it would fit):

17:35:44.588 D: “LightBurn 0.9.04” “Mon Jul 1 2019”
17:35:55.557 W: QMutex: destroying locked mutex
17:35:55.607 D: “starting” busy: false state: 0
17:35:55.607 D: Enumerating ports:
17:35:55.609 D: Port: “COM1”
17:35:55.609 D: PID: 0 VID: 0
17:35:55.609 D: Manufacturer: “(Standard port types)”
17:35:55.609 D: Description: “Communications Port”
17:35:55.609 D: System Loc: “\\.\COM1”
17:35:55.609 D: Serial: “”
17:35:55.609 D:
17:35:55.609 D: Port: “COM3”
17:35:55.609 D: PID: 29987 VID: 6790
17:35:55.609 D: Manufacturer: “wch.cn
17:35:55.609 D: Description: “USB-SERIAL CH340”
17:35:55.609 D: System Loc: “\\.\COM3”
17:35:55.609 D: Serial: “”
17:35:55.609 D:
17:35:55.662 D: Found port: PID 29987 VID 6790
17:35:55.663 D: Manufacturer: “wch.cn
17:35:55.663 D: Product: “USB-SERIAL CH340”
17:35:55.663 D: Name: “COM3”
17:35:55.663 D: Port open failed
17:35:55.710 D: “starting” busy: false state: 0
17:35:55.765 D: Found port: PID 29987 VID 6790
17:35:55.765 D: Manufacturer: “wch.cn
17:35:55.765 D: Product: “USB-SERIAL CH340”
17:35:55.765 D: Name: “COM3”
17:35:55.765 D: Port open failed
17:35:55.875 D: Found port: PID 29987 VID 6790
17:35:55.875 D: Manufacturer: “wch.cn
17:35:55.875 D: Product: “USB-SERIAL CH340”
17:35:55.875 D: Name: “COM3”
17:35:55.875 D: Port open failed
17:35:55.984 D: Found port: PID 29987 VID 6790
17:35:55.984 D: Manufacturer: “wch.cn
17:35:55.984 D: Product: “USB-SERIAL CH340”
17:35:55.984 D: Name: “COM3”
17:35:55.984 D: Port open failed


(Tim Jensen) #15

So any thoughts on this log report?


(Oz) #16

Something is keeping the port locked - That’s why it’s saying “Port open failed”. It’s trying to connect, and unable to. LightBurn is finding the port properly. I’ll have a look and see if there’s any more info I can get out of it when attempting to connect, but if it connects again after you reboot your PC, that means it’s most likely something else holding the port open.


(Tim Jensen) #17

Thanks. Reboots don’t fix it. It seems random.


(Tim Jensen) #18

Any other ideas as to why the port is locked? Lightburn has become essentially unusable to me now. LaserGRBL connects fine. Reboots and power cycles don’t fix it. Could it be a port setting issue? Or maybe something with Windows?


(Oz) #19

I have no idea why LaserGRBL would connect but LightBurn wouldn’t. Do you set a baud rate or any other settings in LaserGRBL? I may have to get SainSmart to send me one of their controllers so I can look at this, but we have other users running that hardware without issues, so I have to believe it’s a problem specific to either your controller or your computer.

  • Do they have a driver that you install? (the CH340 device should have one) You could try uninstalling the driver for it, then unplugging it, re-connecting it, and Windows should update the driver.

  • Have you tried different USB ports in your computer, or always the same physical port?

  • Are you always testing with LaserGRBL first, or have you tried connecting with LB first as well?

  • Do you have anti-virus or firewall software running that could be interfering with LightBurn?

  • Can you try running LightBurn in administrator mode? (Right click LightBurn icon, “Run as Administrator”)


(Tim Jensen) #20

Lots of good points there! I have run it without changing the port baud rate and with changing it to 115200. I have tried different ports and different orders of starting the software with the same negative result. I do run standard Windows Defender (or whatever the Win 10 version is) but that’s all. Tried it as Admin… worked the first time, and not the next 4. Tried different USB ports, and that didn’t matter. It seems to randomly make the connection. Once it does, it is fine. If the connection is broken (like by a power cycle or software reboot) then I am back to square one… hoping the next time I try, it will connect.

LightBurn worked perfectly when I first tried the software several months ago. My only other thought is that a Windows update has changed something. But I don’t know if that is reasonable or not. I will roll Win 10 back a few updates and see if that makes a difference. I have several commissions that I need to finish so it might be several days before I can try that.

I Loved the features of LightBurn. I thought it was a great program when I first got it. But lately it has become an albatross and for no logical reason. I haven’t changed anything physically with the computer.

I would be more than happy to set up a TeamViewer session if you think that would help ( or be worth your time). I know I’m not the only one out there with this issue.