Lightburn File and Burn do not match

So I have a lightburn file that I created, a test template and after burning it the burned result doesn’t match up with the lightburn file. Not sure what to make of it - but there is a clear 4mm separation between objects in the lightburn file and they are overwriting each other in the actual result.

Any ideas?

Since your profile doesn’t appear to tell us what kind of machine you have and what firmware it uses and you haven’t told us, then no… No ideas at all.

If you can be more specific about what you have and maybe post a photo of the problem then some ideas may come to mind.

PM’d to me:

I’m running an Orion 80W machine with Ruida over Ethernet (preferred over USB). I’ve tried this with both connections (Ethernet and USB) and the result is the same. Apparently as a new user here, I can’t upload the lightburn file or an image. So suffice it to say the objects that are overlapping in the burn output are ~6mm apart in the lbrn file.

Most likely the motors are skipping because of the speed or acceleration settings being too high. I’ve bumped you up a level so you can post images now. (It’s entirely to control spam)

Ok… I get acceleration being a possible issue, speed for most of the burn was @ 100% with a select section at 50%… I’m attaching an image of the burn and the lbrn file. Note the box around the text on the right of the image is right on top of the square to the left of the text. In the lbrn file there’s a separation of a few mm (not sure how much). The line thickness around the box was created in AI as 0.001mm in RGB red, before opening the AI file in Lightburn. I ended up editing most of what was imported from AI anyway…

I apologize for the blurriness - its and unsteady hand with the iPhone…

Material was frosted cast acrylic (Cell Cast)

Material-Test-2020-07-19.lbrn (612.2 KB)

It looks like it slipped somewhere toward the last few layers.

The swatches there aren’t lining up with the text, and the spacing of the outer box relative to the text is wrong too.

It sounds like you have the same machine as me (Orion, Ruida, 80W) and I had a lot of misalignment troubles with mine at first. Mine turned to be hopelessly optimistic acceleration settings from the factory.

Since your engraved areas look OK, but there’s misalignment between objects I’d have a look at “Idle Acceleration” and “Idle speed” which are what’s used when moving between objects (laser off).

Try nudging that idle acceleration down some and see if it behaves better.

On closer inspection you’re right the image is all shifted to the right starting with the text. I set up that block to determine what power percentage my laser begins firing. On a wood version it starts at 12% It seems the burn skews in Y the further it is from 0.

Thanks Hank - I’ll try to decipher the docs and find those acceleration settings…

In LighBurn: Edit -> Machine settings.

The laser must be connected and on to read/write the settings. Don’t forget to click “Write” after you change a setting.
And it’s always wise to take a screenshot or write down settings before you change them in case you need to go back…

Any idea what the default password is? :slight_smile:

You shouldn’t need a password to edit most of the machine settings. I’ve never been asked…

Are you trying to edit from LightBurn or from the machine control panel?

Machine control panel - I got the speed turned down to 100mm/sec. Wanted to look at the factory params just to familiarize myself. Are the Speed and Acceleration params available via lightburn? I know speed at the layer level - but I’m still learning the nuances of the software.

Never mind… I found it. Thanks anyway…

Cool. What’s the Idle Acceleration set at?

I wish I knew… I set the machine settings for X/Y Acceleration to half what they were. Did a Write and it said everything was good - then I tried to upload a file again and now it says it can communicate with the controller. So I can’t even load params from the controller at the moment… in deep-poo-poo doing an RCA now.

Now on the machine it says my X=10000.0 and Y=10000.0… that can’t be right b/c it’s sitting at 0,0… but I can’t get into the menu on the machine and lightburn doesn’t want to talk to it… ahhhhhhh!

In Lightburn if you right-click the “Devices” button does it re-connect?
It should say "Found RDC664XG or similar at the bottom of the window.

I didn’t do that - but it decided to connect again without intervention… Ghost in the machine. But now it won’t do anything because it thinks it’s X & Y is way off the board… Here’s what “Get Position” returns.


All I changed was Max Acceleration on X Axis Settings (5000) and Y Axis Settings (1000) and then did a “Write”.

Well that was painful experience. I tried restarting the machine (controller) and it kept coming up 10000 pos for X & Y. So I had one of my minions stand there ready to smack the E-Stop and I sent a command to go to 0,0 - obviously a noisy and bad action - but it did the trick. After bringing it back up from the E-Stop, the X & Y are now set 0,0. So the question is, why does changing the X and Y Axis Max Acceleration params and writing to the controller cause the controller to think it’s current X & Y are off somewhere NW of Nova Scotia? It’s the only thing I did in lightburn… and I was unable to reset the controller directly. Very concerned.

Anyway - to answer you question Hank…