Lightburn freezes mid project using Xtool Pro D1 20w

Hi, brand new to lightburn after hitting issues in XCS even since starting using my new D1 Pro 20w less than a week ago.
In essence, the machine just freezes during a project, in both Lighburn and XCS, locking the laserhead, meaning the machine has to be turned off/on again to reposition the laserhead. Happens connected by wifi or USB in XCS, only tried USB in Lightburn.
Project is a simple laser cut of an SVG file which should only take 4 mins.
Using relative positioning with limit switches turned off as these would immediately and incorrectly set the limit switch alarm off in XCS.
No error codes generated in Lightburn.

Same issue here no solution yet

The title says ‘LightBurn Freezes’ but is it the xTool that freezes?

Just for clarification, the laser engraver stops moving, the laser light goes out, the progress bar in LightBurn proceeds and completes or stops progressing after a while?

I haven’t heard of this happening with an xTool. Are the switches still in place?

With metal rails and metal wheels Static Electricity is unlikely but i’ll elaborate on what i’ve seen because it’s possible.

Several engravers had a design problem where static electricity could reach the control board through the limit switches. Some of the switches were near moving parts which would make them seem to trigger randomly with motion. Some would only trigger when the switch was nearly engaged. Without active limit switches, the static can build up and cause the engraver to brown-out and lose it’s data stream. Occasionally a solid enough spike would cause enough power loss to automatically restart the engraver. When the engraver restarts it sends its start-up or welcome message and waits for start commands. Because it’s expecting start commands it won’t typically reengage if it sees mid-job data.

Does the welcome message or start up message ever ( or occasionally ) appear in the Console window in LightBurn when the laser head stops?

Dry winter months made symptoms like these more prevalent, rainy weather made these symptoms fade.

I have not seen this on WiFi or with XCS but it’s possible.

Occasionally I recommend working on top of a metal baking sheet that can be connected to the chassis and hanging a small conductor from the end of the metal part of the gantry to the baking sheet.

A weak power supply can do something similar.

With the limit switches disabled ( as you have done ),
unplug the Y-axis motor so only the X-axis motor can move.
Set the laser output to 0.5%
Run the job.

If the job completes the power supply may be suspect.

This could also explain the limit switch behavior because a weak power supply could lower the threshold enough to trip randomly when motors begin to accelerate.

Have you also had the same problem with the Limit switches and disconnected them?

Yup. The sent me a new limit switch it should be here tomorrow. Working with Nick at xtool for this issue.

This appears to be an xtool issue so I won’t continue in this forum as it is not a Lightburn problem

Have you checked your USB port settings in the device manager to make sure your computer isn’t using the power saver option to cut it off?

1 Like

Check your device power saving setting in Device Manager.

So xTool sent me all three new sensors and a cross connect cable connecting the left and right, however I just purchased the 40w, running the 20w and 1064nm as alternates, I got the new longer 40w harness today to support the extension, it dosent come with the 40w kit, problem solved with the new sensors alone in a 20w mode

Would you be willing to share a picture of these sensors?
I’m curious what was used to solve this.