Lightburn in to mm button does not toggle Speed and Max Power

Lightburn in to mm button does not toggle Speed and Max Power.

Ruin a job due to toggling the in/mm button only to realize that the Speed and Max Power defaulted to mm settings.

Currently running 9.10 version. Was this fixed in 9.14 version?