LightBurn just stopped in the middle of 90 min job - Screen saver to blame?

Win10/64/16Gb i5.
after perfect working for 45 min i heard windows resetting USB connection and lightburn quit and moved laser head to 0.0 home killing a 90 min job after 45 min. the PC screen saver started and i do not know if that is the culprit.

How do i make sure nothing like this will ever happen again?
How can i force lightburn to keep USB connection uninterrupted for as long as it is running?
my PC did nothing but streaming gcode to K40/Smoothie.

My PC power & Sleep settings are to keep all up.
I will not start a new long job until i understand what went wrong.

LightBurn itself disables system sleep while cutting, so it’s more likely that your USB disconnected, and then, since it was now allowed, the PC started the save / sleep process.

Look in the FAQ for USB connection troubleshooting - I’ll post a link in a few when I’m home again.

1 Like

Ok, thanks guys,
My power & Sleep management settings were set to high performance, never sleep and such, but all my three usb root hubs were set to “allow computer to turn off…” i unchecked all and also disabled usb-selective-suspend hoping this will do the trick. Should I also enable debug log in LightBurn? will this log give us clues in case this will happen again? any performance penalty for keeping this option checked?


Don’t leave logging on - the log file grows until deleted, and it’s quite verbose, so there is a performance hit. I wouldn’t see anything other that “disconnected” anyway, unfortunately - I don’t believe it gives a reason.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.