Lightburn "move" panel issue

Question: I have reflashed the firmware and added the limit switches to home the laser on my Atomstack A5 and add air assist and it works fine now. I am trying to set up a grid now and while working in lightburn when using the “MOVE” panel I can click Get Position then if I enter any number in Y or X the Counsel pops up with an Alarm 2. However when I use the buttons that have the arrows then the laser move. I have not even got to do a project with this thing yet! Can something be off in the firmware again?

You have an offset configured that’s likely responsible for this.

What was the source of your firmware upgrade? Was this provided by Atomstack?

Can you run these commands in Console and return results. Preferably as text, not a screenshot:


Also, can you confirm whether or not your machine has limit switches for homing?

I do have limit switches and Air assist and I used the video here Installing Clean GRBL Firmware on Diode Lasers - YouTube to reflash firmware. The homing and air seem to work just fine.
Console.txt (949 Bytes)

To which corner are you homing?

Can you confirm that the dimensions for your laser are 400x390? Atomstack website indicate 410x400 so want to make sure this is deliberate.


Was this offset deliberately configured?


in Machine settings I have it 400x400

Front left home corner

I also used the pre configured firmware in the video.

Can you make these adjustments by running in Console:

G10 L2 P1 X0 Y0

Once you do this can you rehome? Then run in Console and return results:


Did you know that the Atomstack used an Arduino based board similar to Sculpfun before doing this?

I’m not certain if the pre-compiled firmware provided by LightBurn is configured to to set origin to home but the commands requested above should confirm.

Yes, after it homed fine. It always homes fine though. Here is copy of console
Console.txt (642 Bytes)


Yeah, as I thought. The firmware is not configured to set origin to home position.

2 options:

  1. reflash to a different firmware that sets the home position to origin. This is easily done with LaserGRBL as they have a preconfigured firmware that you can install directly from the program. “v1.1h, custom, XY Homing 20190830” as can be found on this page:
    Flashing Grbl Firmware – LaserGRBL
  2. Run these commands in Console:
G10 L2 P1 X-399 Y-399

Well $hit! I installed LaserGRBL and used the preconfigured firmware like you said and
Console.txt (1.1 KB)
get the error again.

Can you run these Console commands:

G10 L2 P1 X0 Y0

Then rehome.

Then run:


Before you answered back I reflashed it to the stock atomstack firmware. Then seen your reply and again open Laser GRBL and flashed it again with the preconfigured software and now I’m getting home is not enabled. I power cycled the laser and restarted my computer and tried flashing again but always get homing not enabled. THANK YOU FOR TAKING THE TIME TO HELP ME!

Enable homing with:


Ok, did that then it went to the back right corner and started grinding.

Can you run in Console:


Man this is really messed up. Now every time I turn on lightburn the laser moves to the back right and grinds the belt. Any way to reset everything?

Yes. But no guarantee that it puts you in a better position. If you can return the output of the commands listed we can sort out the homing direction.

This thing is so fricking messed up now and chewing my belts up. I’m going to flash it again via the video and start from scratch.

If you pull out the power adapter this will prevent the motors from running. However, you should get enough power from USB to power the controller. You should then be able to run commands without fear of collision.