Lightburn not powering laser correctly

Hello! I just installed a laser onto my LEAD 1010 CNC running thru the Blackbox Controller. While testing in Openbuilds Control, it works just fine. I can click on to power the laser at different power levels and all seems good. When I get out of Control and go into Lightburn I select my machine and am able to jog, etc. correctly. However, when I hit the fire laser button it barely lights the laser up whether it’s 1% or the maximum of 20%. It does fire, but it’s so faint you can barely see it. I checked the max spindle speed set in the controller, and it’s 255. I also checked the max spindle speed in Lightburn, and it’s 255. For the life of me, I can’t figure out why Control powers it up all the way and Lightburn barely sends a signal. Any help would be greatly appreciated!

I have the same problem. The laser works with low power, it is set to 100% in the settings but it works with a couple of percent.

It’s frustrating. If I figure it out I’ll let you know what I did! :slight_smile:

I figured it out. Hit the wrench in the Lightburn toolbar to get to the device settings. Down on the lower right the S value was defaulted to 1. I changed it to 255 which is my $30 GRBL setting. Yours may be 1000 like some other peoples. If so, I guess use that. Once I changed it, I’m getting full laser power in Lightburn now. Hope it works for you as well.

Yes, it is literally the first thing we tell you to check in the ‘Common Grbl setups’ section of the documentation: Common Grbl Setups - LightBurn Software Documentation

Short version

  • You might need to adjust your spindle max RPM value ($30) to match the LightBurn default (1000) or vice versa. The value in LightBurn is called “S-Value Max”, in the Device Settings.


I read the grbl settings and it said it was 255 so I thought it was set correctly. I had 255 set somewhere else as well, but not in the settings under the wrench. I’m just learning all this stuff and will gladly pay my knowledge forward as I continue to learn. I’m glad their are forums and Facebook pages we can go to in order to help one another. Thanks a lot Rick!

1 Like

Thanks for the help. I tried both 1000 and 255 but no setting increases the laser power.
There may be a problem with the software in the laser.
I really don’t know what to do anymore. i tried using some other programs and there the laser worked.

The nice folks at TwoTree have a setup worth review:

I am not super familiar with this laser offering. You may be fighting a non-supported firmware and need to flash your controller with a firmware supported.

Do you know what firmware is used to drive your laser?

I have this laser model:
When the laser is connected it says: connected GRBL 1.1f

Hello, I have the same Totem S engraver, and have simmilar issue, laser does not perform as it should power wise. Settings are as recommended:image

looking forward for any reply from support.

How so? You have told us that the laser is not performing as you’d expect, but not what you set the laser to do, and what result you actually got. We will need more to provide anything back you can use to address the issue(s) you are having.

We created this post to help you understand what we need and why.

tl;dr: pictures, details, and punctuation, thank you.

Rick, thanks for quick reply, sorry for not delivering additional information, just received my laser yesterday, so lots of new things to learn. It is Two trees manufacturers (Chinese) model Totem S, it has LKS motherboard, and upon sucess full connection in lightburn console it is greeted with "Grbl 1.1f " which is it’s firware as I presume. I am runnning on laptop with following specs image with windows 10. What I did, and I just found out it had impact to laser power output, when automatically Lightbur selected the settings for the laser, I saw it set 200x200mm cutting range, thou avalable area is much bigger (400x350mm), so I added second laser manually, entering mentioned avalable area for engraving. Ran test, saw that on 80 % power and 500 mm/min laser barely left a mark, on leather. After this wrote earlier post, and decided to test with default configuration of laser like LightBurn sugested, and I better result, with higer power output, but not perfect, so will study more settings and do more test, hopefully will find what I need. But this is kind of strange for me, how engraving area corelates with laser power in Lightburn. Means I cannot use that vast cutting space, and only smaller one default?

Dear Rick, I have made couple of more tests after a restart of all equipment, and now I cannot replroduce situation as I described above, laser cuts well with Lightburn software, as with GBRL native software, on both laser profiles, custom and default (as Lightburn detected. Thou real boundaties are actually less than I described earlier, but are bigger than 200x200mm. So you live and you learn.

New goodies and learning new things…always good times. :slight_smile:

No no, they are not correlated in any way. Differences in the other parts of the ‘Device Profile’, set while ‘Find my laser’ did its thing, is what you might be seeing adjust power output.

First, you can edit the profile LightBurn built for you, or any defined profile for that matter, and you can do so a couple of ways.

One example, you can change the Workspace size clicking the ‘Spanner / Screwdriver’ icon near the top-center and expose the ‘Device Settings’ for that profile.

Another, you can revisit the profiles you have created clicking the ‘Devices’ button at the bottom-left of the ‘Laser’ window, then highlight the desired profile and select ‘Edit’. You can then advance through the process adjusting as required until complete.

Keep this link handy, we try to cover many of these “How do I get going?” type issues in our in-progress documentation to help. Home - LightBurn Software Documentation

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.