Lightburn not recognizing laser

I am using a mac and have downloaded Lightburn. I tried to hook Lightburn to AP Lazer SN2816 via ethernet cable or usb, Lightburn will not recognize the laser with either one. So I set it up manually but still says no device is found. Is there a driver I need to install? Or what am I missing? Thank you!

If you connect via Ethernet you have to set it up manually. When shown the ‘Find my laser’ screen, just cancel, then click ‘Create Manually’, choose Ruida, Ethernet, give it the IP address, set the size of the work area and the origin.

Mac can work via USB, but the drivers shipped with MacOS conflict with the driver used by the chip on the Ruida, and there’s some messing around required to fix it.

This will walk you through setting up the network address on the Ruida controller:

I did all of this followed instructions changed the IP address on the controller, I have it connected with the ethernet cord. I feel like there is an issue in the the network settings because if I go to network and look at the ethernet that it is connected to, the light is yellow. So I know the connection is being made but for whatever reason, it’s being block and I don’t know how to fix that.

Do you possibly have the firewall enabled on your Mac?

Did you set the same address in LightBurn as the one on the controller? (and what did you use for the controller address?)

I do have a firewall, I turned it off. That did not change anything. (I did reboot computer)

Also, I tried changing the ethernet connection from “Using DHCP” (had a yellow light) to Using DHCP with manual address, I put in 192.168.1.150 BUT that gave it a green light. (btw this is really out of techie knowledge so I’m shooting in the dark). Again restart computer no change.

The address in both controller and lightburn are 192.168.1.118 computer is 192.168.1.18

Hoping there is some other trick to get this to work. Thank you for your help so far.

A thing to try:

  • Turn the laser on (and make sure it’s plugged in to the network)
  • Open a terminal on your computer
  • Type ping 192.168.1.118 and hit enter

The computer will start sending “pings” to the laser, asking the controller if it’s there. You’ll see either:

  • Request timeout for icmp_seq - means it didn’t get an answer
  • 64 bytes from 162.168.1.18: icmp_seq=0 ttl=128 time=x.xxx ms - means it got a reply

Press Ctrl + C to stop it.

If you got a reply then the laser is there. If you didn’t, it could still be a firewall issue, network issue, or something else, but at least you’ll be able to tell if/when things are getting through.

Ok. I tried that and unfortunately got the Request timeout for icmp_seq

Well at least that says it’s a network or hardware issue. When you power up the laser controller do you see “Lan: On” at the bottom right of the display on the controller?

Do you have an Ethernet port on your computer? Macs are usually smart enough to plug directly into the laser with a network cable.

You could also try connecting to the network port on the controller itself, inside the case of the laser, instead of connecting to the port extension that’s on the outer shell, as sometimes those extensions are faulty (or just loose).

Inside the laser will be a box that looks like this (probably vertical):
image

On the right side of the image above you can see three labels: Ethernet, UDisk, and PC-USB. They are for the Ethernet port, the USB thumb-drive, and the USB cable. If you plug the network cable right into the controller that might help.

Yes. It says Lan On.

Yes, I have an ethernet port on computer. I plugged cord directly from computer and directing into controller. Tried the ping and got request time out response.

Then tried from computer ethernet port to hub to controller same response with ping the ‘request time out’

Well, it sounds like you still have the network configured wrong, or it could be that the network port itself is the issue. Try with USB instead, but do a cold boot of your computer first. That should allow the USB port to work the first time. If that works, I can point you at resources to make it behave.

I did shut down the computer totally, restarted plugged usb computer and usb in usb hub to machine port. Went to light burn and added it as a usb connection but it didn’t recognize it.

So…new plan…I hooked up my mac book (we’ve been try to get the desk top to connect), using a thunderbolt usb and IT WORKED! So, I’m fine with that, it doesn’t solve the mac desktop connection but I can design on my desktop (when my hundreds of fonts are) and share in the iCloud to my MacBook to cut. I did run a test cut so I know its all working. Thank you so much for trying to help me. I’m sure I’ll have other question :wink:

Based on the “new plan” results, this would lead me to want to check the cabling and ports used in the initial unsuccessful connection testing you did.

Additionally, you will want to move the desired font(s) used in your work to the other machine OR convert your text to paths to ensure the “look” you want transfers to the other machine.