Lightburn not recognizing my laser

Hello, So I know this has been posted before, but I haven’t seen any resolutions, so I’ll try my luck.

I just purchased a 50W Blue-and-White laser with a Ruida controller. Connected my laptop (running Windows 10) and ran the Device Discovery Wizard, and it will not recognize my laser. I get the “Device Info” screen like it’s searching, and nothing ever comes up.

I have tried turning the laser off and on, restarted the computer, tried different USB cables (even bypassed the terminal outside the machine and plugged directly into the controller), and downloaded RDWorks and it would not connect through that either. Both Windows and LB versions are up to date.

Any ideas would be appreciated!


  • Are you connected with USB, to the ‘PC-USB’ connection on the controller?
  • Did you install the FTDI driver at the end of the LightBurn install?

The fact that RDWorks doesn’t see it either suggests that it could be a physical issue - it uses a different driver than LightBurn uses by default. Check the connections, make sure that you hear Windows ‘ding!’ when you plug in the USB connection, and try a different USB cable if you have one.

It’s also worth checking to see if you can connect directly to the controller box inside the laser, not just the port in the outer casing. The control box has a small extender cable that feeds the port in the machine casing, and sometimes those are faulty.

Thanks Oz. Problem resolved! The thing you mentioned about the Windows ding when you plug in the cable had never occurred to me🤪 I wasn’t hearing that, so I checked and updated my drivers. Next time I plugged in I heard the ding, and bam, I was up and running.

Thanks again, this community is so helpful.

A post was split to a new topic: LightBurn not connecting to Ruida

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.