Lightburn not seeing USB

I own an Omtech 50 Watt maching. I have the usb connected to the computer, I upgraded Lightburn to DSP, I deactivated and reactivated with the key, I’ve searched for the drivers I think I need (D2XX for the FTDI driver), I uninstalled and reinstalled and Lightburn and clicked to install the FTDI at the end of the installation process and Lightburn is still not finding the machine. Am I missing something. Please help!

Have you tried adding this laser manually? If find is not successful, try adding this device manually following this procedure: Manual Creation - LightBurn Software Documentation

Let us know how you get on, and we can assist further. :slight_smile:

Did you get this work? I have the same machine and the same problem.

Same issue would get the same recommendation. :slight_smile:

Yes, I have tried so many different things, nothing seems to work. I have spent so many hours trying to get this to work. Even different laptop with clean install of Lightburn and drivers. Right now I have to copy to flash drive and plug it into the machine and copy the file to the machine to do anything.

We have many folks successfully communicating with a OmTech laser with a Ruida controller, over USB, so we can confirm this setup works.

To offer direct suggestions, we need more information than provided. What version of LightBurn running under which OS? Have you tried any other software and found success talking to this laser? What can you share about the computer used, are these active and known good USB ports? I would also check to ensure the USB cable is also known to be in good working order.

Check that all USB cables are seated correctly, and check the short USB cable inside the laser that goes from the main control board to the external plug on the cabinet. We have seen those come loose in shipping or need replacing. Do you hear the computer “chime” when you plug the USB cable into the port?

Fundamentally, more information would help us know what, “I have tried so many different things, nothing seems to work.” really means, technically.

I was able connect to the laser for about 10 minutes and in the middle of sending a file to the laser it lost connection and I have never been able to get it to connect again by either USB or network cable. I have the latest version of Lightburn on Windows 10. I tested other USB devices and confirmed that the USB port is good. I have not tried replacing the USB cable since it is brand new but I guess that is worth a try. The computer does “chime” when I connect the laser to it.

So, it just stopped communicating via USB? I would look to the supplier for additional diagnostic procedures to ensure you have a good control board with working USB port.

You also say you can not connect via Ethernet. Please describe what you tried, what settings were used, and the results. The details matter when looking for feedback. :slight_smile:

This is worth review: How do I connect a Ruida controller with Ethernet?

Another test to see if this is a LightBurn software issue, can you connect using RDWorks over USB? Additionally, you can roll back to an Older Version (9.20 or earlier) to see if you can connect consistently.

I connected that day. I turned it on today and it’s showing disconnected. I tried to manually connect and I’m getting the same results.

I can’t believe this but I got it working and I can’t believe that is was just a $10 USB cable that fixed it. Very weird that it just stopped working while in the middle of being used. I spent so many hours trying everything I could think of and it was a stupid USB cable. :frowning:

1 Like