Lightburn or office, that is the question

I finally got ubuntu loaded into my pi-4b/4g SBC. Now I am trying to install LB trial / (lightburn-linux64 v1.2.04run. after downloading trial, I click open file and I get a window that pops up and wants to know if I want to use text editor or librea office to open the program with. Is that right?
Randy

Nope. you want to run it, not open it.

The Linux installation doc gives the process:

That should get you started …

I didn’t think Lightburn ran on the PI cpu architecture.

From my understanding, some of the external routines used don’t support it’s architecture.


If it’s a ‘run’ version then it should just execute.

Check to ensure the module is marked as executable.

Keep us up to date…

@JohnJohn can probably settle this… :pray:

:smile_cat:

@NicholasL answered this the last time it came up. As of now this does not work.

Hypothetically, with x64 emulation I think this could be made to work but I’ve seen nobody attempt this publicly or any definitive findings about doing this. I think something like box86 or box64 could be a start.

1 Like

Pfffft!

Good point: LightBurn requires an x86 CPU, not the Pi’s ARM architecture.

Soooo, even though the Pi runs Linux, it can’t run the Linux version of LightBurn.

Apparently I have too much blood in my caffeine stream today …

More specifically it can only run on Linux with an X86 type of architecture…

:smile_cat:

Hello to all: I would like to take a minute to say that I have not had time to respond to all of you. 1/7/23
I had a death in the family and have been very busy. Have not even had time to fire any lasers. And the good news now – I had great grand baby #2 born 1/21/23. This one is a boy. ( I’m all ready looking for his first 22 single shot rifle, I got mine when I was 7.)
Back to the pi – I got Ubuntu 22.04LTS desk top loaded to my sd card, and it works really great. It has all kinds of cool stuff preloaded in it. It even had my Thunderbird mail in it. Now - I loaded up another sd card with 20.01 and it worked really well also.
My new problem is when I flashed 20.01, somehow I made it so that it write protected. When I try to write,
a window pops up and says to make sure the switch on upper left side of the adapter is all the way up. Can I wipe that protected sd card clean and start over again? Or am I out of luck? I want to load 19.something up on it.
Randy

If the sd card has a switch it’s probably a write protect and I’d switch it the other way…

Seems funny that you could write to it, then it was write protected…?

I also have Ubuntu 22.04, but haven’t written anything for the PI with it.

:smile_cat:

hello jack: I have tried that switch at least 20 times. I even found this site and tried all 3 ways to fix –

Nothing worked. I’ll keep looking and trying !!
Randy

You should be able to format it and re-install the image… If you can’t then the SD card may have failed… although doubtful, you have to be able to write to it or it’s useless.

:smile_cat:

Jack: I did a lot of searching and one place I found, said: If you can’t format or flash the sd card then try putting a tiny piece of clear scotch tape over a notch. That notch is on the “right” hand side of the card, or adapter if using one, the notch is straight across from the slide switch. Be careful not to cover any of the contact points with the tape on the back side of the card.
I did that and it worked !!! I formatted the card and then installed Ubuntu 19.3 cinnamon.
I can go into 19.3 and see everything. Looked like a clean install to me. “AND” then a window popped up and said config.txt file does not exist Oh boy – here I go again, back to searching for,
what is and where to find/create said file. Have any pointers to send me in the right direction on my quest for knowledge ?
Randy

If you wrote an image to the sd card, it should have a config.txt as part of the image.

I’ve never seen this on the images I’ve loaded or it was created by the installation software… I remember it asking me some questions.


What are you going to use this for?

:smile_cat:

Well, I’m going to get L.B. to work on a PI one way or another using Linux. Everyone says it can’t be done because of this computer ARM thing? I have no idea what that is, but I’m starting to learn, I THINK !! When I first started this project I came across a site, (I booked marked it, forgot the name for now). That guy said he used Ubuntu Linuxmint 19.3-cinnamon-32 bit .run and to use L.B. Inux63-V1.2.01. He also said you had to do one or two simple, simple steps. Now I have to find that bookmark. I don’t remember the name and I only have about a thousand book marks logged over the last 15 years. ---- My first sd card I loaded Ubuntu 22.? and it works great in the Pi. I love it but no LB. Then I loaded another sd card with 20.4 on to the PI and it worked great also. Then I came across this guy saying, use linux 19.3 and LB V-1.2. So I tried reloading the sd with 19.3. had trouble with write protection, got that fixed. Now I have 19.3 loaded and I am told config.txt doesn’t “exist”. I don’t know why there is no file. Ub. 22 and 20 both loaded and worked great. ------ My next plan of attack is go to the M.S.U. collage in Wichita falls and make a challenge with the computer science instructor to get the students to make L.B. to run on Ub. More than one way to skin a cat !! Once I get this first PI up and running, I’ll only have 3 more to do !! Well, I off to town for now, trying to beat 2" of snow coming ! By for now.
Randy

What it means is the compiled machine code executes on an X86 computer and the one code will not run on the other…

Try running Apple Mac OS on a PC… machine code is not compatible.

The PI on a Raspberry stands for Python Interpreter.

If you think you’re up to it…


I love it that you’re optimistic, but you are not going to catch up to 20+ years of computer in a couple hours reading… I’ve been in hard/software for 40 and I am still behind in the technical end of this…

Good luck

:smile_cat:

Thank you for the kind words. – I’ll be long gone before I get 20+ years in. I implemented my plan “B” today. - I called the collage today but no luck today. We had call for 2" of snow today, the collage closed for the day. Try again tomorrow. 2" of snow in my part of Tx. won"t even stick to the streets.
Thank you for the info. I’ll give you an update after I talk with the collage.
Randy

@berainlb is doing what you are attempting, his approach is an emulator running on the PI.

Did you click on the link I provided and read it?

Probably the most reasonable approach I’ve seen.

Good luck

:smile_cat:

Yes I did ! I read it , booked marked it and then printed it off. Added my hard copies to my vanilla folder with everything else I have. – I talked to the college a little while ago. A young lady in the Computer Science Dept. said that she was the one of the assistants to the professor and she liked the idea of my challenge. – She took my # and name and said that the professor would give me a call back later. (I don’t when later is, may be never). We will see. I’ll let you know if/ when I hear back form them.
Randy

Great… maybe you sparked a fire :crazy_face:

Keep us up to date…

:smile_cat: