Lightburn origin is "drifting"

I totally agree about my lines look like sh.t, but I would like to take one step at a time.
I believe, that all mirrors are firmly in place and secured and belts are pretty tight, about like a bass guitar…
It doesn’t explain the difference between the Lightburn and the RDWorks offset.
You asked for pics of the machine…

Actually it could - They plan the cutting in a different order, and the order of the cut can make a huge difference in the amount of induced resonance or machine slippage. If your machine is wobbling that much when running simple straight lines, your issues are almost certainly all mechanical, and it’s just the different cut order that’s causing the LightBurn output to make the machine slip more.

Ok, Oz. I might make sense…
So I should make the testfile, so the cutting order is exactly the same in both Lightburn and RDWorks ?
BTW: How tight is tight enough for the belts ?

That would be a much more accurate test, yes.

Regarding the belts, it’s hard to say with words - they shouldn’t be stretched, but they shouldn’t have any slack in them either. If they’re much too tight they can wear too fast, and cause vibration, but it would be from the pinion teeth impacting the belt teeth, and would look much different than what you’re seeing. That looks like a loose mirror mount, lens, or a bad bearing block on the laser head.

Thanks, Oz.
I’ll lok into that tomorrow, almost bedtime here.
Will check mirrors and lens are secure, bearings for free run, and I think I might loosen my belts a tad.
Then make a file that runs equal in Lightburn and RDworks…

Regards, Kim
Checked mirrors and lens, all secure and in good shape.
Have checked the rails, and they are all running smooth.
To check the rails, I had to remove the belts, and when I mounted them again, I didn’t made them as tight as before, and that seems to have improved on my lines.
See before and after picture.

It didn’t solve the offset problem, but see my answer to Daboo

I had a similar issue when I received my new laser with a ruida controller. It drifted when it moved to the left after moving to the right. I turned off “pwm rising edge valid” in the controller settings under the x axis settings and that solved my issue.

1 Like

BINGO… Thanks David.
I had to turn off both X and Y “pwm rising edge valid”, but then it solved the problem.
I attach a picture, where I first ran the Lightburn file, and then the RDWorks file on top of it, with the same origin.
And… TADAA, no offset


It’s very curious that this didn’t happen with the RDWorks version but nonetheless, congratulations to a significantly better output and in the end with a quite small change. :+1:t3:

Now you could tinker with your acceleration settings again (change them back or increase them step by step and see how far you can go with still a clean output).


It depends on where the direction changes happen - for the output to shift, you have to change direction in X at the same time as continuing a move in Y, or vice versa, and if you perform the opposite moves, it’ll “undo” the lost step.

I haven’t seen an offset due to the ‘rising edge’ setting on vectors before - usually it’s so small that it’s nearly imperceptible, but this test has enough direction changes in it that it’s obviously showing it as well.

The usual giveaway for the “rising edge” issue is when an engraving leans to one side, like this:

Thanks for jumping in here Brian - I’ll have to remember this one myself. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.