Lightburn origin is "drifting"

Have a problem, that my origin “drifts” when I use lightburn.
So I have created a testfile “testpattern.lbrn2”
When I run the file from Lightburn I get a 3mm offset, which is visible if I run the file twice.
If I do a reset on the laser, the origin returns to the original place.
If I upload the file from lightburn to the Ruidacontroller, the same thing happens.
Then I tried to export the file as DXF, and import it to RDWorks.
Uploaded the file from RDWorks to the controller, and ran it twise as I did with the Lightburn file.
There is NO offset if the file that comes from RDWorks, but 3mm offset in the file coming from Lightburn.

Testfile and picture of the result is uploaded…
The picture shows the result of the file, after is has been run twice on top of each other

How can that happen ?

Regards, Kim

testpattern.lbrn2 (87.5 KB)

That might be a problem related to backlash. First thing I would try within LightBurn is to check if the “Hide backlash” feature within the “Optimize Cut Path” settings is enabled and to check if your outcome is any different if you enable it. I think RDWorks is doing some “Hide backlash tricks” by default.


Hi Brian

Backlash setting was off in my optimizing settings.
Turned it on, and ran the file.
It made no difference in the result.

Rgds, Kim

How are you connected to the machine? (USB / network cable / wifi?)
Did you use identical settings for speed & power in RDWorks?
Do you know the exact model of controller you have in your laser?

1: Connection to machine is via cabled network.
2: Yes. 160mm/sec in both lightburn, RDWorks, and in both *.RD files
*.RD files were loaded into machine via Udisc (USB-drive/key)
3: Believe it’s a Ruide 6442G controller. When reset, it says RDC-V8.00.50 and HMI-V4.01.21
80W CO2, Bed size 90 x 140CM.

With such a big machine you most certainly will have some issues regarded to backlash but if the “Hide backlash” feature from LightBurn doesn’t lead to any different output there is probably something different going on.

Could you attach those two .RD files, the one that works well for you (from RDWorks) and the one generated with LightBurn? I would be interested if and how they might differ.


Hi Brian.

Right, the ”Hide backlash” made no difference.
Not able to upload *.rd files in forum ?
I will mail them to directly

Thanks for looking into my problem 

Regards, Kim

Could you please try the attached LightBurn file as it is (but please make sure that the “Hide backlash” feature is actually still enabled). I would really like to see the outcome of this. If possible please post the result here and describe briefly how the laser has actually traveld while etching your target. It should move row by row from top to bottom and I assume it had some wired pattern before compared to the RDWorks file?

testpattern_new.lbrn2 (313.6 KB)

Furthermore, here are the .RD files from you, as you were not able to upload them. Maybe someone else does find them useful (I only added “.txt” at the end of the filename, please remove these upon downloading those files).

testpatternlghtbrn.rd.txt (32.9 KB)
TestpatternRDWorks.rd.txt (34.2 KB)


Have you tried using LightBurn in ‘Current Position’ mode instead of ‘User Origin’? The RDWorks file is using ‘Current Position’, so I’m wondering if that could be the difference.

There are other differences in the file structure as well, but the cutting instructions are ordered quite a bit differently - the Ruida version has slightly fewer ‘jumps’ in it - IE, traversals across longer distances, so it’s possible that your ‘Idle Acceleration’ value is a bit too high.

Try this:

  • Press the Pulse button on the controller to make a pulse at the starting point of the job
  • Run the LightBurn version of the file
  • When it’s done, press the Pulse button again.

Are the two pulses in the same place? If they aren’t, it means the motors slipped while the job was running.

Att. BrianF84
Here’s a link of a video of the file you sent.
Made a pulse before I started, so you can see, that the origin has shifted aprx. 5mm “northeast” after finish. See JPG in link :slight_smile:

I notice, that some circles are made clockwise, and some counterclockwise, and the cross are made after one circle in the buttom last row

Att. Oz.

“User Origin” / Current pos. change made no difference.
Yes, my theory is also that it has to do with accelleration.
Can I slow that down in Lightburn ?

Go to ‘Edit’→’Machine Settings’.

Machine Settings

Opens an editor that allows reading and writing firmware settings from supported controllers.

Hey Kim,

thank you for sharing especially the video of your job, it was very helpful for me. You already loose your position while the laser is working on the circles so what I would suggest next is checking your Machine Settings / Cut Parameters and decrease the Idle and Max acceleration values (write them down before you do and do a Save of your settings before!).

The Dialog within LightBurn should look something like this:

So here is how I would proceed if I had that issue:

I don’t think that you have to always do the whole job to see if it improves, I would just use the original settings, start a job and maybe run the first line of circles and hit the stop button. This will move your laser back to it’s previous origin and you could do a pulse again and compare it with the first one. You will soon be able to see how many circles are necessary to get you noticeable off.

Check that back after decreasing the Idle / Max acceleration values and see if your situation improves. At first I would probably decrease those values to a very low value just to be sure that they have an impact. And don’t forget to write them to the laser after you change the values and read them back just to check that all went well.

Good luck and cheers,

First picture is the original settings.
Second is what I changed it to.
It made no difference. Still offset in origin…

Hmm… that values are not very high. Have you noticed any difference while watching the job? Was it noticable slower than before? And can you please try to narrow down how much your the job has to be done to get you out of your origin?

Please try to only do a “Frame” of your job and see if it will return exactly to the same origin as before by doing a short pulse, frame and pulse combination.


Try lowering your ‘Min Acceleration’ value as well - it’s currently set to 100, but lowering that could help. What kind of machine do you have, and more specifically, what size is it?

Att Oz.
Machine is red/black china, 80W CO2, Ruida 6442G controller, bed size 90 x 140cm
Ok, tried with these settings:

Att. Brian.
Tried to do the frame and cross, and then the same with 3 rows of circles, then the offset becomes visible.
If I only do the square and cross, there’s no offset.
Made with the same cut settings as my answer to Oz.

Your lines and circles are in general and compared with the not too high acceleration very shaky. Can you please check your belt tension and report how loose or tight they are? As well as if the lens is sitting tight within the tube and the tube itself has not much of a play (try to push/pull the laser head tube while the machine is on and see if it is able to move it a little).

And please try what Oz has mentioned as well, reducing the min. acceleration.

Despite not fully understanding why the RDWorks output is that much better I would bet that you have some serious mechanical issues that also relate to the drifting origin you are experiencing.

Maybe it could also help if you could post a picture of your full machine bed (including the mechanical driving parts in the back and on the sides and the stepper motors). Maybe I can spot something that might be an issue. I had a cheap blue and white Chinese laser and had all those issues you are facing right now (and some more) and decided to build a new one from scratch by myself and I have learned quite a lot on that road.


You have something fairly wrong in your mechanicals somewhere:
A straight line should not look like a drunken lightning bolt. :slight_smile:

As Brian says, I would look to make sure all your mirrors and lenses are tight, belts are tensioned properly, and also check that none of your bearings & set screws are loose, missing, grinding, etc.