Lightburn Says connected, but will not move laser head or run projects

Hi all, I’m pretty new to the laser world and have had an on-and-off issue with Lightburn when used with my Cohesion3D Laser Board (Smoothieware) installed in an OMTech k40. I run on 2018 Mac (Latest OS) right now but have had issues on earlier versions as well. My laser powers on fine, and I can manually pulse the laser on my K40. I checked the smootieboard troubleshooting, and tested the board with everything unplugged and the LED’s indicate normal operation - no errors. I also have replaced the factory Blue USP cable with an Amazon Basics cable. I have correctly setup my smoothie board with Lightburn and have had a number of successful cuts with no issue.

HOWEVER. Periodically, when I turn on my laser and connect to my Mac, LB will say it is connected fine, but when I try to jog, home, or run the project, nothing happens. When this has happened in the past I just shut everything down and try another day, and it feels 50/50 whether it works or not. When it works, it works great! I feel like I must be missing something silly, but this has been a VERY frustrating experience, and none off my google/forum searches have yielded a solution.

One thing to try. When you have this issue, check the serial port that’s being used in Laser window.

Manually select the actual proper port for your laser.

If you turn on your laser prior to opening LightBurn it should connect to the same port as previously but that’s not necessarily always the case either for various reasons.

1 Like

I have to remember my port. I get 3 port options. If I choose the wrong one it will say it’s ready but will not move.

1 Like

This definitely seems like it would be the solution! How do I found out the actual port? and how do I select it? This is where we are getting way over my head :wink:

Screenshots of my USB Device tree and of my options on Lightburn:

It’s almost certainly the “cu.usbmodem142201”. Try selecting that one if in doubt.

1 Like

Thats what I thought as well, but console says port failed to open? I don’t have anything open on this Mac but LB, Safari, and Finder, so IDK what is blocking the connection?

I’m not currently on a Mac to confirm but can you run something like this in Terminal:

lsof | grep usbmodem

That will return processes that may have the port open. Then run in Terminal:

ps a | grep <PID>

Where is to be replaced by the process ID identified in the previous command.

Can you return the output from that?

1 Like

With the first command, here is what I’m getting:

LightBurn 2042  Ben    9u      REG                1,4        50            16785206 /private/tmp/
LightBurn 2042  Ben   10u      CHR                9,7      0t37                 845 /dev/cu.usbmodem142201

With the second, using the number 2042, I’m getting an error:

zsh: parse error near `\n'

The second command failed but the first command gives enough information to indicate that it seems only LightBurn is holding the port.

That’s odd. What happens if you quit LightBurn and rerun the command? Then open LightBurn again and attempt to reconnect.

Nothing shows up when I run the command after closing LB, when I open back up, I get the same code back as above.

Try this:

  1. Quit LightBurn
  2. Turn off laser
  3. Turn on laser
  4. Open LightBurn

Does anything change?

Slight change in numbers (I’m not sure if that matters), but still doesn’t work.

LightBurn 2203  Ben    9u      REG                1,4        50            16788062 /private/tmp/
LightBurn 2203  Ben   10u      CHR                9,5      0t53                 889 /dev/cu.usbmodem142201

Numbers don’t matter because when LightBurn was started again the OS assigned a new PID to it.

It’s a bit of a head scratcher. Do you have another USB cable that you could try? Are you connected directly from computer to laser? Or do you have a hub in the middle?

Tried the factory blue cable, Amazon basics cable that I bought to replace crappy factory cable, and then a random USB cable I found while digging today. Going through a USB hub/adaptor as my Mac is USB-C and needs to connect to the 2.0 cable. However, I have the same issue on an older Mac with the standard type-A where I can plug the cable in directly, so I don’t think it is the adapter.

I’ll also repeat that I have had success cutting with this setup, but for reasons I can’t explain it sometimes just DOESNT. LOL

To be clear, hubs can at times cause issues. Not clear if it’s the issue in this case obviously. Do you have a dedicated USB->C to USB->A female adapter that’s not a hub that you can try?

I’ve heard of some people having problems with USB-C ports in general. Those I think are typically where it’s a USB-C to USB-C on the laser. Oddly enough, adding a hub has been the answer in those scenarios.

Not sure what else to try, you may want to consider rebooting and possibly resetting the SMC on the Mac.

ugh. Tried running the same code on the console of my older Mac that connects directly without a port, and had the same code back. Tried another hub I use for my iPad, and same results as well. Tried a reboot, and noting. Will an SMC reboot hurt any other programs/etc on my laptop?

It shouldn’t and is widely done but it’s still a computer so I’m sure there are cases where this has caused issues. It’s not generally considered a risky step. Having said that, I’ve done this many times without issue across multiple computers. Read more about it to determine your comfort level.

1 Like

Did the reboot. Same issues. Hoping you or someone else might have a new clue?

Perhaps move attention to the controller side. Is everything properly grounded?

You indicated you have this problem on two computers so it’s possible the issue is on the controller itself.

Does the Smoothie board have an SD card? If so, try removing and reseating it a few times.

1 Like