Lightburn stops in middle of project

I continue to have issues with projects stopping about half way through, I have tried the following:

NEJE 2S MAX with 40W and 3.5 W heads

Lightburn v0.9.20

Lightburn v0.9.21

Lightburn v0.9.22

Lightburn v0.9.23

Used neje_grbl_uploader_v3.2.exe

Set uploader and Lightburn to 1.1f 115,200bps baudrate

Set uploader and Lightburn to 1.1f 921,600bps baudrate

Set uploader and Lightburn to 1.1f 2Mbps baudrate

Disabled USB sleep settings in Device settings

Disabled all power saver and screen saver settings on PC

New USB cable with ferrite chokes

Tried both 3.5w and 40w laser heads

All projects just stop about 30-45 minutes in and don’t resume. The console log shows the project start, then the STOP I issue.

I have tried multiple projects including test from North Lakes Woodworking, same results

I recently tried to enable debug mode on lightburn and see commands just stop, then my STOP.

No loss of connection or any errors on console.

I plan to post on several sites, so I apologize if you see more than once.

What else can I do? I am running out of ideas on what to do next

4 posts were merged into an existing topic: NEJE Master 2S Max stops in middle of project