NEJE Master 2S Max stops in middle of project

I continue to have issues with projects stopping about half way through, I have tried the following:

NEJE 2S MAX with 40W and 3.5 W heads

Lightburn v0.9.20

Lightburn v0.9.21

Lightburn v0.9.22

Lightburn v0.9.23

Used neje_grbl_uploader_v3.2.exe

Set uploader and Lightburn to 1.1f 115,200bps baudrate

Set uploader and Lightburn to 1.1f 921,600bps baudrate

Set uploader and Lightburn to 1.1f 2Mbps baudrate

Disabled USB sleep settings in Device settings

Disabled all power saver and screen saver settings on PC

New USB cable with ferrite chokes

Tried both 3.5w and 40w laser heads

All projects just stop about 30-45 minutes in and don’t resume. The console log shows the project start, then the STOP I issue.

I have tried multiple projects including test from North Lakes Woodworking, same results

I recently tried to enable debug mode on lightburn and see commands just stop, then my STOP.

No loss of connection or any errors on console.

I plan to post on several sites, so I apologize if you see more than once.

What else can I do? I am running out of ideas on what to do next

RESOLVED - Grounded rails and head

So the NEJE is also having static electricity issues just as the Ortur machines have. Interesting and thanks for posting you found the solution.

I spoke too soon. same issue is back!

it’s a long shot but try another USB port on your computer. I have one which is flaky in that sometimes even the slightest move of the cable causes a connection error. Might even try a USB hub if you have eliminated all possibilities of your operating system doing dumb things. Windows is well known for doing what Microsoft decides is best for you and whenever they decide.

Thanks, its a brand new pc, tried both USB ports and new cable with ferrite ends. still the same.

when this Stopping event happens can you still control the machine? ie hit the HOME button in LightBurn and it goes to the home position? I don’t know what firmware NEJE uses but once you figure that out see if you can find any information on commands to send the controller to see it’s version and/or it’s settings and try entering those into the Console command field. For GRBL type firmware you can enter $$ and it will show you the settings. This will help you understand if you still have control connectivity.

You could also have a bad power supply. Often they send cheap power supplies which over heat or glitch when run for any length of time. My Ortur takes 12VDC input and has the same polarity as many 12VDC LED light power supplies and people have verified polarity and used those power supplies successfully on Ortur machines.

When it stops, it status bar show around 35-45% complete, Busy and the time keeps incrementing. I am able to hit STOP, then HOME and it responds. it is GRBL 1.1f 2M baud

IIRC the NEJE use an 8bit controller and you stated GRBL v1.1f, are you using the LightBurn device setting of “GRBL” and not any of the other GRBL options?

Also, is this a design created in LightBurn and not one exported from another package?

The other thing I would do is look for what Ortur recommends for DIY static electricity grounding just in case you didn’t do all the things needed to prevent static buildup.

Things you can also do to test what’s going on is to create a low power burn which is so low power it doesn’t even mark anything and see if that too stops. If it doesn’t, it could indicate a power supply problem. If it does fail then it could be static discharge.

The other thing to test after the above 2 things, is to slow the machine to 50% of what you are currently running it at and see if there’s any change in where it fails(35-40%) or is it time related? ie at 50% speed it’ll take 2x longer and at the same point in time as when you hit 35-40% previously it should only have completed ~20%.

Had same problem,very frustrating and literally took a lot of the fun out of it.I did everything you did to correct…sometimes it would be ok and most times it would stop especially during raster not vector. I was using 32 bit windows 7 pc. I wanted to get some software that wasn’t supported by windows 7 so upgraded to Windows 10 64…same parameters accross the board. I haven’t had one single problem since.

@norcalnate, I merged your double post (please don’t do that) here, as this one is providing the most responses.

I can not count how many times Microsoft Windows was ‘the problem’… one of the many reasons I dump Windows over 20 years ago. Just hate magic and unexplained things and especially in computers.

I was at a store the other day to purchase something which stated online that the store had 5 in stock but the shelves were empty. The worker said ‘oh, that’s how computers are, sometimes things aren’t what they’re supposed to be.’ She gave me a scowl when I told her, ‘no, computers do exactly what people tell them too and keeping track of stock is one of the simplest things a computer can do.’

So you now have no clue what Windows was doing but a new version of Windows seems to work for now. yay.

Agreed! But knowing better and being an iOS person with everything but my CNC’s and iTunes. So in my case probably self inflicted as win 7 support,driver updates,patches no longer exist. An upgrade for me was overdue and machines running happily again. I’m still running large router table off of parralell port on the win7 machine too

Hi, I had this same problem on my CNC many years ago and it was my USB. I bought a decent hub and never had another problem.
I now use this same hub on my NEJE master 2s max and have no issues.

1 Like

Our neje master 2smax 40 watt is doing the same exact thing any updates

I ended up reflashing the board using NEJE software update tool. Removing the device from light burn. Adding it back in with default settings and it seems to be working well now