Lightburn stops in the middle of project

My lightburn program is stopping in less than 5 minutes after starting a project.

I can’t seem to figure out what to do. I have completed several projects recently without incident.

I have a Jtech 7w diode laser attached to a Shapeoko 3 xxl running GRBL.

Does anyone have any suggestions?

With my limited experience with the program it’s my understanding is Lightburn uploads the program to the lasers memory. I may be wrong, at least that is what mine does. My first thought is your laser memory is full. Clear it and try again.

do you know where i might find the laser memory

Well, something has changed then. Let’s see if we can help figure out what is going on and get you sorted.

Does it stop in the same place each time you run this job? Does it stop at the same time with a different job? How are you connected to the laser? What OS are you running? Have you done an OS update that might have changed your comm sleep settings?

I sent you a link to the JTech setup page when you asked this question via our support email. Did you get a chance to review and compare your settings to those described in that document?

Try to provide all the steps you have tried and the results so we can best direct our diagnostic process. More is better in this case.

Yes I did check out the link. Everything is okay as described in the link. My computer did update last night however the sleep settings are set to Never on the computer settings.
It does not stop at the same place when I run a job, nor does it stop at the same amount of time, but it always stops in less than 5 minutes.
The laser is connected to the control module for the Shapeoko. We are running Windows 10 Home 64 bit.
Can’t locate comm sleep settings?

With a GCode controller, there’s no memory being uploaded to - the job is streamed live, so anything that could interrupt the USB connection is a suspect. Read through this topic as a starting point:

I did as the article said and the problem continues. I have even reinstalled lightburn and the problem persists.

Look for USB sleep or USB selective suspend. I can’t recall, but they might actually be different settings on Win10. Here’s the selective suspend doc: https://www.hamoperator.com/Fusion/FusionFiles/K9EQ-Fusion-PDF-0023.pdf

And here’s the USB port sleeping / power shutdown settings: https://www.pcworld.com/article/3045567/how-to-keep-charging-your-usb-devices-past-your-pcs-bedtime.html

I have done everything in these articles also and I am still having the same problem. I am wasting material like crazy trying to figure this out. I greatly appreciate the suggestions though.

Lightburn finally gave me an error popup that said that it had lost communication with the controller. so I dismantled my entire computer set up and cleaned all of the connections and gave my shop a thorough cleaning. I made a surround to prevent any dust and debris from getting to the computer or any connections.
After reassembling everything, my connectivity problem seems to be solved (hopefully). Live and learn. I would like to thank @LightBurn, @Rick, Toolcrazy for all of their time and suggestions.

1 Like