Lightburn update is terrible

I just allowed the update and now nothing works correctly. Origin is forgotten every time I shut down. I have to use the handheld controller to go back to origin… and 20 minutes into a burn the thing went crazy and started burning everywhere. I shut everything down, restarted computer, power cycled the laser and then it did it again after 2 minutes. Ruined cutting boards… LB was awesome until this update! Now I cannot trust it.

With this attitude you not going to get very far with these people. This forum is unlike many others, they just don’t answer complaints worded as yours are.

Joined 9 hours ago and have only read 5 minutes, and this is your first post…

You need to relax, maybe a cup of coffee.

I’ve upgraded so many times I’ve lost count. I haven’t had a single issue like you describe. Lightburn doesn’t modify the configuration during an upgrade, so it should be transparent.

My main machine is a China Blue 50 watt co2… However, I have 3 cnc3018 and they were the first machines I used Lightburn. Other than learning cnc machines and the other technical information, I had no issues.

It’s pretty clear that there is a configuration issue.

Have you gone back through the setup (did you go through the Lightburn setup) to ensure the machine and configuration is as it should be?

If there are problems, I’d guess they are in the ‘Device settings’ under Edit.

How did you install this ‘update’.?

Don’t post stuff when you are mad, anywhere, it’s not a good reflection on you and we have a hard time helping you.

Help us help you.

If this is really how you feel, then you should abandon Lightburn and go back to the Chinese software junk where there is no support and no one who will listen to your complaints.

If you want help there are many ‘wizards’ here that can, but they won’t if your posts are offensive.

We welcome you, if you will settle down a bit changing the rants and raves to something we can help you with.

Good luck



ok, so maybe I vented. I apologize.

I changed nothing in my configuration and I have never had an issue. I had been ignoring the update because I wasn’t sure what it was changing/adding and now it is doing what it is doing.

I don’t have anything fancy. It was a Mysweetie CNC3-3018Pro that I have been using for about 4 months. I had ran out of boards when my jointer went down and took a while to get the parts. When I came back to it I ran a couple of practice runs on a new design and they were great, Installed the update and now not so much. These are 2.5 hour burns that I was always able to walk away from and come back later so it was more than a little frustrating when this happened last night.

I have double checked all of my settings and I have not written any custom macros or Gcode. Lightburn was the berries until now so I would obviously love to be able to use it again.

As for how I installed the update; I finally decided to click Install when the notification came up that there was a newer version.

As for what exactly is happening; I framed the image and the extents were correct so I ran the burn. I came back to it after about 20 minutes just to look at it and it had somehow changed the image position and randomly moved it to the right about 100mm. I went back and shut everything down made sure connections on he machine were tight and then rebooted… Repeated everything above and it the image shifted before I even walked away. That is when I went searching for complaints about the update or how to revert to the previous version when I found this forum. The only change I have ever made is the update.

Any help or advice (other than throwing away this machine) is greatly appreciated. I am trying to earn enough through this machine for a Glowforge. The wife would kill me if I spent that much on a hobby without showing its more than that…lol

2 posts were split to a new topic: Home vs. Origin at end of job - with Ruida Controller

The Glowforge is expensive and is operated by proprietary software.

It is incompatible to any other software package including Lightburn.

You need for it to ‘on-line’ to a live Internet for it to operate. No internet, no Glowforge… A couple good reasons not to buy a Glowforge…

Glowforge is not a grbl machine and any macros would have to be done in their software… which is doubtful it’s supported. :frowning:

Did you go back through the original Lightburn setup?

You need to do this, it would be much quicker as you seem to have so many issues.

Sorry, don’t know much about Windows 11.

Good luck


Let’s attempt to restore a set of LightBurn Preferences (prior to your update).

in LightBurn, click File in the top row
Scroll down to ‘Load Prefs Backup’
Look through the list and select a set of LightBurn Preferences that is date-stamped from when your system was working as expected.
Select the one you would like to try.
Click Load.

I was awestruck when I saw how robust and comprehensive that list was on my computer.


I would do my homework on Glowforge lasers. Go to their community forum and see all the complaints they have when the machine does not operate correctly. They do not have comprehensive support and it can take days and even weeks for them to get back to you when you have a problem. You’re only way to contact them is via email. Your time on your warranty ticks away until you are no longer able to return it for a refund or repair.

When you’re ready to do an upgrade, ask the people here what they would suggest you try. You will get honest answers and firsthand experience on the lasers that are being used with LightBurn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.