Lightburn Wi-Fi Bridge with Raspberry Pi 3b+ (USB Question)

I just received the Raspberry Pi 3b+ for testing the WiFi Bringe. I know little about the Raspberry Pi, but I did notice as well as it having the Network connection it has 4x USB ports.
Would it be possible to connect the Laser’s camera into this and access this over WiFi as well?

Not yet, but it’s in progress.

Great news, that’s the icing on the cake for me. Thanks Oz.

To be a little more specific, this was a planned feature from the beginning, but the connectivity issue was the larger priority. Adam has the camera code getting captures and returning images, and now I have to add the LightBurn side to integrate it into all the camera functions. It’ll likely take a month or two, given how priorities shift around, but it shouldn’t be horribly long.

1 Like

I’m sure it will be worth the wait, you guys do a great job.
The network cable and the USB camera cable are the only things I haven’t yet integrated. I will be great when the only cable going to may laser is the main power.

Thanks again Lightburn Team for your efforts.

1 Like

If you are the adventurous type, there is usbip which will share a USB device over a network and I’ve seen a youtube video of a guy setting this up and using a webcam with it.

Here’s my post about using LIghtburn on a laptop in the house and my laser engraver in the back yard this weekend using usbip: Using an rPi for a wireless/remote USB port between Linux systems - Maker Forums

If there are any latency issues, I would first go to a wired network and then try an rPi4 instead of a 3B+.

Thanks for the information Doug, I’ll check it out.

1 Like

I checked my youtube history and found the video. It’s rPi <-> Linux desktop but there is a Windows client which might also work. The Lightburn Wifi Bride will probably be a better implementation as it will likely not be sending/using a camera stream and will probably use UDP also but until then, this would probably work.

The bridge will be TCP for reliability, but we’re setting it up so it streams smaller thumbnails (as JPG frames) at a modest rate, and a full-size frame only when requested by the software, to keep the bandwidth down.

1 Like

Nice and I figured you would be creating it such to reduce unnecessary bandwidth since there’s few times full streaming is needed so it’s a good fit for working well with a wireless connection. Should be a hit.

I have been able to add the raspicam stream to the ipcamdriver for a temp solution. It is showing in the camera area, I have not installed to configure it yet though. Will report back to confirm it was able to configure with enough detail to be usable.

If you use a wifi camera the you could eliminate the need for the pi all together.

I am using the Pi for connecting my Laser to my network over WiFi. I don’t need a WiFi webcam, I already have a camera on my machine in regular use but it is connected to my laptop via USB cable.
As I already use the Pi I was thinking it could also be used for my USB camera.

How did you do this? I jus setup the bridge (1.0.0.-RC3) and it is pretty cool but I would like to SSH in and setup the camera that way. I am getting stumped when it doesn’t let me SSH in.

I even added the ssh file to the boot directory. I get “remote side unexpectedly closed network connection”.

I promise, the camera support is coming :slight_smile:
But yeah - SSH should work, I explicitly enable it when building the image.
Did you try ssh-ing to it before you added the ssh file to the boot directory? Because if you did that first it may have actually killed ssh instead - I’m unsure why that happens but I’ve seen it a couple times in testing. A completely new Bridge RC3 image should have ssh ready to go once you are connected to WiFi.

Can you access the Bridge web dashboard by going to the IP of your bridge in the browser?

I did. And it may have, so I wiped the card and tried again with SSH in there

So I got the RC3 image by trying the RC2 link but the website says RC3.

And yes the web browser link works great.

Also, I just ran my first real job via this bridge. Well done; it worked great.

Doing some googling it appears there may be issues on the pi itself; is there anyway to run commands from the GUI?

I’ve been following the threads on USB cameras and what Oz is saying about a bridge in Lightburn which should provide a way for me to use an old iPhone as the camera. Seems like a slam dunk value prop to me for recycling old iPhones into my shop for this sort of work and so I want to add my voice in support of the dev work.

I picked up an Atomstack A5 Pro diode laser to play with alongside the Flux Beamo CO2 laser I picked up last year. The Beamo integrated camera is fabulous and sold me on day 1 for video workflow integration in my woodshop.

In the interim I did pick up a cheap USB camera from Amazon ( Amazon.com: Webcamera_usb 5MP USB Webcam Mini Camera,High Definition 2592X1944 Web Camera with Cmos OV5640 Image Sensor,USB Camera Module with Aluminum Mini Case,5 Megapixel Raspberry Pi Web Cam with 3.6mm Lens : Electronics that “works sorta kinda” but I’m in the midst of figuring out the X/Y offsets to make it align right. Resolution sucks with the camera I picked up but it was a cheap way to check out the functionality versus the Beamo.

For Lightburn to provide a way for us to recycle used iPhones, whose video capabilities far outstrip a cheap USB, floats a lot of boats.

Soon please?

Unfortunately, nothing in the LightBurn Bridge will allow using phones as a camera. It will still require a USB camera connected to the Raspberry Pi and even then, not all USB cameras will be supported. Most webcams should work, but they need to support a specific image protocol we take advantage of. All of the official LightBurn cameras will work and we’ll do our best to have a compatibility list available once that feature launches.

I was getting same error. I had to rebuild the ssh keys.
$ sudo rm -r /etc/ssh/ssh*key
$ sudo dpkg-reconfigure openssh-server

After that I installed the motion camera setup. The thing that cause me the most headaches was I forgot to enable the onboard camera.

How did you run the commands if you couldn’t SSH?