Lightburn will not burn

Hi,
i wonder if someone’s could help me?

I have a Neje Laser Master 2S,
I have just tried it a little with the app and software for mac and Iphone.

I am an professional luthier/guitar builder since 1993 , and I will use this machine for logo , and other stuff in the making.

I decided therefore to make a ventilated
metal box, with fan , light and a big pump for air assistants , as for professional use.

Quite soon I understand that the Neje Software was litle to simple for my use, I decided
to try Lightburn.
I like it a lot, but when first tried with my Macbook air, with USB it didn’t work, I tried a lot and read about that others had similar problem.

Then I tooked up my Mothers 10 year old PC laptop, cleaned it up, downloaded everything , Firmwire I actually think I have done everything right.
It work well in every aspect , except that the Neje will not burn, just the blue light is there.
But the laser unit moves around and so, the only problem is the non burning.

Now when I use the Neje Software for mac and Iphone , it is a reverse problem, it burn to hard, But from the beginning when I got the Neje laser it worked out fine.

Would that be two different problems?
And what could it be?

I loosen the laser lens and see there was a small white spot , I have tried to clean it but still there.
What do you clean the lens with ?

Extremely grateful if someone could come up with some Ideas and help about this🙏.

Thanks in advance!
/ Christer Merighi Ådin

Luthier in Sweden

A few things to check for:

  1. Make sure you’re not moving too quickly. I suggest setting your units to mm/min, not mm/s as this is the most common for diode lasers and will make comparison easier with others
  2. Go to Edit->Device Settings and check the “S Value Max” value there. Compare that value to $30 in Edit->Machine Settings. If they do not match, make S Value Max equal to the value in $30

That is a potential problem but should result in the same issues irrespective of software. Use IPA (isopropyl alcohol) or equivalent to clean the lens. Make sure the lens is completely dry before attempting to fire the laser.

Would love to see some of your work.

Thanks a lot🙂.
I have tried to go from 6000 down to 1000 in speed i Lightburn , but its the same no burning.

I do not know how I check the S Value for my unit but in the Consol I find it to be
$30 =1000
and it’s the same in the mashine settings.

I still have the same problem with terrible burning when I use the Neje Software, even if I change focus distance and speed , power .
From the beginning a year ago it’s worked fine.
But this should be another problem?
Maybe the mashine?
Or Lense?


Here is the white spot at the lens

Here is my first test with Neje Software

No when I try the same




Go to Edit->Device Settings. Not sure about your language settings but in Swedish it would be Redigera->Enhetsinställningar. S Value Max is called Max för S-värde. Check that value and make sure it’s 1000. If not, change to 1000.

The burns look like they’re out of focus. Test the focus to make sure it’s as sharp as possible.

Separately, are you able to modulate power at all? As in does reducing power reduce the light intensity?

You only really have 2 variables to change the burn. Speed and power. To get less burn you need to reduce power or increase speed. Even if you can’t modulate power you should be able to increase speed.

You may want to run a test pattern to see if things are working in basic. This will confirm if power modulation is working and how speed is affecting the burn quality.

I take out the lens and find this spot


I tried to clean it with iso but will not disappear

The lens could very well be damaged and would need to be replaced. It’s not clear to me if that’s the cause of your burning issues, however.

1 Like

I’d agree with this, the lenses should not have that white spot. I’d replace the lens.

I have tried everything you told me set to 1000 and so on … still just not burn, could it be just mess with the lens? https://drive.google.com/file/d/1kP__2JsXKuiojcIXEusfwbi7SHUjvZgn/view?usp=drivesdk

The drive file looks like it’s not being shared.

Can you upload the .lbrn file that you are using as well as these things:

  1. screenshot of Edit->Device Settings
  2. run this command in Console and return output:
$I
$$
  1. push “save gcode” in Laser window and save the file with a .txt extension and upload the file here.

Hi, I now got it to worked out fine with nice results , I just had to tried a lot changing the speed as you told me😊
It did not burn because of it was to fast.

I now only have problem to make the Lightburn work with my Macbook air OSX 12.
It works fine with my old PC laptop.

Thanks alot. / Christer

Okay great. Glad it’s working for you.

As for the issue with Mac I suggest you check the forum to see if the issue has been discussed. There are many similar Topics. If it can’t be solved then create a new Topic detailing out what going on.