Lightburn will not connect to Xtool D1 Pro 10W

Ok I know this has been asked a ton of times but I am still having an issue. I have a Mac Air with M1 and able to connect to Xtool. I recently purchased a Mac Pro with Intel chip. I cannot connect to the Mac Pro. Steps I have followed based on all the research I have found:
Connect to Xtool through XCS (Cannot connect with USB but was able to with WiFi)
Install config file into Lightburn.
Installed CH34xVCP Driver
Verified in system report Serial port is showing up when plugged in
No other program is consuming the port. I do have a power cord plugged into one USB-C and Xtool in the other one.
Multiple restarts and LB will not detect device.
Attempted to setup manually using GRBL. Choose setup and it will not show in the available devices. (screenshot is all that is ever in the list).

The weirdest thing is it showed up yesterday and worked all day. Today I went to plug in and it will not detect anymore. I am at a loss.
Screenshot 2023-10-03 at 2.18.48 PM

Is this still the case today?

Also, check the controller on the xTool and make sure the toggle for firmware writing is disabled.

Yes and the firmware switch is off.

Have you tried rebooting the computer?

Many times!

It’s unusual for the device to show up in System Report but not be made available as a serial device in LightBurn.

Can you check to see if a serial port is created in Terminal?

ls -l /dev/*usb*

If a port is not being created then there’s a gap between device detection and serial port creation. This would normally be an issue with the driver. It may be that you’re having a driver conflict but let’s address one issue at a time.

MacBook-Pro ~ % ls -l /dev/usb

zsh: no matches found: /dev/usb

This explains why LightBurn doesn’t see the serial device.

I’d suggest going through this page and using it to help identify if you have a driver conflict and how to potentially address:
GitHub - WCHSoftGroup/ch34xser_macos: MacOS USB driver for USB to serial chip ch340, ch341, ch342, ch343, ch344, ch9101, ch9102, ch9103, etc

Can you tell me which I have? I have 2 USB-C ports so not sure in this article.

Chip Model Support

  • CH340/CH341/CH343/CH9101/CH9102/CH9143 (USB to Single Serial Port)
  • CH342/CH344/CH344/CH347/CH9103/CH9104 (USB to Multi Serial Ports)

From what I recall your laser uses CH340 or CH341. In any case, it will be a single serial port.

Ok yes CH341 is what I was using. I followed this article and got to the kernel steps and the terminal would not find anything when I entered the command sudo kextload /Library/Extensions/usbserial.kext/*154kx4k*_ga*MjEzMDg1NTAwNy4xNjk1ODU5MDgw*_ga_W46SBPZ1NW*MTY5NTg1OTA4MC4xLjEuMTY5NTg1OTA5OS4wLjAuMA

Did you go through the steps in the previous site or just the xTool site?

If you followed the latter did you reinstall the driver and go through the permission step?

Just the XTool site. I followed all instructions precisely. I have to sit down tomorrow and go through GitHub.

Ok after reading the GitHub it is the exact same instructions as the XTool site I posted. I did all of this. At the end of this it asks to query “ls /dev/tty* and this is what it currently returns

MacBook-Pro ~ % ls /dev/tty


Something seems odd here. Are you adding an asterisk before and after the ‘tty’ portion of the command? If not, add that please.

You should not have any device called /dev/tty which is a bit odd.

Can you document what specific it is that you did?


MacBook-Pro ~ % ls /dev/tty*
/dev/tty /dev/ttyse
/dev/tty.BLTH /dev/ttysf
/dev/tty.Bluetooth-Incoming-Port /dev/ttyt0
/dev/ttyp0 /dev/ttyt1
/dev/ttyp1 /dev/ttyt2
/dev/ttyp2 /dev/ttyt3
/dev/ttyp3 /dev/ttyt4
/dev/ttyp4 /dev/ttyt5
/dev/ttyp5 /dev/ttyt6
/dev/ttyp6 /dev/ttyt7
/dev/ttyp7 /dev/ttyt8
/dev/ttyp8 /dev/ttyt9
/dev/ttyp9 /dev/ttyta
/dev/ttypa /dev/ttytb
/dev/ttypb /dev/ttytc
/dev/ttypc /dev/ttytd
/dev/ttypd /dev/ttyte
/dev/ttype /dev/ttytf
/dev/ttypf /dev/ttyu0
/dev/ttyq0 /dev/ttyu1
/dev/ttyq1 /dev/ttyu2
/dev/ttyq2 /dev/ttyu3
/dev/ttyq3 /dev/ttyu4
/dev/ttyq4 /dev/ttyu5
/dev/ttyq5 /dev/ttyu6
/dev/ttyq6 /dev/ttyu7
/dev/ttyq7 /dev/ttyu8
/dev/ttyq8 /dev/ttyu9
/dev/ttyq9 /dev/ttyua
/dev/ttyqa /dev/ttyub
/dev/ttyqb /dev/ttyuc
/dev/ttyqc /dev/ttyud
/dev/ttyqd /dev/ttyue
/dev/ttyqe /dev/ttyuf
/dev/ttyqf /dev/ttyv0
/dev/ttyr0 /dev/ttyv1
/dev/ttyr1 /dev/ttyv2
/dev/ttyr2 /dev/ttyv3
/dev/ttyr3 /dev/ttyv4
/dev/ttyr4 /dev/ttyv5
/dev/ttyr5 /dev/ttyv6
/dev/ttyr6 /dev/ttyv7
/dev/ttyr7 /dev/ttyv8
/dev/ttyr8 /dev/ttyv9
/dev/ttyr9 /dev/ttyva
/dev/ttyra /dev/ttyvb
/dev/ttyrb /dev/ttyvc
/dev/ttyrc /dev/ttyvd
/dev/ttyrd /dev/ttyve
/dev/ttyre /dev/ttyvf
/dev/ttyrf /dev/ttyw0
/dev/ttys0 /dev/ttyw1
/dev/ttys000 /dev/ttyw2
/dev/ttys1 /dev/ttyw3
/dev/ttys2 /dev/ttyw4
/dev/ttys3 /dev/ttyw5
/dev/ttys4 /dev/ttyw6
/dev/ttys5 /dev/ttyw7
/dev/ttys6 /dev/ttyw8
/dev/ttys7 /dev/ttyw9
/dev/ttys8 /dev/ttywa
/dev/ttys9 /dev/ttywb
/dev/ttysa /dev/ttywc
/dev/ttysb /dev/ttywd
/dev/ttysc /dev/ttywe
/dev/ttysd /dev/ttywf

Sorry. I should have caught it earlier.

What you want to be searching for is *usb*. So:

ls /dev/*usb*

MacBook-Pro ~ % ls /dev/usb

zsh: no matches found: /dev/usb

This is likely still a driver conflict.

Can you confirm that the USB port works for other devices?

What version of MacOS are you running?

Have you explicitly checked for other existing drivers?

I have used it fine with my MacBook Air M1. That computer had no problem finding the device on first try of plugging it in. I am running Ventura 13.6 on both devices.
I have not checked for other existing drivers. I would need some instructions as to what I should do.