Lightburn window too tall in Ubuntu

Lightburn window too tall in Ubuntu. Moved icon and toolbar icon sliders to minimum. Can stretch left or right but not up or down.

What resolution is the display? Can you show a screen shot?

If your display is short, you might need to change how the windows are docked to accommodate the display size.

Thanks. I ended up closing some windows to allow the main screen to be resized vertically.

Oz, the lightburn interface window is too tall, and has no maximise options available for the window toolbar to maximise the window.
Even right clicking on the process tab and selecting maximise, doesn’t actually maximise the interface itself, rather I noticed it maximises a transparent area to the full size of the desktop area, but does not affect the lightburn interface.
Here’s a screenshot of the maximised window, notice that the borders are not shown on the lightburn interface, and the interface is too tall for the screen resolution (this is set to the max size for this machine):

the following screenshot is the normal or restored size, notice the shadows and borders on the lightburn interface:

Even trying to drag the size of the window doesn’t help. It looks as though whatever calculation is used for maximising the to the full size of the desktop, is out by a few pixels.
Anyway, hope those help.

I just tested my Ubunto 20.04 LTS / LigtBurn 0.9.20 installation and I cannot confirm your problem. With me I can fine minimize and maximize the window and the whole frame and the function buttons from the window settings are visible and function. Not like under Windows or MacOS but it works “usable”

If you notice in both images I posted, there is no Maximise/Minimise button on the window decoration toolbar, very top right of the lightburn window. Right clicking the open program in the taskbar, has the maximise/minimise options, but behave as I’ve pointed out above. Just FYI, I’m using Linux Mint (Ubuntu version) with the Cinnamon Desktop Environment. are you using Gnome in Ubuntu, maybe it behaves a little differently. Other than that, I’m able to connect and burn. I’m using the NEJE Master 2, with 7000mw Laser.

Yes, it’s a “standard” installation with Gnome I have. But I am considering trying Mint too, just to get usb connection to my laser. With that window problem I will be able to live with but I can not do without a laser connection.

Have you used Terminal to check the device is present at all?
sudo lsusb should show connected USB Devices
sudo ls /dev/tty Might show more information
sudo ls /dev/serial Should also show info if the device is connected.
You may also need to use sudo adduser $USER dialout && sudo adduser $USER tty to allow permissions to access the device.
Sorry if you’ve already tried those, just though I should mention in case those help. The last command, is what allowed lightburn to see my Engraver.

Hi Dennis, I appreciate your reply very much, thank you.
Unfortunately it also gives no change, i.e., no device gets found.
If you want to be so kind and just see my screenshot through if I did it right, I’ll be grateful.

I’m using Linux Mint/Cinnamon and my LB has the minimize/maximize button and everything seems to work as expected.

The Commnds you did just fine, but it looks like your missing the necessary things for LB to make a connection to your Engraver, such as the /dev/serial. I didn’t have this issue, so I didn’t need to go investigate further. You may need to look into what steps you need to do next.

thanks, I will try

The LightBurn window is as tall as it needs to be to accommodate how you have the windows arranged. If you un-dock the ‘Laser’ window from below the ‘Move’ window and instead stack them together, the overall window will not need to be that tall any more. You’re running on a very low-res display compared to most.

Oz, I think you commented on the wrong issue, anyway, the laptop is using the highest resolution that Linux Mint will allow the laptop to run at.

I’m having exactly the same problem as yourself. I did all the stuff you did and LB just can’t see the machine at all. I suspect that LB isn’t actually finding the USB ports at all. I have tried all the different machines available (my Cronos board isn’t listed). When I am asked to choose a port there isn’t a choice although there are 3 working usb ports available.
I’m running 64bit Mint Linux 20 Ulyana specially installed to get LB working.
sudo lsusb finds
“Bus 005 Device 003: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter”
I know the machine is working because I resurrected an old windows machine c.2006 and installed the supplied windows software. The problem is I haven’t used “Windows TM” for 14 years and I really don’t want to go back to it. I’m stuck at this point.
PS. A side note. The windows version of LB doesn’t work due to a missing/corrupt .dll file in the “MS ‘C’ runtime.”
“failed to start because api-ms-crt-runtime - |1-1-0.dll not found.”

Is this right? Shouldn’t it be:
sudo adduser $USER dialout && sudo adduser $USER tty

Hi Larry,
I have actually capitulated in terms of solving the problem and this is the first time in my long “it career”. Fortunately, after all, in very important situations, I have the ability to use my Macbook to control LightBurn and my laser. But none of my windows or linux machines can find my Mini-Gerbil / laser.
I have even bought a new computer with Win 10, clean and freshly installed operating system … it finds all my usb devices in all 6 usb ports, such as external hdd, memory sticks, camera, mouse and keyboard etc. - but not my laser . I now have so many new usb cables that I could open a shop and sell them out.
It’s so mega frustrating!

I know the problem with dll files and LB / Windos and I solved it with the help of Oz. (This solution can be found here in the forum.)

But because I (we) may be the only one with this usb port problem, there is of course no real help to get beyond good thought advice to buy a proper cable, add a User in a Group … or remember to ground the machine properly …

But, it must be said that it is not “a LightBurn problem”. It is the operating systems that can not figure out how to simulate a serial connection from a usb port! - the reason for that is the great mystery.

Having slept and shut everything down when I restarted the machines today, (I also updated some software including QT before shutting down) LB appears to have recognised the machine. I believe that unless a machine is especially branded then most ‘cheap’ machines are GRBL firmware. I still have no choice of USB port but LB says the machine is ‘ready’. Having said that, when I try to print LB says the 3018 machine is busy or paused.
There are lots of steps to this.

  1. If you have a manual control (jog) board you need to remove it. You can’t have the manual control attached if you want control by computer.
  2. There is a little switch on top of the laser unit. If that isn’t switched on then the laser won’t light up.
  3. The LB program needs a 64 bit operating system (Linux anyway).
  4. There’s some mention of a driver, but programs running on Linux rarely have drivers. I’ve never seen one for software. I’ve only ever seen proprietary patches for Broadcom Wireless and Nvidia Displays.

The program is running and we are so close to a solution I can’t give up now although I’ve no idea what is wrong.

Have you chosen a port to connect to?

Hi Oz,
Yes, when I click on Choose it only gives me one option (USB0). My USB ports aren’t labelled so I have tried plugging into all 3 in turn.

Screenshot at 2021-01-17 16-46-46|690x387