LightBurn with Camera on Linux / Formatting computer

…I think it is installed

1 Like

:beer: …this is the first round I owe

Just reading this now.
It reminded me of a thread a few months back where an old camera driver could be applied to the LightBurn build in Linux.

I’m sure you’ve seen it but you may want to keep it handy.


Many thanks for this info.
Right now I want to try what Jack recommends. I’m not comfortable with Linux and really appreciate Jack’s attempt to help me.
We’ll take it from there…

1 Like

…just let me know when it’s convenient for you to move on from here.

I thought for a while if it was better and less embarrassing to do this per PM, but there must be some others out there who can hopefully use something from this topic. So I stand by it :wink:


I take time when I can and don’t know all about linux.

Most of the people reading threads don’t appreciate the discussion to up and disappear from in front of them. Which is what happens with a pm.

The more of us looking at something the accurate the information or at least a different view.

You have absolutely no reason to feel embarrassed. You have knowledge in other vital areas… I advocate that you make better decisions with better knowledge…


1 Like


You may need to update your installation. Run this in Terminal:

sudo apt update && sudo apt upgrade

On a different note. I tested my LightBurn camera on a Fedora 37 installation and it picked it up and showed a live image without issue.

Note that I have an 8MP 85 degree camera. Not sure how the various cameras differ but at least that’s one data point.

I am currently running what you wrote and hoping for the best.
My camera is a LightBurn 90 degree original camera and it works fine under Mac OS and Windows.
So if everything goes wrong, I can still consider doing an OS change.

A quick explanation… the && is a conditional … all programs should return a value upon completion.

A zero is success and anything other than 0 is a failure. In the above, it executes the apt update and if it’s successful it will exec the apt upgrade.

Consequently if the apt update fails, it will not attempt to execute the apt upgrade

My 2¢ worth…


As an aside, if you want to free up your License Key seat without going to Cryptlex you can go to ‘Help > License Management’ and select ‘Deactivate License’

I haven’t observed any problems with the update/upgrade, but I don’t have enough knowledge to judge whether everything went as it should.

After the update/upgrade, I restarted the computer and tried to start OBS again - with the same disappointing result. I also tried the camera directly with LightBurn again, but as soon as I select my camera, LigtBurn crashes. (Cheese has no problems with the camera)

It’s a shame to keep you going with such a stupid problem, sorry.

this is on 20.04 correct? It should run without issue, unless the update/upgrade changed your glibc version perhaps?

Thanks, I did that yesterday, it works fine this way toggling the license on and off.
It is my workshop PC which is exclusively used for my lasers, which I have reformatted with Ubuntu from Mint. I can use LightBurn fine with both distros, but without a camera.
Of course I have saved all my projects, but my machine settings, material library and also my art library - I forgot in the heat of the battle. Not a broken leg, I can remember most of the material settings and have made a test piece with all materials and their optimal settings. In the art library there was something that hurts, but I’ll probably get that sorted again.

…everyone else, REMEMBER to save these files too, once in a while, not just the projects!!

Yes it is this version (if the last update didn’t upgrade Ubuntu itself, I haven’t checked)
…glipc I have no idea what it is.

The update as it was written will not upgrade the distribution, just the individual packages.

I’ll try installing Ubuntu 20.04 today and testing this.

It’s almost too much…, on the other hand, then we can draw a thick line in the sand regarding Ubuntu.
I downloaded Fedora37 and will install it tomorrow if I can :wink:

Try lsb_release -a

jack@Kilo:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy

Ubuntu will ask before it updates anything…

Is the video ok to Ubuntu, but fails with Lightburn?

Next time it fails, try sudo dmesg | tail

This will print out the system message log… the | bar ‘pipes’ it to another program called tail. It only print the last few lines… It’s usually a pretty large file.

It might give us some insight if it logged it.

jack@Kilo:~$ sudo dmesg | tail
[sudo] password for jack: 
[564439.438527]  sdf: sdf1 sdf2
[564439.439764] sd 6:0:0:2: [sdg] Attached SCSI removable disk
[564439.439813] sd 6:0:0:4: Attached scsi generic sg8 type 0
[564439.441871] sd 6:0:0:4: [sdi] Media removed, stopped polling
[564439.442402] sd 6:0:0:4: [sdi] Attached SCSI removable disk
[564439.451836] sd 6:0:0:3: [sdh] Attached SCSI removable disk
[564439.452721] sd 6:0:0:1: [sdf] Attached SCSI removable disk
[564439.873550] ISO 9660 Extensions: Microsoft Joliet Level 3
[564439.874799] ISO 9660 Extensions: Microsoft Joliet Level 3
[564439.875588] ISO 9660 Extensions: RRIP_1991A


yes, in Cheese the camera works but if I call it in LightBurn, LightBurn crashes.
I can’t test what you suggest right now, it’s way past bedtime. Thanks Jack