LightBurn with Camera on Linux / Formatting computer

I have to switch from Linux Mint to Linux Fedora 37 or Ubuntu 20.04. Is it necessary in this context to “release” LightBurn from the computer and “register” it again under the new OS? (or does LightBurn identify the harware itself and doesn’t care about the OS?)

(The reason for the OS change is that I want to use a LightBurn camera)
And finally, is Fedora or Ubuntu better suited to run LightBurn?


If you login to the License Portal you can see the various aspects of the system that are stored. I’m not sure if that’s the full list of things considered. I would go with the assumption that you’ll likely need to reactivate. You could restore your prefs files and see if it works. If it doesn’t not a big deal to reactivate.

I’m not sure if one is better suited than the other but since the Linux version of LightBurn is built on an Ubuntu system it may be easier to meet dependencies. However, that hasn’t prevented your challenges on Mint, even though that’s Ubuntu based so clearly not the only factor.

Thanks for the answer. Uninstalling the license is probably the safest thing to do.

The second half of the answer confuses me a bit. Do you think it is not sure if Ubuntu or Fedora can handle LightBurn and the LightBurn camera? (sorry if I sound a bit strange, but I have to translate and think technically :wink: )

I wasn’t implying that. Going with Ubuntu is likely the shortest path to a working system with camera. But typically Mint or other Ubuntu based systems would behave relatively similarly with regard to hardware so it just raises some question marks for me. There must be something that Mint has done differently from base Ubuntu to cause the issue. Or possibly there’s something with your specific hardware going on but not sure.

Perhaps you could verify that things work in a bootable USB before wiping out your current installation. Or install to a separate drive so you can retain your existing installation.

Unfortunately, the problem is a bit more complex. Mint has a problem with a library that handles cameras, it’s different like in Ubuntu 20.04 and Fedora 36?. With these two linux variants, the use of LightBurn together with LightBurn camera is supported. (without LightBurn the camera works fine in Mint)

It is @ColinW who informed me about it and I fully understand the prioritization of their fine development work. I just didn’t know it before and thought it was my hardware that was the problem. I am also not skilled enough in Linux. Therefore, I am inclined to switch to another, but the right, usable distro. I use my computer in the workshop only for LightBurn and as long as it’s not Windows, I don’t care.

I run Ubuntu as do a vast majority of users.

Debian is really the only pure Linux 100% open source. The drawback is most communication chips use a proprietary driver. This is against the purity of Debian, since no one knows what that driver is doing … calling home to china?

Ubuntu, along with all the other ‘flavors’ of Linux came from Debian and varies from the pure Linux philosophy by allow non open source programs to run on it. You won’t find Lightburn in the Debian repository since it’s not open source. Just like some of the wifi modules on my pc are not supported directly on Debian… You can put in a ‘wrapped’ driver that has been reverse engineered in Debian, but you have to do it, it won’t…

Ubuntu is a great center ground… I used Debian for a while, but there was always some part of the hardware there was no driver/software support.

IMHO, I’d suggest Ubuntu after running Debian Linux since the late 1990, usually on an extra machine as there wasn’t nearly as much software out there for Linux. I’ve also use many of the other flavors of Linux…

Debian was sponsored by the GNU project in the early 1990’s for a year then it grew under the General Public License. Ian Murdock was the founder/creator of Debian.

Ian Mudock named Debian from his girlfriend Debra (Deb) and his name Ian (ian). Unfortunately Ian hung himself sometime around 2015… Sad end for anyone… :frowning:

Let us know how it works out…


Thanks Jack, always great to hear your opinion.
As I mentioned, I am not a super user on Linux. However, I have run a bit with Ubuntu before and it should probably be fine, especially when I know you use it yourself with your camera and LightBurn
I’m in the process of making a boot USB stick with Ubuntu, saving my data and formatting my computer. Of course I will report back

ps, even if it doesn’t work out, I don’t want to follow poor Ian. :wink:

I ran my camera through the Lightburn PI to the Ubuntu machine. One of the guys wrote it up on the forum here… Can’t see to find it…

They have been promising camera support from a least September of 2021, I think…

One of the issues with the setup is that it’s streaming full video continuously, which really isn’t needed unless you wish to watch it. I can see it load the machine and the local network when I streamed via the bridge. I only enable it when I need the camera … I did run it on an previous version of Ubuntu, but don’t’ have it setup that way anymore.

I’m still running the PI bridge for a wireless connection.


What a disappointment…
Otherwise it started fine, installation of Ubuntu 20.04, LightBurn and LightBurn camera run fine in Cheese…
But Ubuntu behaves just like Mint, as soon as I select my nice new LightBurn camera, LightBurn crashes. LightBurn also does not start again until the USB plug is pulled out.
Right now I’ve shut down the machinery and turned off the light in the workshop, I’m in the private room and poured myself a whiskey. That should be the crowning glory of today’s new start with the nice gift I got for LightBurn… :tumbler_glass:

If any of you have a constructive suggestion, you are most welcome.
I could get a Windows computer, but it will only be at the very end.

1 Like

A few ideas:

  1. Try running LightBurn with sudo and test. Might be some sort of permission issue.
  2. Try installing OBS and creating a virtual camera. Use the virtual camera in LightBurn. That might behave differently.
  3. Perhaps try running Ubuntu 18.04.6 to see if that changes anything.

That is what I used … Pick Tux:crazy_face:

I think you’re running into something that’s somehow inherent to Linux… Seems you get the same operation no matter what ‘flavor’ of Linux you use.

Lightburn tests on Ubuntu, I understand, so there must be some issue.

@berainlb other suggestion is run it from root and see if it’s a permissions problem


Thanks Jack, What is “Pick Tux”? does it work as a kind of intermediary, I will install it and find out.

How can it be a permission issue when I use both separately with no problems? (As I said, I don’t know much about Linux, I can install it and with the help of a patient soul type something into the commando prompt without really being aware of what I’m doing.)

I’m good at LightBurn, GIS and a bit of CAD, but I haven’t worked seriously with Windows and Linux for many years. After my old workplace had switched to Mac, Ipad and Iphone and I handed it over when I retired, all my work with hardware and software (OS) ended, it was simply not necessary anymore. When I think back how much time I have spent on antivirus protection and updating Windows…unbelievable.

@berainlb , @jkwilborn - thank you very much for your support

This links you to the Linux versions of the software…

I setup the Lightburn directory in my root, one of the few… I download the .7z file and use the manager to extract it… On the extraction window I move to ‘home’, a level above your user entry… the actual path is /home/jack, but if I extract if from the home level, highlight ‘jack’ and extract. It will unpack it in your home directory.

You will have to go to the Lightburn directory to invoke it. This is fixed by a ‘desktop’ file that specifies all of these locations…

We can get you up, if you wish. I find Linux much easier to understand and navigate… It’s i/o is more simply implemented…

I spend more time trying to find stuff on Windows, I cringe when I have to use it. :face_vomiting:

We’ll help you out, it’s not rocket science and I’m sure you can make it work.


…you are a brave man, Jack!
I have to fix some production first and hope to try this little penguin afterwards. - Thanks

I installed LightBurn last night and didn’t specify a specific location so it installed under /home/laser/.local/share/lightburn.
Should I uninstall LB and install it in /home directly?

No, lets get you up and running, then we’ll make it easy for you to manage upgrades…

Learn a little every day …

I have a Tux sitting on one of my CNC machine… :crazy_face:


I download and try to install Tux

Tux is just he Linux mascots name…

Let’s get it working …


:wink: I mean Pick Tux, shouldn’t it be downloaded and installed?

You will have options on how to install things. Some programs are in repositories, like all of the supported software for Ubuntu along with the source if you want to build the executable yourself.

If it’s an application, you have to download it and install it…

You can install it via an additional ppa, which points to a different repository.

sudo add-apt-repository ppa:obsproject/obs-studio
sudo apt update
sudo apt install ffmpeg obs-studio

From a command window, copy and paste each line, one at a time… into the window. This should install OBS…

If you have questions about what a command is, use ‘man command’, for apt, ‘man apt’ That’s the manual pages for that software.

If you want to find a command, use ‘apropos command’, it will search…

jack@Kilo:~$ apropos sudo
cvtsudoers (1)       - convert between sudoers file formats
gnome-sudoku (6)     - puzzle game for the popular Japanese sudoku logic puzzle
sssd-sudo (5)        - Configuring sudo with the SSSD back end
sudo (8)             - execute a command as another user
sudo.conf (5)        - configuration for sudo front-end
sudo_logsrv.proto (5) - Sudo log server protocol
sudo_logsrvd (8)     - sudo event and I/O log server
sudo_logsrvd.conf (5) - configuration for sudo_logsrvd
sudo_plugin (8)      - Sudo Plugin API
sudo_root (8)        - How to run administrative commands
sudo_sendlog (8)     - send sudo I/O log to log server
sudoedit (8)         - execute a command as another user
sudoers (5)          - default sudo security policy plugin
sudoers_timestamp (5) - Sudoers Time Stamp Format
sudoreplay (8)       - replay sudo session logs
visudo (8)           - edit the sudoers file