Lightburn won't connect with Ortur on Mac Mini

I’ve got an Ortur Laser Master Pro 2 S2 that worked with my Mac mini Intel for a few days and now it won’t connect, even though Lightburn finds it and adds it to the list. I’ve tried 3 new USB cables, restarted the Ortur many times, restarted the computer many times, deleted Lightburn and re-installed many times. Finally gave up and hooked it my Mac Mini M1 and it worked for a few days, then the same problem. There is no “port” option when running the Apple version of Lightburn (next to devices). Right clicking on Devices only makes the console report “Waiting for Connection” each time you right click on devices. I’ve deleted the laser in devices and re-added it through Lightburn search feature. If it finds the laser, why can’t it connect to control it? OK< I know you’ll say it runs best on Windows, but I have all Apple computers and after taking the time and work to write an app for the Mac, it should work just fine. I have the latest firmware update 1.87 for the Ortur and my computers all have the latest OS updates. Anyone have any idea what I should try next?

Can you explain this? Do you mean this field doesn’t exist or there’s nothing in the pull-down?

I think this is going to be the key to getting this sorted.

2 things please.

  1. Please attach a full screenshot of LightBurn with the laser connected and on.
  2. Can you confirm whether or not the laser shows up under Apple menu->System Report->System Information->USB?
    If it doesn’t show here then LightBurn will not be able to connect.

manually move the laser head to the middle of the work area and turn on the LM Pro 2 and tell us if it returns to the HOME position or not.

It starts at the home position, bottom left, from wherever I move it to when the laser is first started up, regardless whether it’s attached to a computer or not.

Are you saying it returns to the HOME position or not? It kinda sounds like it but I asked you to start the machine with the laser head in the middle of the work area. Does it go to the homing switches on power up?

I’m asking this because it lets everyone trying to help know that your controller board is working and powered up.

In the Windows version, there is “port” tab next to “devices” so you can pick the port you want to attach it to. There is no such beast on the Apple version. I mentioned that because a guy I know told me to click on the "port’ and make sure it’s connected to correct port, but he was running windows and so I couldn’t find what he was talking about.

OK, I got both computers working. It’s really weird. I had two computers drop out and wouldn’t re-connect to the Ortur laser. I’ve been working on the Mac M1 half the day, messing around with “devices”. I tried going to “devices/create manually”. It asks for the IP address, so I had look around for that since I’ve never had to look for it before. I found it and copied it and pasted it onto the lines, but it didn’t lineup and fill the line properly but it locked up and I couldn’t press the “next” button and I couldn’t edit it. Lightburn was totally locked up. So I did a “force quit” on Lightburn and opened it again and it found the laser. I have no idea what happened to kill it and no idea why it started working. I’ve been messing around trying to find the problem for 2 days and it started working more by accident than design. So this evening I went back to my old Mac Mini intel and hooked up the laser to it and it couldn’t connect, then I noticed in the window next to Devices is a tab/window that said CU.bluetooth-incoming-port, so I made sure my bluetooth was on (it was) but the laser didn’t show up in my bluetooth list. So I clicked on the down-arrow and I see another choice which looked more logical, cu.usbmodem1234561 and I clicked on that, and it connected. I have no idea how it changed to the illogical choice and stopped responding, but I found that solution by accident. So both of the computers are back up and running, the old one with a logical solution and the new one is still a mystery as to what went wrong. Only time will tell if that problem rears its ugly head again. And if it does, it will be past my return window I’m sure. I’ve sure had a lot of trouble with this machine.

Yes, that’s what I meant. No matter where I move the laser to when it’s turned off, when I turn it on it goes home. You’ll notice in my last post that I accidentally got them both working. Thanks for the help anyway.

it sounds like your Macs are changing where it defines where the laser is connected and since LightBurn expects to find the laser where it was last it says it can’t find it. No idea why you’d be using network IP addresses for a USB device but since you froze the system and had to restart it probably found an invalid device setup and went looking and found the USB device.

One thing which might keep things consistent is how you start your LM2. I would power it up, watch it HOME and then plug in the USB to the computer. I say that because your USB cable can provide power to the LM2 controller board yet not operate the motors plus it’ll be going through its boot sequence while it’s connected to your Mac. Far better to get the LM2 all up and ready to go and then connect to the computer. $0.02.

Glad you figured it out, kinda. BTW, I was not interested in if it HOMEd from different locations, just that it went through the HOMEing cycle. Good luck and make fun things.

This is the mythical “port” field that you were saying was missing. Your laser connects through USB so it will never be Bluetooth. Bluetooth is an option there because all ports that advertise themselves as serial addressable are shown there.

This often happens with Mac that it will go to Bluetooth in the port field. This is usually related to startup order. If you start the laser before opening LightBurn this will likely be the correct port selected. However, Mac serial ports are dynamic. So if the laser is not plugged in no such port will be available upon launch of LightBurn. In either case, simply pulling down the port field and choosing the correct field will address this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.