Lightburn won't recognize my machine anymore

Running latest version of Lightburn 0.9.10 and latest version of Mac OS Catalina. Connection is via USB. The software won’t recognize the machine anymore (Ruida). It used to work for more than a year without problem. I see the FTDI controller in the System profiler, so I know the machine is connected, but the software doesn’t recognize it.

I tried installing the latest FTDI drivers and uninstalling them, none of that help. Neither power-cycling machine or the computer.

Any tips? Thank you!

If you can, I would recommend a wired network connection to the machine, as MacOS includes a low-level serial driver that conflicts with the FTDI driver. I’m honestly amazed that it worked for you for over a year, unless you recently updated the OS.

If you still want to use USB, this should help sort out the driver conflict:

If you want to try networked, this will walk you through it:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.