Limit switches at Aufero Laser 2

Hi!
I would like to buy a laser cutter, probably Aufero Laser 2. However, I have read that it has no limit switches, so does not move independently to the home position. In a video I saw that the laser head is simply moved manually to the start position above the workpiece. Here in the forum I have read that the laser head is manually pushed into the home position before switching off.
What I would like to have answered before I buy the machine: How much of a hindrance are the missing limit switches actually in practice? Is it still possible to laser/cut several identical pieces in succession at always the same position?
Or is it so annoying that I’d rather spend the extra $100 and buy the Laser Maser 2 Pro?

I can go through the lot, the simple answer it that $100 will be the best investment in any laser you could possibly make.

My first two grbl machine did not have switches. I built hall effect for them, but realized how much of a help they were. Last grbl I bought (last xmas) has ‘factory’ limit switches on it…

Most of this software is set up for machines that ‘know’ where they are automatically, usually on ‘boot’ by the limit switches.

Without switches, you have to manually place the head to it’s ‘home’ position (limit switches do this, much more accurately) and power it up. They definitely increase repeatability.

It’s not like it’s not do-able without them, but they are a very nice addition, if you can afford them, you won’t be sorry.

Read the Lightburn grbl setup on the grbl machines They speak about it. At least I think that machine is a grbl machine…

Most machines motors ‘lock’ when that ‘axes’ isn’t moving, to prevent the machine from loosing track of where it is. So you don’t want to move them any other way than via a console or computer if they are not powered off.

I’m sure you’ll have fun, take care…

:smile_cat:

Hey Jack, thanks for the explanation! :slight_smile:

The explanation of the GRBL setups states:
“With the machine powered, jog the laser head to the origin position. In the console window, type: G92 X0 Y0 and press (enter). The G92 command tells GRBL to set the current location as the specified coordinate, so you’re telling the machine “this is zero”. You will also need to set $10=0 for this to work correctly.”

Does this mean that once I enter the coordinates like this via the console, the laser will always know where zero is? Or do you have to set it again every time you start it?

And what does it mean that you built hall effects for your first laser?

Aufero 2 has a GRBL controller, that’s right. So does the Laser Master 2 Pro. I think even all Ortur lasers, but I’m not sure about that.

Personally, I think having a way to home using limit switches makes for a much more repeatable process. It’s a time and potentially frustration saver.

Every time you wanted to reset the current position which is at least every time you startup the machine. However, the conventional way to handle this is through a startup procedure. Manually place or jog the laser head to the front left of the machine and then startup or recycle power. Location at start is 0,0. This allows you to use Absolute Coords as normal. Essentially, it’s a manual homing process.

All Ortur lasers use GRBL.

So does it make sense to spend a little more money and have the limit switches for it? Okay!

I have seen that the Aufero Laser has 1 limit switch. But it has a tiny work surface of 18x18cm. The successor Aufero Laser 2 has no limit switches :confused:
But to buy the small and to be annoyed afterwards because of the work surface is also stupid, right?
It’s all unexpectedly complicated ^^"

Maybe you should ‘look’ at other lasers, now that you are ‘more’ educated…?

:smile_cat:

Honestly this is going to do mostly with how you expect to use the laser. If you’re doing a lot of one-off items that have relatively high tolerances (e.g. <2 mm) then you’re likely to never really even miss the limit switches. Some people only burn to the approximate center of a piece of material. For them the homing is almost a nuisance.

My general advice here is to buy for what you know you’ll need. Especially as you’re just starting out and the investment cost is relatively low. You’ll discover more about what you’re missing and what you’re totally fine with only after using the laser and establishing your workflow based on your needs. Then you can make a more informed decision for the upgrade.

I’ve looked around quite a bit, I think. Atomstack and Neje I have also looked at, Sculpfun and CO2 Cutter in general. But with everything there seem to be problems more often. More often than I’ve read about Ortur, anyway. It won’t be perfect either, that’s for sure. :slight_smile: And also never come close to a good CO2 cutter. But what matters to me is that they ship from Belgium (relevant if you live in Germany and don’t want to pay high customs fees), the support seems to be very good, the laser modules do what I plan to do with them and the racks are relatively stable.
The only question that came up in my search was what about the limit switches and to what extent their absence affects the overall experience.
However, the reference to the accuracy has helped me a lot! Perfection I do not need, but ±2mm I find already relatively much ^^" So I will probably invest more money to have the limit switches and the associated repeatability fidelity.
Thanks for your tips and help!

There are always many options. That’s what’s nice about having a choice.

If you have questions we’re around and will try and help.

I’m sure you’ll be happy with whatever you decide on and have a great time with it.

Take care.

:smile_cat:


This IS the back of motherboard.
Connect the correct pin to switch in C for ground ans NO for X Y limit pin

The problem IS to attach the switch on the rail

After you activate in software the homing functin

Try this

Hi Luc,

I’m also using an Aufero Laser 2 an try to install limit switches for x- and y-axis.
Electrically and mechanically no problem.

But i’m not able to start homing, even if i enable “auto homing”, or try to start it manually.
I also enabled “Hard limits” in the machine settings.

The laser seems to “try” anything (one can hear a noise from the motors) but there is no movement and after a few seconds i always get “error 9”…
Can you please share your settings one have to made in lightburns machine settings?

Did you enable homing cycle ($22=1)?

Also, it’s possible that your firmware is configured for XYZ homing. If so, Z needs to home first and then XY home. Try shorting Z switch after starting homing and see if it proceeds from there.

1 Like

You are right!
Since the Aufero isn‘t using z-axis… is it possible to deactivate z-axis (or z-axis homing)?

Not through a runtime configuration. You would need a firmware compiled with XY homing. I have not seen one published by Ortur but it’s possible they offer one through support.

I wish they would publish their source code as they are obliged to do under GRBL’s open source license. Apparently there’s been some movement on that front:
Ortur Laser Will Go Open-Source | Hackaday

I don’t know of any of the common laser manufacturers complying with the license so hopefully Ortur can set the standard.

1 Like

Ok… just a quick thought…
A small circuit, which detects activity on z-axis (which should only appear when homing) and if there is activity, shorts z-limit to gnd :thinking:
Somehow like a z-axis Simulator…

@berainlb @jkwilborn
Trank you both!
I have to answer here, because as a newbie it is Not allowed to me answering more than three times in one Thread :man_facepalming:

Ok, an electrical circuit Solution will be too complicated.
So I will try to get in contact with Ortur!

You could try to rig-up a hardware workaround. It would need to work with the full 2-step homing cycle where it hits the switch, moves away, and hits the switch a second time.

I think you’d have better luck tracking down an alternative firmware. You may want to reach out to Ortur support and explain what you’re trying to do and the complication you’re experiencing to see if they have an alternative firmware already available.

Or just add a Z-limit switch and trigger it manually until a firmware update is available.

1 Like

If you short the Z input to ground it will probably still issue a 9 error, because it can’t complete the home.

With switches, each axes uses the same sequence

  1. move towards the limit switch
  2. on contact, back off the limit switch
  3. move back towards the limit at a slower speed for a more accurate ‘zero’

If it’s can’t do all three it will fail.

As @berainlb advised, you can pull it off manually, tap the switch twice a few times usually works.

@berainlb I know these use limits, so I’d be surprised if Z axes home wasn’t taken into account. I’ve never watched any videos on these machines…

:smile_cat:

1 Like

Ortur for some reason has changed design direction on their use of limit switches. Their newer machines I believe starting with Aufero 2 do not come with switches installed. I can see them not even bothering with changing homing for this in firmware in that case. I believe they’ve also shifted to using grblHAL as the base of their newer machines so probably starting from a clean slate. Not sure if Aufero 2 is one of the machines using the grblHAL base, however.

I opened a Support ticket at Ortur.

If their answer is negative, using the smallest available stepper motor with a switch would be the easiest workaround.

Great, now i‘m allowed to answer more than 3x in one thread…. :roll_eyes:

Does the board support Z-axis motor? I suspect there will be no stepper driver for Z-axis. Some of their controller PCBs have pads for the driver but are not installed. There was another user on this forum that modded his board to add Z-axis which was a cool hack.