Limit switches for homing

Hi guys,
I’m trying to set up my DIY laser to use limit switches to home the laser. I’ve installed them and think they are wired correctly, but getting an error when I hit the home button in LB. I’ve tried wiring to NO and NC, but neither works. I assume they should be NO?

Here are my settings and the error:"

$0=10 $1=25 $2=0 $3=2 $4=0 $5=0 $6=0 $10=1 $11=0.010 $12=0.002 $13=0 $20=0 $21=1 $22=1 $23=0 $24=250.000 $25=10.000 $26=250 $27=1.000 $30=1000 $31=0 $32=1 $100=100.000 $101=100.000 $102=800.000 $110=2250.000 $111=2250.000 $112=600.000 $120=500.000 $121=500.000 $122=30.000 $130=500.000 $131=500.000 $132=200.000 ok $h ALARM:8 Homing fail. Cycle failed to clear limit switch when pulling off. Try increasing pull-off setting or check wiring. ok Grbl 1.1f ['$' for help] [MSG:Check Limits] [MSG:'$H'|'$X' to unlock] [MSG:Caution: Unlocked]

If you push them by hand, they have to be pushed 2 or 3 times.

The machine wants to back off the switch after it’s initial contact, and it looks like it’s not able to do that according to the error you received. The idea is that the machine will move an axis to the switch at a rather high speed, and once it makes contact the movement stops, but it wants to re-assess the actual stop point by moving off the switch and then moving toward it again at a much slower pace. This ensures the accuracy of home position. There is a setting (homing pull-off) in LB which allows you change the amount the axis “backs off” of the initial contact with the switch. Make this setting larger so it will completely clear the contacting of the switch. You could enter 20mm for instance (which should certainly clear it), then reduce the amount until it just barely releases the switch. So in summation, the machine will bump the switch twice: once to find the rough location, and again to at a slower rate for accuracy. Hope it helps!

The problem is that the laser does not move at all. My K40 auto homes at startup, so if it is at the middle of the work area, it moves negative X and Y until the switches are activated, and does what you describe.

My DIY, on the other hand, does nothing. If it’s in the center, and I use $H or the home button on the move tab, it doesn’t move at all, so it never gets to the switch. The stepper motors are not activated. I can jog Xand Y just fine. But once I send a home command, it “clicks” like when you connect the COM port, but then freezes and I end up resetting the COM connection.

Your homing seek is at 10mm/min./ 0.16mm/ sec.
Maybe it is timing out.

It must sense the limit switch as activated.

$5=0 in settings requires a NO switch from ground to limit pin to activate.


1 Like

Thanks Alan. I tried upping $25 to 60 but still get nothing. I can’t jog the X or Y and even trying to move them by hand, it feels like the stepper motors are engaged, but not turning. They move just fine when the $H is not on.

I’m wondering if maybe one of the masks is wrong???

Hi Arkie

What is the mask?

Even at $25 = 60, that’s only 1mm per second homing speed.
The steppers would be engaged but barely turning.

I believe the $25 should be up near the maximum feedrate of $110 / $111

If $22 is set to 1 that means a homing cycle must be run before you can jog the X or Y.


Have a look at my Instructable:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.