Line error 25, laser stops?

Laser has been working fine until I upgraded to newest version, now I get “Line Error 25” shortly after I start a cut, whether lbrn files or jpg images. I know what line error 25 is, but never had the problem before?

Without some basic information about what machine you are having the problem with, it’s going to be really difficult to answer.

As you already know what ‘error 25’ is, maybe posting that information, too, would help get you headed in the right direction?

It might a specific error number, “on or near line 25” - LightBurn generates a text file full of GCode that gets sent to your laser. If the laser returns an error, LightBurn will tell you the error code, and try to give you the line number that produced the error. If you click the ‘Save GCode’ button, then open the resulting file in a text editor, you (or we) might be able to figure out what the issue is.

Can you copy the text from the console from when it gave you the error?

Thanks, will post that today.

Thanks, I will post that today.

Text of error problems from console:
Waiting for connection…
Waiting for connection…
Port opened, waiting for response.
Grbl 1.1f [’$’ for help]
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
Starting stream
Stream completed in 0:00
<Idle|MPos:40.000,70.000,0.000|FS:0,0|WCO:-10.008,-20.016,-0.991>
ok
ok
ok
ok
ok
ok
Starting stream
error:2
On or near line 18:
Stream completed in 0:02
error:25
ok
ok
ok
ok
ok
ok
ok

Saved gcode:

; LightBurn 0.9.07
; GRBL-LPC device profile, user origin
G00 G17 G40 G21 G54
G90
G0 X40 Y70
G91
M4
; Cut @ 300 mm/min, 100% power
M9
G0X16.92Y-12.15
G1X.27Y.3S1000F300
X.3Y.28
X.32Y.25
X.34Y.23
X.36Y.2
X.38Y.18
X.39Y.14
X-40.76
X.38Y-.14
X.38Y-.18
X.36Y-.2
X.34Y-.23
X.32Y-.25
X.3Y-.28
X.28Y-.3
X.25Y-.32
X.23Y-.33
X.2Y-.36
X.18Y-.37
X.15Y-.39
X.11Y-.4
X.09Y-.41
X.05Y-.43
X.02Y-.43
X-.02Y-.49
X-.07Y-.48
X-.11Y-.46
X-.15Y-.45
X-.18Y-.43
X-.22Y-.41
X-.26Y-.38
X-.28Y-.37
X-.32Y-.33
X-.34Y-.31
X-.37Y-.28
X-.4Y-.24
X-.41Y-.21
X-.44Y-.17
X-.45Y-.14

<< snip >>

Your profile says “DIY” for the laser type. Is it a GRBL-LPC device, or generic GRBL?

The reason I ask is that LightBurn uses information in the profile to know how aggressively it can send to the controller. GRBL-LPC has a larger receive buffer, so LightBurn can push further ahead. If you are using a standard GRBL device with this profile, you’d end up dropping characters and getting transmission errors, which is what looks like is happening here - the GCode is perfectly valid, so I suspect the controller is losing data. The saved GCode was generated with the GRBL-LPC profile, so it’s expecting a device that can handle that throughput.

Thanks for the reply! Been sorta out of action for a couple of days, will try this fix today, thanks again!

Fix worked, profile identified two settings, deleted the LPC device and laser works like it should. However, now the “fire” button is gone now that allows you to accurately place the start point of the burn. Is that specific to LPC setting?

It’s a setting stored with your device settings. Since you created a new device, you’ll have to re-enable it.

Click here:

image
(or use Edit > Device Settings)

Then click here (lower right):

image

Thanx, your support is awesome!!