Linux click apprun?

Last line of installation instructions for Linux says to double click the apprun to run lightburn.

I have no “apprun” in the lightburn directory!

There is a Lightburn app that does not run

I am by no means a Linux power user, but I threw a copy of Ubuntu Linux on an old laptop and installed LightBurn. The apprun appeared for me. All I can suggest with my oh so little knowledge of Linux would be to try reinstalling LightBurn to see if it fixes the issue.

Chris - which version of Linux are you using? And, importantly, 32 or 64 bit? (We only have a 64 bit version for Linux, and it’s built on Ubuntu 16.04, I believe)

1 Like

Ubuntu 18.04.1 desktop 64bit

apprun is not in the downloaded file. Is it supposed to be or is it created by linux?

You should be able to just launch “LightBurn” directly. If that doesn’t work, let me know.

that does not work.
“there is no application installed for executable files…”

I changed permissions on the lightburn app to allow executable and it now works…
Why did I need to do this?

Because Linux is terrible? Seriously, I just don’t know much about Linux, haven’t figured out how to properly deploy for it yet, but it represents about 1% of our users, so it’s low priority.

I have a small home theater pc that is too slow for windows. It seems to be ok on lightburn excepter for raster preview…

The raster preview is running the full motion planning simulation, so it’s a little heavy.

In the security model used in Linux, files must be flagged as executable before they can be run. By default, files in Linux are not flagged executable.

Normally setting the correct file permissions would be handled by the installer but Lightburn does not have a Linux installer. What you download is just an archive file that you extract the contents from and move to the location you want Lightburn to live. Therefore, you had to manually set the exe flag.


Thems fightin words :wink:


Thanks. Will this affect running a raster on my soon to be completed laser (grbl)


I had to add this line to meet the 20 character minimum.


Nope - As long as the software has permission to run you should be good to go.

Linux is terrible… lack of understanding does not make software terrible.
As for the install issue, I can provide a copy of my .desktop file and instructions on how I have LightBurn installed on my LInux system. All functions work fine other than the camera.
I’m glad Lightburn is ported to LInux and do appreciate there efforts even if its a smaller number of users.

1 Like

I am also very glad Lightburn is ported to Linux. If you poked around the Lightburn or Laser facebook groups, you’ll see so many instances of Windows deciding that mid-job is the best time to update, where Linux respects you as a user and waits for you to tell it to update. It can be a bit daunting to learn, but there was a time when you didn’t know how to use Windows or MacOS either.

Personally I don’t like the direction windows is going as a desktop, which is why I’ve been trying to push Linux use at our makerspace when the software allows for it.

1 Like

FYI I submitted a PR to the documetation repo to fix this. I must have missed this step when I wrote it last year. Hopefully we shouldn’t see this issue come up again.