Linux Commarker B4 setup in Lightburn

Though Lightburn 1.5.02 installs nicely on my Linux Mint 21.3 Cinnamon system (Latte Panda Sigma):

  • Kernel: 5.15.0-97-generic x86_64 bits: Desktop: Cinnamon 6.0.4
  • Mint 21.3 Virginia base: Ubuntu 22.04 jammy
  • Machine: Type: Desktop System: LattePanda product: LattePanda
    Sigma date: 06/13/2023
  • CPU: Info: 12-core (4-mt/8-st) model: 13th Gen Intel Core i5-1340P bits: 64 type: MST AMCP
  • Local Storage: total: 1.82 TiB used: 945.67 GiB (50.8%)
  • RAM: 32GB

I’m at a loss as to how to interface it to my Commarker B4 (30 W MOPA)

I have purchased and installed a license. But I can find no instructions on how to set this combination up. Can I follow the instructions given for Apple’s MacOS? I have copied the files from EzCad2 onto my system, though, of course, it cannot run. Can I emulate the instructions about copying the configuration files for EZCad2 into the LightBurn config (in /usr/local/share ???). Otherwise I’m kind of stuck.


Use lsusb to examine what’s plugged into the pc.

Copy and paste from my cli.

jack@Kilo:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 25a7:fa67
Bus 001 Device 003: ID 062a:4102 MosArt Semiconductor Corp.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 9588:9899 BJJCZ USBLMCV4
Bus 003 Device 003: ID 056a:0011 Wacom Co., Ltd ET-0405A [Graphire2 (4x5)]
Bus 003 Device 002: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The BJJCZ entry is the fiber machine…

This will tell you if the os can see the controller.


1 Like

Thanks, that is helpful.

I see that that entry doesn’t appear in my lsusb output until I re-enable the emergency shutoff switch, even though the laser is turned on. I got lucky and noticed that on a hunch. Others might not realize it.

Now I have to sort out the configuration parameters.
Any tips would be helpful.


Most e-stop switches kill the power to the whole machine…

Glad you’re back up…

Have fun


1 Like

This forum thread and this page from ComMarker on connecting your Commarker B4 (30 W MOPA) to your computer and LightBurn may help you get setup:


Thanks to everyone.
These comments and links give me the information that I lacked.
This is a very useful forum.
I hope to return when I know more to help others.



I am still having difficulty. After I posted this as ‘Solved’ I had to spend some time away from this project. Now when I return to it I am again unable to connect to the Laser.

I have made certain that BRLtty is disabled, that the device appears in the listing from ‘lsusb’, and that I have (what seem to me) sufficient privileges to access the port. To wit:

dave@LP-Sig0:~$ groups
dave adm tty dialout cdrom sudo dip plugdev lpadmin sambashare libvirt

Bus 003 Device 045: ID 9588:9899 BJJCZ USBLMCV4

brltty service was disabled via systemd and uninstalled using ‘apt remove’.

I understand that the results returned by lsusb show the device number of the device moves around, especially if the USB cable is left plugged in. I’m not sure what to do about that, or where it is stored (if it is) in the configuration.

I have repeatedly attempted to scan for my device, which seems inevitably to lead to a timeout and a complete software crash.

I have tried to manually create another device entry, which always fails similarly.

I’m ready to go, but not sure where to turn next.


In LightBurn, open the Laser window and see if LightBurn has identified the correct COM port or if the word “Choose” is in the middle box along the bottom edge of the window.

If you’re not connected, feel free to make a different selection. After selecting something, wait a few seconds and see if any text appears in the Console window.

The Console window in LightBurn will be the most helpful indicator to show that LightBurn connected to the Commarker.

When I select a laser configuration, it doesn’t change the middle laser window selection… It just says auto.

Screenshot from 2024-03-18 12-40-57

Lightburn find-my-laser - 2024-03-18 12-43-03

Nothing happens in the console window.

I gave up.
I’m removing Lightburn for now.
I simply couldn’t make it work.
I did find that I was having typical Windows-style issues finding the .cor file because of the embedding of 'F:' file path information in my .prefs file - bad form!

It seemed to have difficulty with the device-id for the USB that was creeping ever higher into the 40’s and beyond. As in: Bus 003 Device 049: ID 9588:9899 BJJCZ USBLMCV4. Not sure. Seemed to work better when I got removed some devices like a cellular modem that used a bunch of ports. That caused the numbers to reset lower. At least once “find my laser” didn’t crash. It didn’t find the laser, either.

So far, it seems a bit windows-y for my taste.

I will try to move it to a more typically contemporary BeeLink Ryzen 7 device running Linux.

Is there any chance that this can run in a VM or Container under ProxMox? I’m running out of dedicated boxes. I suppose that is just asking for trouble.


Work… maybe… but not trouble.
I’m sure more than half the dev team has Linux Boxes and they’re interested in making it work.

I may be way out on this, but it seems like those paths don’t get built until an action builds them. I’ve seen .prefs files with no file information. Did you copy the TF card with the files to a local directory outside LightBurn?

It was a memory stick, but yes, I did that.
Not LightBurn’s fault, but I did explicitly ‘import’ the .cor file several times.

That is not my real problem, however. My real problem seems to be that can’t seem to find my laser, and always (though valiantly) dies trying.

I’ve had this a couple of weeks now and still have not been able to do even a minimal test.

If I create a new device manually, there is no search for laser available. Have you tried creating this manually?

This is what is shown on my machine with lsusb listing.

Bus 003 Device 004: ID 9588:9899 BJJCZ USBLMCV4

Are you sure the protection is set correctly for the port so it’s allowing you to connect? I never had an issue with this, but I was, also, never able to see the devices entry in the /dev directory.


As I showed above, the lsusb appeared like this:

The Device number incremented every time I plugged in the USB cable. So I took apart the machine and removed some of the devices that were using USB resources, for instance a 5G cellular modem that uses 5 (count 'em: 5) USB serial entries. Others I could not remove. But after this the lsusb entry became:
Bus 003 Device 016: ID 9588:9899 BJJCZ USBLMCV4
But it still would not connect.

I created new manual entries more than once, rebooted, removed them, switched which were set as default, etc.

I don’t know what you mean bu ‘protection’. I am a member of groups that give me access to all USB ports.

Anyway, I gave up, removed my license key, and uninstalled everything.

All traces appear to be properly gone, but I still have been unable to even make the galvo move, let alone engrave anything.

How do you figure?

This device ID is set by the OS and you don’t have any control of this. It says it’s plugged in and working.

Did you follow any kind of setup for this machine?

How to Use LightBurn: A Step-by-Step Guide to Connecting and Operating ComMarker B4 - ComMarker


Mr Wilborn,

I’m not going to pursue this discussion any further.

I appreciate your efforts to help me and I respect this software. But this is going nowhere.

  1. The page you referenced describes the initial setup using the EZCad2 ‘driver’ on either Windows or MacOS. Neither applies to me.
    I’m using Linux. Initially Linux Mint, now preparing another machine using Ubuntu 22.04.

  2. This page is dated and does not even apply to the engraver that I am setting up. It is referring to the ComMaker B4 Fiber laser. I am using the ComMaker B4 MOPA Fiber laser, very similar but definitely not the same.

I have followed these instructions to the limited extent possible, but almost all of this doesn’t apply. There is no version of the EZCad2 software that runs on Linux. There is a version of Lightburn for Linux, and I appreciate that.
But I have used the imported settings from EZCad2 where appropriate. Very often they are simply wrong for the MOPA. Others have generously posted MOPA information, but it requires some searching.

My problem is entirely related to Lightburn not recognizing or interacting correctly with the emulated USB port. USB ports work differently on all of these platforms, especially when emulating antiquated serial interfaces.

It appears that in resolving these issues I am on my own.
I don’t doubt that I will get this sorted out in time.
When I do I will post what I learn. Perhaps that will help someone else.


What software are you running?

I have Ubuntu, so can’t run EZCad either.

This should work and if it isn’t lets try and call in the bigger guns and see if they can resolve this for you or if the MOPA board is different. I hate to see you use that Chinese stuff.

Maybe @JohnJohn can give us some idea of what is going on…

Hang in there… thanks for the response…


Find my Laser is term for a button that might conflate things.

That button sends LightBurn to look for a device signature and compare it with a list. If you’ve imported the markcfg7 file, you’re probably using the Create Manually button to create the profile manually.

This may not be on our list of common devices.


Jack @jkwilborn is one of the few community members running Linux. He’s quite enthusiastic.

I’m not seeing the Linux setup for Galvo instructions either. I’ll file a request for this with the documentation team.

I think setting up another machine with Ubuntu is a great next step.

If you continue to struggle with the setup in Ubuntu, please reach out here in a new thread. I know there are at least half a dozen Linux enthusiasts around who are likely able to help.

I’m not convinced it’s a driver issue. He can see the device using lsusb, below. If you look at my post, it’s also showing the same device identification. This is a MOPA, do you think it’s relative?

I didn’t have to install a driver for my machine to connect. Linux is usually pretty good about the USB works or the driver needs to be installed. Linux has had all the drivers I’ve ever needed on the disk.

Sometimes the braille driver will override the one you need…

sudo apt-get autoremove brltty

Sorry I didn’t think of this earlier… hopefully you’re not blind…