Little to no color difference when filling/engraving

Hi all,

I rebuilt a cheap Chinese laser to use a Neje 30W laser (7.5W output) and a new (clone) CNC shield.
Currently I’m trying to laser a power scale. But there is very little to no difference between power levels/speeds.

The material is regular (light brown) MDF.

The scale below was made at 3000mm/min & max power: 80% as a grey scale image.
At the 25% mark it starts to get darker but it doens’t change much between this and 100% (of 80% max power).

The image below shows another power scale (X is power Y is speed).
The top row has a speed of 1000mm/min and the bottom row 3000mm/min.
Column 1 has power level 10% and the last column is set to 100%.
Still almost no difference between different power levels or speeds.
(The job wasn’t finished so couple pieces are missing).

Anyone an idea what the issue is?

Are you sure your machine settings are suitable for a speed of 3000 mm / s?
If the maximum speed set by your machine is less than the speed you select, you will not be able to move faster than that, so you will get the same results.

I copied the feedrate from a similar machine (eleksmaker). Currently they are both set to 5000mm/min.

please share your machine setting

I do not think you can get that fast move with $ 110 and $ 111 currently on your machine.
please go to device setting then go to additional setting tab and tell me what is your max speed X and Y axis.

The speed in the “addtional settings” matches the speed I set in GRBL.
My machine is capable of moving at +3000mm/min (minute not per second). I timed a movement (and accounted for acceleration) and the feedrate seems correct.

this is my setting

1 Like

Ashkan, I believe the additional settings in the ‘device settings’ are only used in the preview mode and do not have an effect on the controller.

Matthias, might help if we can see the .lbrn2 file that you are using. Post both of them if you can :slight_smile:

hi jkwiborn yes i know .
I just asked MattCall1995 to see the additional settings to see the speed calculated by Lightburn

material_testcard_k40_homedepot-2_90mm.lbrn2 (47.8 KB)

I used this file but I already changed some stuff. The biggest quality gain was by increasing the interval distance to 0.2mm. I guess there was a lot of overlap which darkend everything.

Where did you get that gradient?

It’s all on one layer running 33mm/s at 100% power. It’s doing what you asked it to do. :frowning:

The other layers are just junk. Click on the ‘zoom to frame’ (next to camera). You can shift + click on the layer (in the layers window) and it will select it.


It’s doing a grayscale image so it’s one layer. That’s how it suposed to work in this case I guess?
The other layers are indeed junk but are disabled.
If I look in the preview and shade according to power I get the result I want.

The other test (with the individual blocks) was created with just regular fills and with the powerscale function.

There are on-line programs that can generate this much faster than you can. A quick search showed this one for Lightburn.

For grbl, there is no minimum power setting.


Yes the original file for the individual blocks was generated with the tool you mention. I only changed some parameters.

I know the minimum power is only used with certain controllers. Weird thing is that I only get the minimum power option when doing an image and not with a normal fill. That’s why I tried to change it to see what it does. Maybe I just overlooked the minimum power setting in other cases.

There is no option in grbl to set minimum power. You must have modified it to do that ???
Do you have the original?


Min power is used on gray scale image

1 Like

I’ve used a couple of those generators and they seem to work. Don’t know what happened to the one you had created, but it was a single layer with the same power.

Why did you have to modify it…?
It’s supposed to run ‘out of the box’ so to speak…
Suggest re-creating it, should be quick. Post the output so we can look at it.

Sorry I don’t remember my grbl controller being able to set minimums, but I did little engraving with it…


The thing I changed manually was the speed. In the tool I set the range from 1000 to 3000. But realised later that this was mm/s instead of the mm/min I needed.

I will run another test when I get off work.