LM2 Pro, laser turns on then off, just the laser, during mid-burn of project

Not sure if this is a hardware or software issue,

During a simple line burn (pictured) the laser will turn off anywhere from 50% complete to 90% of burn project, but the gantry system is still moving. In one of the pictures, you’ll see the outline, I watched it go around 2 times trying to figure it out, before i hit the home button. If I home the laser head and hit start, it work fine, till the laser turns off again, to me it seems completely random the time frame. but I’m also not sitting there with a stop watch The other picture shows my settings 750mm/95% repeat 5 times. and the progress shows 99%, so this is not a long burn process 10min give or take… i don’t sit there and watch it for every burn…

I’ve had it turn off during a fill operation as well.

even the console tab showed 3 of 5 for the repeat, no errors were being given.

all power saving setting on the laptop are turned off.

I have a video in a google link, in the video the laser is supposed to be on at 95% power.


Most likely this will be something hardware related.

Check the cable as well as the ports from the controller to the laser module. Make sure that there is no damage to the ports/pins as well as the cable ends. Make sure the cables themselves are undamaged. For something like this it could be frayed/nicked cable. Or possibly an internal failure.

If not the cable this could also potentially be a power issue or the laser module failing. Try 2 tests:

  1. Set the power to a low setting and use the Fire button in Move window to turn on the laser with no motion. Does it outlast how long it would otherwise normally run?
  2. If yes, then try running a normal job but with just very low power. Does it finish? If so, then likely a power issue or laser module issue. If not, then more likely something with the wiring although it could still be a power issue.

Do you get any errors in Console? Try running ? command a number of times until you get “VA:” included in the status message. Copy those values into a reply.

Thanks Berainlb

I’ll try those test. in the next day or so. and look and/or replace cables.

The laser engraver has jumped up the error game on me, it stopped doing the error that this thread was about. now i get this going on (see pic attached) again no errors in the console.

I do my “fill” at 135deg and 45deg and as you can see it just lost where it was and shifted about 2in while running mid way through the project. I was trying 2 different burns at the different angles for these coasters. again no errors in the console.

I know its hardware, i have the OLM2 pro 1.5 series, I’m borrowing a friends OLM2 Pro 1.8 series and its working just fine.

I plan on resetting the firmware on my engraver. after that i’m not sure what to do. am i able to buy a new controller?

Can you describe what happens when this occurs? This looks like typical missing steps but hard to say what would be causing it.

My first thought would be loose belts but I’d suggest a full mechanical review of the system. Check belts and pinions to make sure they’re properly secured.

What speed were you running this job at?

the new OLLM2 Pro with 1.8 also had the same errors eventually happen.

After much searching, testing, new parts, switching out entire machine, disabling power save on everything, new usb cable, switching locations with different power from grid. I even tried exporting to .Gcode for laserGRBL to to burn, same problem was happening, but i think i fixed it.

the laptop i was using was causing all the problems i have been having,

right now a different laptop its burning the same coaster as in the pic. no problems.

odd though the laptop works fine for everything else. and it had been working for over a year.

Thanks for the help, sorry to make you have to think about solutions.

like i said i know its hardware, just not the hardware i expected… haha the jokes on me

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.