LM3 stops in middle of burn - several times

This is actually a continuing problem. I have the Ortur LM3, using Lightburn software 1.2.04 with a windows 10 laptop. I have the LM3 plugged into a socket with no other items plugged into the same room. I have run an extension cord from another room for the laptop. I have run another extension cord from another room to plug in a water assist pump and a floor fan.
The extension cords are HD outdoor cords.
I have placed the air assist off of the table where the LM3 is so as not to have any vibration.
I have replaced the usb cord with a more HD cord.
All electric plugs are 3 pronged, so I’m assuming they’re properly grounded.
I’ve made sure that nothing touches the usb cable while the LM3 is running.
I have tried moving the whole kit and kaboodle to another location and had the same results.
OLF:205_RC16. is the Ortur I’m currently running. I have tried going to the Ortur Firmware Repository to upgrade but the only one listed there is like a trial with no instructions or any information at all.
Any info would be sincerely appreciated.

I downloaded RC38 (New Firmware) for the Laser Master 3 here:
https://ortur.tech/firmware/OLM_Series/ESP_OLM3_205_RC38.zip
Inside the zip file is a binary similar to what is seen in the video.

You’re absolutely right, I couldn’t get the instructions to download.
https://ortur.tech/latest-firmware/
This looks like a job for @OrturTech :slight_smile:

In this video the Ortur LM3 looks like a drag-and-drop firmware flash. You hold buttons and start the LM3 in a special mode to accept the firmware and then you drag the firmware into the Ortur. You’ll need to unzip the download and drag the binary file (.bin) over to the ortur.

Let us know if this offers new or further obstacles.

I have an LM2 Pro that would do the same thing, just stop at random times during a burn. No errors at all, it would just stop. On one of those occasions, I happened to have task manager up and I saw that the CPU usage was at 100% (and it stayed that way for several minutes). Because of this my Windows 10 desktop PC stopped talking to the laser via USB. It turns out that my firewall program (and sometimes my anti-virus) would start up at random times and suck up all the CPU resources. Now I disable those programs whenever I’m using my laser and I haven’t had a problem since. It might be something to look into while you are waiting for Gil to chime in. Just my two cents worth.

1 Like

I have downloaded and installed the software. Thank you for the link and the video. I am still having the same problem though.
Do you think I should try to run the laser from a desktop computer vs. the laptop I am currently using?

I have tried to turn off the firewall and the antivirus software. I am still having the same problem.

1 Like

Same here Firmware was updated but same results.

ALARM:3

Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.

Ortur Laser Master 3 Ready!

OLF:205_RC38.

OLH:OLM_ESP_PRO_V2.4B.

OLM:GENERAL.

GrblHAL 1.1f [‘$’ or ‘$HELP’ for help]

[MSG:‘$H’|‘$X’ to unlock]

error:9

G-code locked out during alarm or jog state.

[MSG:3:Caution: Unlocked]

ok

NVM I found the problem it was my type C adaptor. its limiting the data being transferred to my computer. I was using an HDMI for external monitor and the USB 2.0 for the laser. Lesson learn Only use the adaptor 1 at a time hahaha. Now its working perfectly. :slight_smile:

1 Like

I’m glad you figured that out. I don’t have anything hooked up to my laptop except the laser and the usb mouse.

are you loosing the directory file for OLM3 everytime it stops? i think if thats the case you might be also loosing data being transfered to your laser

how long is your cord? or is your cord also connected to an adaptor?

no

[quote=“ali11759, post:1, topic:81079”]
I have the LM3 plugged into a socket with no other items plugged into the same room.
I’m using the cord that came with it. Actually very short.

I’m wondering if I should get a desktop computer to use with this instead of the laptop I am currently using.

maybe you can try to change USB cable first? im also using a laptop. But if you have a desktop that you can use you can try specially if its a USB 3.0 or higher(maybe it will help on transferring of data).

I have purchased a new usb cable that has ferrites at both ends to help block interference.

I have done this. Nothing has changed. Should I have a copy of the original sd card on my computer?

Also I have tried three different laptops, should I try a desktop computer?

I use a desktop PC so it doesn’t have a USB time out setting, but if you are using a laptop, it is my understanding that there is a setting that shuts off the USB after a certain amount of time (I think it’s a power saving thing) and a lot of folks on laptops have run into this issue. It’s something you might want to look into.

Thank you. I’ll try a desktop to see if it fixes my problem. I appreciate your help

This really isn’t a LightBurn issue.
Here are the steps to install the firmware Upgrade on the OLM3.

  1. Long press on power button, keep holding the power button.
  2. Press the Reset button once.
  3. Release the power button, and you should see Red→Green→Blue flashing sequence.
  4. Drag the upgrade file to "Ortur laser“ disk,don‘t close the file until it shuts down by itself.
  5. Restart the machine.
  6. Open LightBurn and type $rst=* in the console to verify the upgrade.

You might enjoy this group, dedicated to the OLM3: Redirecting...

Thank you for this info. Another person gave me a link to a video to do this. I have implemented the upgrade but I stil have the same problem with the machine stopping multiple times during a run.

Alison

Understood. That’s why I posted the link to the OLM3 Group. There are numerous discussions about OLM3 power supplies and other issues that may help.