LM3 stops in middle of burn - several times

I have been dealing with this issue from day one. Very frustrating. 3 out of 4 project failures. I tried many things such as, turning off all power saving settings and internet connection, changing usb cables, adding a powered usb hub, trying seperate power circuits, firmware updates and changing several settings. I finally fixed my issue by connecting a long wire with clips from the frame rail which the laser runs on to a screw on my breaker box on the wall to provide a ground. It seems that static electricity builds up from the moving parts and discharges through the usb connection. I have completed 50 or more projects since with 100 percent completion. This may not fix everyone’s issue, but it did fix mine.

4 Likes

Fantastic. Glad you got this sorted. I hope this applies to other folks that are experiencing this as well.

1 Like

That sounds incredible. I will def give it a try this week. Thanks.

1 Like

Nice!
I just posted about an LM3 issue I have with it powering off mid-job. I’ll try the grounding and see if that improves my situation.

2 posts were merged into an existing topic: Lasermaster 3 constant beeping when powered up

Claude and Robert Engel I believe you are both posting to the wrong thread. I have not had any issues with finding my sd slot.
Confused…

I think so too… I’ll tidy this up.

1 Like

I’ve been having the same issue, sort of. LM3 stops in the middle of a burn. But for me it’s because it’s lost Wi-Fi connection. LightBurn seems worse than LaserGRBL, but they both do it.
I’m wondering if it’s a power quality issue with the LM3. I live rural, and I know my power out here is bad. Electronics take a real beating. I’m going to get a power conditioner to run the LM3, grounding the LM3 to the conditioner. I’ll let you guys know if it helps.

Question for the LightBurn folks. I really like Lightburn, but LaserGRBL handles losing Wi-Fi better. When LaserGRBL reconnects to the LM3, it asks if I want to start from where it left off. LightBurn starts over. So, I have the options of either double burning a portion of the gcode or starting over on new media. Is there an option somewhere I can select for it to start from where it left off?
If not, can we make that a feature request?
Thanks

I also have had jobs stop in mid burn at times for one reason or another (mostly user error on my part). But an option to start where the G-code left off would be SUPPER FANTASTIC! I second the motion.

I finally fixed this problem with the help of all of you.

I attached an upgraded USB
I disabled firewall
I disabled the sleep feature
I installed the updated software…
Nothing changed!
Then I found this:
I stumbled across this today, it may help you: ORTUR Laser Master 3, Connection Problem Solved! - YouTube
PROBLEM SOLVED!!!
After I did the above, I ran a 7 min job, then a 10 min job, then I rand a 7hr 40min job. It worked fantastically. Thank you Atroz for that little video.

I hope this helps someone else out there. That said, the next day tried to plug the USB cord into the LM3 and guess what? The usb connection from the LM3 was stuck in the USB cord end. At this point I tried to get Ortur to replace the machine. They sent me to Amazon as that’s where I got it from. Amazon is going to give me 80% of my original cost back. Honestly the machine actually ran for 2 days total since I got it in Sep.
I’m going to ATEZR to get a 20W laser.

I’ve reached out to Ortur Gil with this issue. But I thought I’d see if any of the LightBurn Guru’s might have an idea. I’m NOT a TCP/IP, windows networking guy. So…

I used WireShark to eavesdrop in on the communications going to/from the LM3’s IP address. What I saw was normal communication with an occasional “TCP windows full” alert. From what I can gather that’s a buffer alert. That “TCP windows full” alert would gradually increase until it was 2/3 of the comm traffic. I would then get a TCP/IP fail alarm. Usually, the LM3 failed to respond. The it would fall back to com handshaking, trying to re-establish communication with the LM3. Sometimes it was successful, sometimes not. On those time it wasn’t successful I would have to reboot the LM3 and everything would start talking again.

The little research I’ve done, “TCP windows full” alert occurs when there is a LOT of network traffic going on. I know windows is famous for having a lot of crap going on in the background. Plus, a lot of other programs can background network traffic as they check for updates, etc.

What I am going to try tomorrow is to limit background network traffic. I’m not quite sure how to do that yet. I’ve got a lot of techno-babble to read.

Got any ideas or suggestions?

I’m purely speculating but perhaps check to see if you’re getting packet fragmentation and adjusting MTU size accordingly.

Okay, I think I’ve solved my problem(s). I’ll detail my troubleshooting steps. But first two words of caution.
*** I am not a TCP/IP guru. What I think I know I got via the internet. We all know how reliable that place is.
*** The computer I’m using is in my shop. It’s not my home computer. So, I can afford to be bold with the shop computer. If I crash it, oh well. Pain in the a**, but I haven’t lost anything I can’t reinstall.

  1. I ran WireShark. It’s a freeware program that lets you eavesdrop on TCP/IP communication. There was a LOT of errors between the LM3 and my shop computer. LighBurn would start off talking to LM3 just fine. But the longer LighBurn ran, the more errors would pile up. To the point the LM3 would just quit talking. I also saw there was a lot of background TCP/IP communications going on. LaserGRBL acted the same way. Sometimes they could recover from the errors, sometimes not. And the errors kept piling up.
    Note: WireShark will show you ALL of your TCP/IP communication. I had a ton. Weather widgets, Xbox, Skype, ect. Stuff I never installed was still talking in the background. Once I decided I needed to get rid of the crap. I limited WIreShark to showing only LM3 communication with the command HOST:192.168.xxx.xxx with 192.168.xxx.xxx being the LM3’s IP address.

  2. To lower the amount of TCP/IP communications I took the LM3 off of my shop hotspot and put it on my home internet. The hotspot was a repeater between my shop and my home internet. I then ran a windows 10 de-crapper to remove unwanted apps. Careful here, this will wipe everything non-essential to a running computer. READ the info before you use it.

  3. Following berainlb’s advice, using this website, I determined the largest MTU packet size I could send. It turned out to be 1100 bits. I suspect it’s so low because my home internet signal strength in the shop sucks. Note: WireShark affects packet size. I don’t know why or how. But I could get larger packet sizes without WireShark running in the background.

  4. Following this website, I set the MTU size for internet interface I was using to 1100 bits. I have multiple ipv4 ethernet interfaces. By watching WireShark I determined the LM3 was using Ethernet 2. I set it’s MTU packet size to 1100 bits.

  5. I just ran a 15-minute burn that completed without any stops. Before all of this I was lucky to get 3 or 4 minutes. An indicator of how much I’ve increased the communication reliability. An $wi command on the LM3 show’s my Wi-Fi signal strength as “unacceptable”. And yet I completed the 15-minute burn without issue.

1 Like

FYI - I was still getting the occasional glitch. I was pretty sure it was because of low WiFi signal strength in my shop.
I reconfigured an old Linksys router to be as WiFi extender. $wi shows my signal strength is now “acceptable” and I was able to up my MTU packet size from 1000 bits to 1500 bits. No more glitches.

1 Like

I also had a similar issue, I could not get past ~5 mins doing a fill. I tried all of the usual mods, stop AV, Wallpaper, ScreenSaver etc etc.

I did disable the storage device & then tried my test job again, but is stopped after 5 mins. I then re-started my laptop & started my layout that always failed & it finished the job after 31 mins.

I have no idea why rebooting completes the fix, the drive is still showing up in the device manager after the reboot as it was before the reboot.

1 Like

I missed this gem as it went by. I’d really like to know what the Ortur Firmware revision number is when your engraver connects.

Other laser engravers have moved toward the ESP32 architecture so I will be applying this test to similar machines. Thank you for sharing this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.