Lockups on v0.9.22

I have been using Lightburn for some time now and everything has been working perfectly, until I updated to v0.9.22 this morning …

Now I am having constant problems, where the laser will simply stop during the burning process. This can be anywhere from start to finish of the burning task.

Lightburn does not show any errors, or messages in the console log saying there has been a fault / error … The software itself has not crashed or paused or anything else, It just stops sending data to the Laser.

I have uninstalled the latest version and gone back to v0.9.21 and everything is working properly again.


I also notice that if the laser remains on for about ten minutes while I prepare the work, the same disconnects, whereas it did not happen before. I will try to go back to the old version to try.
Then it happens to me that after starting the work the move window of the laser shows speed and power.

This continues to happen with v0.9.23 and it happens way more often than it should. Buffered/unbuffered, it doesn’t matter.

Please look in to fixing this soon, it’s really not acceptable to be ruining so much valuable material because of this.

1 Like

I upgraded to v0.9.23 yesterday and so far I have not had any further issues.
Although I have not done a lot of testing at this time …

I went back to v0.9.21, but the same thing happened. The laser just sits there frozen with the clock counting up, everything looking normal exepct nothing is happening.

You have provided little to help us understand what exactly is and/or is not working for you and how you have things set. If you are looking for productive suggestions and potential resolution, please share more as the details matter.

Ok Rick, what happens is

for more information look at the first post

Thats all I can tell you. There is nothing in the console, the laser has just stopped, but lightburn still thinks it is burning. You can pause/unpause, but it doesn’t do anything.

You have provided little to help me provide you with more information. What things do you want to know that I have ‘set’? I told you I tried both buffered and unbuffered comms.

If you are looking for productive suggestions and potential resolution, please request more exact details.

Let’s start with what version of LightBurn have you tried, 0.9.23 is the latest public release. Did you try that? What OS are you running on that PC? Have you ever been successful running a job on this laser using LightBurn? Id so, what version of LightBurn were you using to do that?

We are here to offer help. We need to know as much as possible as we are not there to ‘see’ and observer what you do.

We do provide a search tool (upper-right of every page here on this forum), provide posts explaining what we need to be helpful, and a bunch of solutions all ready posted, for the most common issues folks have for getting things going as they’d expect.

We only ask you to enter with a desire to help solve the issue as well. You seem upset or resistant to provide your details and have only copied what others have said. Searching for the best way to “Ask for Help”, returns,

As said, we are here to help. Need to know what folks have, and what is or is not happening. What has been tried and what was the result. Without this, we are just guessing and you don’t want that.

Have you verified that it is this release of LightBurn definitively that’s the source of the issue? Have you tried going back to whichever version you upgraded from to see if that version works without issue?

Are you using the “Gerbil” device profile in LightBurn?

I have never had a version of LightBurn that didn’t have this problem. I only started with LightBurn around a month ago on 0.9.21 and this was a problem back then.

Are you saying I am to blame for wasting my material?

The OS I am using is Windows 10, fully up to date. This problem occurs intermittently, often in batches, so yes I have had successful burns with 0.9.21, 0.9.22, 0.9.23, but I have also had this failure with all those versions.

As above, these are the only versions I have tried. I have only been using Lightburn for a short while and I have never found it to be a solid product. Burns will always intermittently fail. If anyone can recommend a version that is solid I will happily roll back to that and stick with it forever.

The thing is though if I (and everyone else) kept rolling back until we find a stable version, then bugs like this will never be reported or fixed.

Originally this thread had no replies from anyone associated with Lightburn after being up for a few days. Instead of letting this problem just drop down the forum unanswered I replied to add my voice to the fact that this is a problem.

You don’t think I already searched for a solution? How do you think I found this thread? Can you provide me with the bunch of solutions you refer to above? I am eager to fix this.

Correct me if I am wrong, but doesn’t my profile tell you what machine and controller I have? I am willing to help you in any way to get this problem solved, I am not resistant to providing any details that you require.

I am upset, yes, you would be too if you spent an a couple of hours creating and preparing a unique painting only to have it ruined when the laser cutter stops cutting it 45 minutes into an hour long burn.

I am using the Gerbil-STM profile.

More than anything else, it seems that you guys have a real problem with knowing how to handle complaints. Rather than getting all defensive and replying with snarky comments, what you should do is just acknowledge the problem, show a bit of empathy, then commit to looking in to it. It’s really quite simple to keep your customers happy.

The way things are now, antagonising your customers only makes it worse for both sides.

Ok fellas, calm down a little and maybe we can work it out as a team :slight_smile:

Nathan … There are so many variables that can cause problems …
What controller is built into your Laser ?
What version of controller software does it run ?
What are the min / max speeds your steppers can run ?
Have you tried GRBL setup instead of Gerbil-STM ?
Did you import the controller settings from the controller itself, or from a config file, or manually ?
Are you connecting it to USB2 or USB3 port ?
Have you tried multiple USB ports (front / rear) ?
Have you used other burning software that works properly ?

Please try lower versions of Lightburn such as .20 - .19 and so on …

It’s a game of trial & elimination …

Drivers … Cables … USB Ports … Power Supply … Settings … Other Software on your PC …
If we can eliminate them one by one, it will reduce the guessing and narrow down the cause.

For me personally, I have been using Lightburn since v0.9.15 and had no problems with any of them until .22 … I rolled back to .21 which was the last working version I used to fix the issue, but discovered there was still problems. This was because I had updated the firmware on my GRBL but not the corresponding info in Lightburn. I adjusted these settings again and fixed the issue, then updated to .23 when it released and its working 100% for me (so far).

You need to keep going to previous versions until you can find a stable one, then the devs can look into what changes have been made from there that could be the problem. If ‘none’ of the previous versions give the desired results, then it is not Lightburn that is the problem.

1 Like

This is incredibly strange - Nothing whatsoever changed in the communication routines or GCode generation between 9.21 and 9.22.

@Nathan - We’re not trying to be difficult here, I promise - some of this is trying to figure out what you’ve tried, and whether this behavior is new with a new release, or has always been this way. Mini Gerbil and other boards like it are ‘bare’, and the K40 is known to be electrically noisy and comes with a pretty terrible USB cable, so it’s not at all uncommon to experience drops, interference, or grounding issues, and these manifest as job stoppages.

When I ask things like, “are you sure it’s the software?” that’s exactly what I’m asking, nothing more - have you tried other software, and had no issues with them, using identical settings? If so, that would be evidence to support that LightBurn is at fault, and I’m fine with that - just trying to actually figure out what to look into.

I did six 63 minute cuts today -

v0.9.21 - froze during cutting
v0.9.20 - froze during cutting
v0.9.18 - froze during cutting
v0.9.17 - success
v0.9.17 - success
v0.9.17 - success

This is good, but yesterday I managed to do about eight of the same cuts all on v0.9.23 with all but the first of the day succeeding, so it may still be a bit early to get excited.

I’m not completely convinced that it isn’t a problem with the Mini Gerbil board. From what I have observed it seems really fragile in terms of voltage and electrical noise. To that end I am running the board on a seperate external 5V power supply and removed a bunch of paint to make sure that the chassis was properly electrically grounded.

A difference I have noted since rolling back is that when it freezes with version v0.9.20+, the busy time display keeps increasing, while with version v0.9.18, the busy time display was stopped also.

Internally, does LighBurn set a timeout to detect cases where the controller is not responding, but is still connected? If the mini gerbil controller has crashed or isn’t responding, shouldn’t LightBurn detect this or eventually timeout and put something in the console? That’s what makes me think that the problem is with LightBurn rather that with the controller, I would expect that LightBurn would detect when the controller stops responding.

I’m running the 2019 mini gerbil firmware. I tried the latest one from last month, but that was really messed up for a multitude of reasons.

I am pretty sure the mini gerbil guys recommend using the STM version, but I will give the non-STM version a go.

I imported the conrtoller settings and have only lowered the speed and acceleration because I was noticing that layers would sometimes get a few millimeters off when cutting at high speeds.

I also went to the trouble of swapping over to a different laptop. The laptop has no other devices plugged in, the laser is the only device connected and it’s connected via a short and thick usb cable. The laptop is also a clean Windows install, so there are minimal other tasks running. All the power saving/sleep settings have also been disabled. This didn’t help.

Prior to installing the mini-gerbil and starting to use LightBurn the laser cutter was rock solid with K40 Whisperer, but that’s not a workflow I’d like to go back to.

It doesn’t at the moment, no. If I did this, the timeout would need to be something quite huge - If you’re cutting, going really slow, and doing long, single lines, there could be a significant amount of time between when I send a command and when the board has finished with it.

For example, cutting a 500mm line at 5 mm/sec would take 100 seconds - close to a minute and a half. USB communications are error corrected, and there is a retry mechanism built in, so it should be robust. If a single character gets dropped (or added, or changed) that could be the difference between a short move and a long one, ruining the output, so it’s not abnormal to assume that everything is fine as long as the device is connected.

At least in unbuffered mode, shouldn’t you be able to calculate how long the command will take (like you did above) and therefore choose an appropriate timeout based on that, plus a few seconds of leeway?

Hi Natan, which version of MG board do you have 1.1a or 2.0, I have 2.0 and similar system, (but not windows, I run on Linux Mint), and my LightBurn 0.9.23 runs just fine.

You haven’t provided enough information - what computer system?
You’re also jumping into a thread where the original poster has an entirely different laser controller than you do, so you’re not having the same issue (or at least it’s not going to be the same cause). If you’re using a Mac running Big Sur, this is known and being investigated.

My bad I’ll delete my message! I was trying to get help without starting another thread!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.