Logitech C920 no capturing nor can I change setting in LB

Merry Christmas to y’all. ( cross post in FB groupS)

Trying to install camera to my laser for LB.
Logitech C920
Windows 10
LB 1.3.1 ( no more renew)

I can see the image but at the first step of capturing image, it won’t.

Tried to :

  • change the setting in LB “custom camera” to default, it does not stay the changes after re-lunching LB.
  • Windows camera and mic all shared and Allowed across all app
  • Enable/disable honeycomb : no results
  • Power cycled several time: no result
  • Different USB cables & ports on PC
  • PC annoy be upgraded to Win11
  • Logitech c920 driver dated from 2021, no newer version available

I do have the 120 fish eye camera and it is working. But due to the focal distance, it is too far and small when acquiring the bed image.

Anyone would have a solution for my C920?
Went through the LB forum past oosts and came out empty handed.

Thank you for reading so far.
Appreciate any feedback.


Where do you see this?

What happens instead? Can you include screenshots of what you’re seeing?

At this point, when clicking the Capture… NOTHING happens

screenshot posted

the camera capture system:
I tried also to change it to the Default , but it won’t save the changes.
Once restarted after the changes, it revert back to the Custom’s

Is this screenshot from after attempting to push the Capture button? It’s unusual that there is no additional message on screen.

I don’t think I’ve ever heard of this happening. That’s odd.

Do you possibly have anything running on your system that could be interfering with the function of other applications? Like a real-time malware protection application?

Thank you for taking the time to help!!!
Really appreciated.

Yes. After clicking capture, nothing happens. It feels like the camera was never received the instruction to take the picture. Or the contrarily, the camera did not take any action.

As for other programs, I uninstalled the Logitech HUB and still the same issue.

I since, changed it to another no name 8M camera to test and it works out without any issue.
So, the 120 degree LB camera works, the 8M square camera works, only the C920 is not working …….

Definitely something odd.

And the camera capture system’s options, it reverts to custom, every time I restart the LB.

I even though it could be the 4 port USB hub that I was using and re-routes the camera USB to connect directly onto PC…. Still the same.

Have you tried every port on the PC directly?

I am a tech.
I do troubleshooting for living…lol
the only other thing I did not do is to bring another C920 to test it on my K40…

found the issue:
the preference.ini file was set as READ ONLY

now testing ,

Are you referring to LightBurn’s prefs.ini file?

I’m curious how this would have been changed to read-only. And this would have theoretically prevented all changes to the file including adding devices or otherwise.

it was not allowing me to do any changes…
I finally realized that after re-adding the laser and it was not there after the re-start of LB…

Not sure… may be myself playing around?
no way to know…

We Techs, always blame on user’s action… lololol

BTW, the TCP mode in LB still doesn’t work.

the only way to get communication going was the method I first used : Virtual comport.

After changing the preference.ini attribute from READ ONLY to disable, the Camera Capture system was able to changed to Default.
and C920 was able to be calibrated with the cost of lower resolution…

TAHNKS YOU VERY MUCH FOR YOUR TIME for helping me out!!!

Which TCP mode are you referring to? Not following here.

Is this for the laser or the camera?

Perhaps try it again under Custom if it was something to do with the RO setting to begin with.

I tried again selecting the communication mode TCP when adding a new laser:

  • GRBL
  • Ethernet/TCP

I was still not able to connect with my MKS DLC32 from LB to my Laser.

The only way, still, was via virtual COM port. I posted years ago

Does your controller support serial over telnet? If not, this won’t work. I believe FluidNC supports it on ESP32 based boards.

What firmware are you running?

I use the MKS DLC32
it runs GRBL 1.1
I can access to the board via Web browser from my PC and wirelessly to the laser and control my K40

i can ping my board no issue from any PC

It’s almost certainly not general GRBL 1.1 as that didn’t support ESP32. It’s most likely going to be based on Grbl_Esp32 (predecessor to FluidNC) and if so, could very well support serial over telnet.

Check out this page:
Using Telnet · bdring/Grbl_Esp32 Wiki · GitHub

This alone isn’t indicative since any board with wifi would allow this.

sorry that I missed an important letter after 1.1…

I have the FW 1.1 h

I just figured out the WIFI connection issue:

The MKS DLC32 V2.x uses by default PORT 8080

And I was able to change the LB’s default PORT 23 to 8080 by changing the file prefs back in 2022
but LB has since removed the NETWORKPORT from the pref

Not sure why they did that.

connecting to my board using USB cable and at the console
using the command [ESP131]
I changed the port 8080 to 23
and thereafter, the WIFI communication was established.