Low Light Laser "Fire" is always on 100%

Hello there,

i´m new to this forum, but due to the fact that all the threads during the last couple of days came realy handy to set up my laser i thought i might make myself an account.

I recently got an unbranded chinese.5.5W diode laser, with a board that looks like the ones build in the eleksmaker lasers aswell. It has a arduino nano wich i flashed with the grbl 1.1 firmware.

I realy like the lightburn software, but since yesterday my low light fire button is burning at 100% all the time i press fire no matter what value i type in.
Is that problem common? Does anyone have a solution or an idea on that?

heres are my $$

$0=10
$1=25
$2=0
$3=3
$4=0
$5=0
$6=0
$10=1
$11=2.000
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1
$31=0
$32=1
$100=80.000
$101=80.000
$102=250.000
$110=500.000
$111=500.000
$112=500.000
$120=10.000
$121=10.000
$122=10.000
$130=200.000
$131=200.000
$132=200.000

*excuse my (probably) bad english, its not my first language

thanks for the fast reply.
my maschine doesnt have a fire button,
it fires when i press the “fire” button in LightBurn

It’s likely because $30 is 1, not 1000.

$30 is “what is the highest number the software will send me” for power. By setting it to 1, if the software sends 1 or higher, your laser will be on 100% - you basically have on / off control and nothing else. Change that to 1000 (the GRBL default) and make sure the S-Value Max setting in the device settings in LightBurn is also that same value (1000).

Thanks for the help,
could you help me finding the S-value Max in Lightbox.
sorry, i´m still new to the software

Edit > Device Settings, then it’s along the right side of the window, near the bottom.

Thank you!
it was already set to 1000 in LighBurn, I set the $30 to 1000 and now its working perfectly.
thank you

I just encountered a differerent problem.
The “fire” button works just fine now, but with the $30=1000 the laser doesnt engrave anymore,

$30=1 engraves
$30=255 engraves
$30=500 engraves
$30=999 very light engraving
$30=1000 no engraving (but laser on)

Those are why. If you have asked LightBurn to run your design any faster than 500mm/minute, which is the setting in your firmware for the maximum allowed speed, the controller will lower the power output because it can’t go the speed you requested.

Your settings for $120 and $121 (acceleration) are also very low, and I suspect your machine is not 200mm x 200mm either ($130 & $131).

It’s worthwhile to read about what these settings are and what they do: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration

It looks like your settings are currently just the GRBL defaults, so you’ll need to configure it for your machine.

well that explains a lot,
I already tried to get into the Grbl Wiki, but due to the fact that I´m new to this topic I was quite lost with setting up the maschine.

Thanks for the tips with the $110 and $111, I was already worried that the maschine cant go any faster than that.

do you have any suggestestions for max speed, or is it more a finding out by try and error?
Also I dont know wich value for the acceleration would be suitable

The maschines frame limits the size to 610x510mm
my Grbl settings now look like this and its getting better

$$

$0=10

$1=25

$2=0

$3=3

$4=0

$5=0

$6=0

$10=1

$11=2.000

$12=0.002

$13=0

$20=0

$21=0

$22=0

$23=0

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=255

$31=0

$32=1

$100=80.000

$101=80.000

$102=250.000

$110=1000.000

$111=1000.000

$112=500.000

$120=50.000

$121=50.000

$122=10.000

$130=610.000

$131=510.000

$132=200.000

Trial and error is really it - Run a frame around a decent sized square, then double the max speed and the acceleration and do it again. At some point, the motors will buzz because you’ve gone too fast. Cut both settings by half, and then do just one at a time from there, going up about 50% with each test, and when you hit the limit, go back.

Great,
sounds like i have a plan for tomorrow.

I´d like to support your work, and mine aswell, by purchasing a software licence. For my nano arduino i need the Gcode licence, right?
thanks a lot again

Correct. Here is the link: https://lightburnsoftware.com/collections/frontpage/products/lightburn-gcode

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.