Mac cannot find my laser

I am running Mac OS X El Captain (10.11.6) and lightburn 0.9.09 and when I use the “find my laser” it doesn’t come back with anything. If i try to manually add it, it cannot connect either. Any help would be appreciated.

How are you trying to connect? USB? Ethernet? If USB, make sure you are connecting to the proper USB port; some have a USB connector for USB flash drives and another for USB to computer. More information would be helpful!
Laser Brand?
Controller?
Connection method?

Laser is a Boss LS 1420, connected via usb to iMac. Usb goes from iMac to a usb hub which splits to laser and camera. Everything was working on my PC for the last two years and we are switching to Macs. Is my Mac to old?

LightBurn will run on Windows 7.0 or later, 32 or 64 bit, MacOS 10.11 or later, or 64 bit Linux. LightBurn does not require a powerful computer for most work, though if your designs contain a lot of images, more memory is helpful.

Try connecting with a different USB port, and/or power cycling the computer. The FTDI driver for Mac has been known to conflict with Apple’s own internal virtual serial port driver, and it can end up locking out the port.

Additionally, how long is the total USB run? Is your USB hub a powered USB connection? The maximum in-spec length for USB cables is 5 meters (16.4 feet) without an extension. If you need to go longer you can purchase an amplified cable which is basically a single-port USB hub that repeats the signal. Also, double-check that you are plugged into the correct USB port on the laser.

I will try the reset. I have already tried power cycling and switching usb ports. The USB from the computer to the hub is 6’, the hub is powered, and the cable going from the hub to the laser is 6’.

When I try to install the FTDI driver 2.4.2 I get a warning message the “The following disk images couldn’t be opened” with a reason of “no mountable file systems”.

I did a little more checking and tried running the FTDI driver through terminal using hdiutil. It returned the following:
" Mounting…
2020-03-05 15:24:44.819 diskimages-helper[492:10014] -remountReturningDictionary: detaching because no mountable filesystems.
Attaching…
Error 112 (no mountable file systems).
Finishing…"

From what I can find my mac is to old for the FTDI driver due to macOS Sierra 10.12 and earlier is not being able to mount the new Apple File System (APFS). My Mac can only go to macOS X 10.11.6 Is there a work around?

It might be simpler to switch to Ethernet - You can probably run a cable directly from the Mac to the laser, or from the Mac to a router, and then from the router to the laser. The setup isn’t terribly hard, especially if you’re not scared of the command line.

It has the nice side benefit of being about 2x faster, too.

Yeah I was just thinking that. My other laser is on cat5. I’ll give that a shot in the morning. Hopefully the camera will still work via usb. Lol

Well I just got it working. Ended up using FTDI 2.2.18 which works on my Mac. We will see how it actually runs though. But it is talking back and forth so far!

I’ve been running LightBurn via USB on an old Mac Pro with Mac OS X 10.11 for almost two years now. It works well and is a great use for an old Mac.