Machine ignores "optimize Z moves" setting

Hey, y’all. Just installed a motorized Z with a focus sensor (pen style) and while everything is working great, the machine seems to ignore the optimize Z moves setting and goes to zero between each cut at different heights. I have tried turning on/off both optimize and relative moves for the Z, but nothing changes. Is this a bug, or am I missing something?
I have a 6442S-B (EC) controller in that machine.

Thank you for reporting these observations. When back in the shop, I will run some tests to see if I can reproduce, but have not seen this before. What version of LightBurn, and what OS are you using?

Hey, Rick
The LB version is 0.9.23, I run it on a W10 pc (kept up to date).
I used the current controller in a K40 with a Z bed without any problems. Now it is in a new 50W laser, I did update LB a couple of times before setting up the autofocus last night.

Sorry, but not following here. What is this “current controller”? Is this the stock M2 Nano board that came with the K40? What is “it”, that is “now in a new 50W laser”? Can you please rephrase this?

I’ve had this Ruida 644 controller in a K40 with a LightObject Z bed. About a month ago I’ve purchased a new 50w machine and replaced the knockoff controller that came with that laser with the official Ruida controller that I had in the K40.
Basically this Ruida controller was in a k40 first and working properly, then I put it in the new machine.
I ordered an autofocus kit with the new laser, but had to wait for some extra parts to come in, which took about a month. In that time one, or two LB updates rolled out, which makes me believe that it is a possible software bug.

You can help us test this theory :wink: , if you are willing, roll back to a version known to work for you previously and see if the issue is resolved. If so, that would be a strong indication of a bug.

Do I need to uninstall my current version, or can I just install it over just like an update?

You should be safe, but… Personally, I would remove any possibility I might encounter an issue to know what my baseline test should return.

So I’ve just installed a 9.21 version on my work Mac laptop and unfortunately the same thing is happening. Any idea why else this would be happening? I will try an even older version tomorrow on the Windows computer.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.