MacOS issue with 0.9.21 and Ruida

I have a ruida controller and am running Mac OS 11.2.3 and when I try to start a burn the laser does not move or fire the run time does start counting on the ruida when I hit the stop it will move back home (if the laser is not home) and double beep like normal I can frame and move the laser around with it just won’t burn anything I reinstalled 0.9.20 and it works just fine (I have both versions installed currently but nothing I do will get .21 to fire)

Are you connecting with USB? If so, can you try this driver?

Ruida with USB on Mac has always been a crap shoot because there is a driver conflict between a driver included by MacOS and the one that Ruida uses to communicate.

Mar19-14:08 New Problem!
Laser stops after certain time when engraving image - no solution found yet!
So many waste of material for trials - it’s really bad this issue, because it can’t be only tested with certain time of engraving.

Mar19-13:50 Update!
I mentioned that I installed the FTDI USB Driver, this is correct, but I installed again the driver you offered in Forum. Not sure if this is a different FTDI USB Driver, after the install the issue when I opened Lightburn that I need to repeat the first command sent to the Laser is solved, but the problem that the Laser stopped in the process still exist- Many Thanks to the Lightburn Team and the Forum.

same problem here - now I sitting in my workshop and thinking what to do - 0.9.21 is not working correctly and only printing vector lines - it stops when it come to printing image. MAC OS Sierra - RUIDA 6445 - 1060 W2 Laser and have the FTDI USB driver installed on Mac. Guess I end up to install the old version. Will look now for the old version, unfortunately I choose the option to delete during install - Any solutions! Greetings - Wolf

same here, Mac OS and RUIDA6445G laser suddenly stop in process during image engraving with V-9.21.
I took some time to understand the problem, but every testing is very time consuming because mostly the laser stops shortly before ending a bigger job. So I need to let the laser run a while, at least 10 min.

I reinstalled the previous version 9.20 and there is no problem, the problem exists only for the Version 9.21.

Earlier this morning the new Version 9.21 stops already before even starting engraving an image, then I also reinstalled earlier this morning the FTDI-USB driver for Mac, that I installed half year ago to get Lightburn to run that time - this improved at least that the image starts to print in V9.21, with V9.20 I had no problem at all.
Here the link for the FTDIUSB Driver: (I took this one from the Forum to reinstall)

I also noticed that Lightburn is using a new file format in V9.21, called *.lbr2 - so I saved my old Lightburn file in the new format and tried to use the laser that way. Not sure it works or have any influence to make this new Version from Lightburn run, because I just used a small data file, which came out fine.
I will use a bigger file later on to test.

I really like the new functions in Lightburn’s update, hope someone find a solution to this problem, which works consistently.

Anyway; till now I’m uncertain and afraid to put a big plate of expensive acrylic in my machine, because the Lightburn might stop working in process.

Can we use only *.lbr2 files with V-0.9.21 to avoid a stop in process during engraving. Could this be possible?
This means if I’m using V 9.21 it’s mandatory to save the data in the new format “lbr2” to avoid machine errors?

Because in some answers was mentioned that the USB connection for MAC might be a problem. If I would save my data on an USB stick, can I avoid the problem?
If not - it is surely a problem of the V-9-21 - isn’t it?

Dear Lightburn team could you answer me if this is this correct ?

Same thing here .21 after installing the driver will run for a while then stop and even hitting pause and start won’t kick it back on same file in .20 no issues

The provided patch fixed the problem for me. Thanks for making it happen so quickly!!

yes - same to me - I can not make the process continue to run - I need a complete restart - guess need to ordere more material - at least the seller for my acrylic will be happy :slight_smile:

Thanks Henry for the input - could you please tell me where I can find the patch to resolve this issue?

I spoke too soon… The driver seemed to have worked for 3 files I ran, then on the 4th it stopped cutting (toward the end of the cut luckily). Before I installed it, my cut was stopping on the 4th out of 5th pass. On one project, the cut took a random turn and cut through my artwork.

The one I used was the one you mentioned above.

Yes - same to me - mostly at the end for bigger files.
The USB Driver had some kind of improvement, but did not resolve the problem!

Same the theory about using a USB stick instead of USB line to avoid the Driver problem with cable connection. Didn’t tried it yet, because every trial is so time consuming to wait for the end of a >10min. job to be processed. Sometimes the error start after 2nd trial or 3rd trial.

This Version 0.9.21 must have some kind of coding which doesn’t work with RUIDA.
Maybe the compiler to produce the data files for RUIDA Controller need to be modified for our constellation MAC-RUIDA. Guess only the Lightburn Team can do it :slight_smile:

Anyone with this issue, please tell me which controller and model number you are using.

The project file format has nothing to do with why your files are stopping. Try using ‘Send’ to send the file to the machine instead of ‘Start’ and see if that works.

I am using the RDworks V8 D Controller.

I will try using send instead of start and see if that makes a difference.

I need to know if it is a 6442, 6445, 5121, etc… Model number, not “Ruida”. :slight_smile:

Pardon my ignorance! Model is 644XG.

On the controller it says Ruida 6442G-B both versions of lightburn just says 644xg

I believe I’ve identified the cause. Can users with the Ruida connection issue please try this version and let me know if this solves you issue?


Thanks so much for your support - never expected such immediate response!
You have an amazing team at Lightburn!
Now it‘s midnight over here, so I will try tomorrow and report back to you.
Wish you a nice weekend!
Ruida 6445G

Dear Lightburn Team,
here my report to the modified version as promised.

I installed your modified Version 0.9.21-2 and did dome trials to see if this update runs more stable, but unfortunately I ran into the same problem that my laser suddenly stop working.
I used a job with an image and vector graphics, total time according Lightburn 17:11 and the laser stopped at 15:05.

The old version 0.9.20 works without any problems!

I made a small video to show the problem in action, the laser sound like it looses suddenly power on the stepper motor.
here is the link to the youtube video of the problem:

Thanks for your great support - I hope you will still work on this problem to resolve it!
Any new trials please let me know - I will test within 24h!

For now I will downgrade to 0.9.20

Ok, you have a 6445 controller, not a 6442, and so far that is one of the things that seems to be common among people with the issue. MacOS was one, 6445 controller is the other.