MacOS issue with 0.9.21 and Ruida

Thanks for your feedback,
What does your answer mean - Do you still try to find a solution?
With 0.9.20 I had no problem at all - obviously the new Update had some changes how to handle the controller.

e.g.: you mentioned that Ruida should have even fewer issues with connectivity:

TEMPORARY CONNECTIONS FOR DSP CONTROLLERS

Ruida, Trocen, and TopWisdom users should now have fewer issues with connectivity. LightBurn now connects to DSP controllers only when active. If you run multiple copies of LightBurn and have had issues sending to the laser from your 2nd copy, this fixes it.

However, would appreciate if you could look in to your controller connectivity improvements, if there any conflicts now with the 6445 controller.

Could you please try to find a fix for this issue.

Thanks and have a nice weekend!

For anyone having Ruida connection issues, please try one of these, and report back if it works for you.

Big Sur:
https://drive.google.com/file/d/1XvTlUMFzVkTOqEJ_SGnfDAfhR8yV--q2/view?usp=sharing

Mojave, Catalina, or older:
https://drive.google.com/file/d/19fZWYdAHbmxVabY4ExlgXiH2gI3wJx_B/view?usp=sharing

Win64:
https://drive.google.com/file/d/1Dg1JF2q78jU8IchmbLHByK1M18iPM7W4/view?usp=sharing

GOOD NEWS!
Thanks for offering a modified Lightburn version 9.21-3
I just made a trial with a 17min. job, including image, engraving, cutting.
The job runs smoothly to the end, without any problems, this never happened with the previous version.
I tried a second job, ca. 15min., also includes image, engraving, cutting, this job also runs to the end without problem.
I would say this version is running stable and can only say a BIG Thank You to the Lightburn team.

My workflow is as follows:
Design Laser models on iMac BigSur and save it in the cloud.
Then at the workshop, we have an old MacBook on the machine with OS 10.12.6 Sierra

Here again my system configuration on the 1060 laser for reference:
Ruida 6445, MacBookPro 10.12.6 Sierra, USB cable connection with FTDI driver from Lightburn Forum.

I used the following Download you offered for Mojave, Catalina or older!

https://drive.google.com/file/d/19fZWYdAHbmxVabY4ExlgXiH2gI3wJx_B/view?usp=sharing

THANK YOU for offering a stable version 0.9.21 !

Ok. The same issue here with lightburn ver. 0.9.22 and Ruida … Can not recognize the 6445G controller.
I already downloaded the above drivers to add Ruida manually but without any luck … couldn’t find the Ruida controller in my lightburn controller list .

Actually for me the connection problem is solved with Ver. 0.9.22
I’m using an old Mac book pro with Sierra and a Ruida 6445G.
Both are connected with USB cable.
But you need install the FTDIUSB driver you can find somewhere above mentioned and linked.
Under Devices in Lightburn you have only one choice for Ruida Controllers, just took that and connect.

Yes . i already installed the above drivers , but couldn’t find the Ruida controller in lightburn under devices . I’m using Mac Book Pro with Mojave.

Which license do you have? You will not see any of the DSP control systems LightBurn supports if you do not have the DSP License.

You can upgrade to unlock DSP support from our web store here: LightBurn Software - Upgrade from GCode to DSP license

Same for me as Rick showed on the screenshot.
I’m using the DSP version from Lightburn and simply choose „Ruida“ from the menu.
It’s included in the Lightburn DSP Version.