MacOS move buttons too small + set move limits

I’m new to Lightburn and have a quick question and what I’m thinking is a bug report.

The first issue is a minor bug. It is exactly the same as documented in this post. I just wanted to mention that it was affecting me as well. I found it does not occur on my MacBook Pro with Retina display, but it does happen on my Mac mini which does not use a high DPI display, just a standard 1080p display. It seems to occur when the low DPI display is the primary display for me. I tried setting the environmental variable as suggested to no avail. Although perhaps I did not do it correctly. I used the terminal command “enable QT_AUTO_SCREEN_SCALE_FACTOR=1” to set it temporarily to see if it worked. Hoping this is just a bug to be fixed. My temporary fix was to turn up the toolbar button size, but now the other buttons are too big.

The question I have is is there a way to set the limits on the move controls? It allows me to move past the 200mm build area. My only thought to limit that is with a hardware max limit switch, which the K40 does not have by default but I was just wondering if there was a way to set that in software for now?

Other than that I’ve had good luck figuring it out. I still have to figure out source for a bracket or shock for my door so I can install the Lightburn camera. I have gotten my cuts to look about the same as with K40 Whisperer now. K40 Whisperer on the left with the M2 Nano board and Lightburn on the right with the LaserBoard. I think the default Lightburn DPI is set lower than the 500 of K40 Whisperer and I just have to turn that up from 254 to get a higher quality burn.

Thanks for any suggestions or tips!!

~Ben

PS. Ignore the slight outline on the parrot on the right image, I had the power set way to low the first time and sanded it off to try again.

If you enable overscanning that outline won’t happen - it allows the controller to do most of the deceleration after the laser is off, so you don’t get a dense burn on the edges.

The MacOS button sizes issue should be fixed for the next release. We’re hoping to release it shortly.

For the jogging, if you use the ‘Click to position’ feature in LightBurn, it will never jog outside the bounds of the machine:
image

GRBL has functions that will prevent jogging out of bounds, but Smoothieware doesn’t do that. We could probably emulate that in the software, but honestly no one has ever asked before.

Thanks for the info on the bug fix and jog to position.

FYI, that outline was caused by the fact that I already burned on that piece of wood with the power so low it barley marked it. I sanded the most of the burn off it and did it again with more power but didn’t get it lined up right when I put it back in. The outline is just what was left after I sanded the prior job off.

The out of bounds question just seemed like a nice safety to have, but not necessary. I would prefer to have the limits in the firmware anyways but couldn’t find a way to do so yet. I’ll probably just have to install max limit switches.

I’ve discussed with the other dev, and we’re already doing 90% of the work required to add limits to the jog. We query the machine position before a jog so we can update the ‘Current Position’ value to the new location, so we can just clamp the move to the known machine size. Should be an easy change, and worth adding.

Thanks for considering my suggestion. I’ve been looking into the soft endpoint options in smoothieware and they aren’t great. Either halt the machine entirely when you hit it, or ignore any input that goes in the wrong direction past the limit which has its on consequences. It could throw the software off thinking it’s somewhere else because the machine accepts and ignores the input past the limit. Ideally the firmware would accept the input, jog back 1mm once hitting the limit like a bounching ball, and tell the software where its at and not to try and go further or the result will be the same bounce back. Limiting it in Lightburn seems like it would be much more reliable and safe. It’s not that I expect to push it past its end points, but a slip of the mouse clicking the wrong jog button could do that if one wasn’t paying attention.

I’ve only been playing with the k40 for a few weeks now and it’s my first laser cutter. I have no prior experience with CNC, or related tech so it’s all new to me. As such some of my ideas for how things work may be off. Feel free to correct me if I make a statement that doesn’t make sense. I’ve been trying to learn this stuff on the fly and am currently working on setting up a light object z table which should be interesting to figure out.